EM TuningAH Fabrications
Results 1 to 8 of 8
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Mar 2011
    Posts
    77

    What Iridium Plugs??

    I've had a Revo map on my MY11 S3 and found a hesitation between 3k and 4k revs. Audi replaced the plugs and for the 1st month it was fine, now the problem seems to be back.

    From what I can understand the standard plugs aren't up to the job. What are the best plugs to buy?

    Cheers, Ramos

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    warren_S3's Avatar
    Moderator

    Status
    Online
    Join Date
    Oct 2007
    Posts
    6,067
    I'd suggest if your plugs are failing within one month you have a bigger probelm somewhere than just plugs.

    What are they looking like when you pull them out?
    Audi S3 Panther Black [2011] Build Thread
    Mods: Revo Stg2, Blueflame TBE, Eibach Pro springs, R8 oil cap

    On order: Audi S5 3.0V6T Coupe Black Edition, Phantom Black [Due 26 May 2014]

    Planned Mods: Revo Stg1+ with DSG map, Revo CAI, custom exhaust, H&R Trax spacers, EM Tuning LED interior lights, R8 oil cap, Porsche coolant & brake fluid cap

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Mar 2011
    Posts
    77
    Quote Originally Posted by warren_cox View Post
    I'd suggest if your plugs are failing within one month you have a bigger probelm somewhere than just plugs.

    What are they looking like when you pull them out?
    Hi Warren,

    I must admit i'm not a very hands on type person when it comes to cars some haven't checked. However I read so many threads regarding upgrading the plugs I thought i'd give it a go, and if it carries on like you rightly say then it must be something else i.e. coil packs or MAF sensor?

    Just ordered BKR7EIX spark plugs which again from what a read are meant to be the best?

    Ramos

  5. #4
    warren_S3's Avatar
    Moderator

    Status
    Online
    Join Date
    Oct 2007
    Posts
    6,067
    Certainly seem to be a very good option of mapped cars, and a perfectly acceptable alternative to the Denso plugs.

    I'd get a feeler gauge and set them when they arrive just incase they aren't gapped exactly to the car.

    Cars that do a lot of short journeys seem to suffer more veneering on the ceramic insulator, which in turn affects running as the plug can't work efficiently. Using fuel system cleaners made no difference for me, so I've just changed plugs every 10k (instead of the OEM recommendation of 60k!).

    When you push the car harder you expect some side effects, but I'm not sure the FSi system works that well when cold, especially given some of the deposits being seen in cars when engines are opened up.
    Audi S3 Panther Black [2011] Build Thread
    Mods: Revo Stg2, Blueflame TBE, Eibach Pro springs, R8 oil cap

    On order: Audi S5 3.0V6T Coupe Black Edition, Phantom Black [Due 26 May 2014]

    Planned Mods: Revo Stg1+ with DSG map, Revo CAI, custom exhaust, H&R Trax spacers, EM Tuning LED interior lights, R8 oil cap, Porsche coolant & brake fluid cap

  6. #5
    Cheese's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Surrey
    Posts
    180
    Quote Originally Posted by ramos333 View Post
    I've had a Revo map on my MY11 S3 and found a hesitation between 3k and 4k revs. Audi replaced the plugs and for the 1st month it was fine, now the problem seems to be back.

    From what I can understand the standard plugs aren't up to the job. What are the best plugs to buy?

    Cheers, Ramos
    I seem to be having a very similar problem to the one you describe - different map though - AmD Stage2 with a Milltek TBE. Haven't tried changing anything yet though...let me know how you get on.
    Last edited by Cheese; 11th September 2011 at 00:02.
    Audi S3 8P3 | Milltek TBE | AmD Stage2 | H&R ARBs | Bilstein B14 Coilovers | Sachs Racing Clutch




  7. #6
    paddy's Avatar
    Audi=No fault code, no idea

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Surrey
    Posts
    5,135
    Sounds like the problem i had when revo agent loaded the wrong map. Check you have the MY11 updated map, that sorted mine. I think you need V10 for My11, it just hesitates at a constant 3-4k rpm if it has V9 installed. MY11 ECU is not the same as MY10. I have had no issues with hesitation or plugs since i got the right map installed

    EDIT
    Extract from e-mail from REVO
    ------------------------

    As for your vehicle it sounds like your dealer has accidentally installed a earlier version of software that had some compatibility issues with revised firmware from the factory, this was all fixed in v10 of the 8P0 907 115AP S0010 code so this is a quick and easy fix for you!
    ------------------------
    HTH
    Last edited by paddy; 10th September 2011 at 20:49.
    Ibis white Revo S3 and now matching Vivaro LWB HR 2900 :-)

    Many people are alive because its illegal to shoot them.

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    26
    Mine is doing exactly the same but at this point has no map!

    Standard 60 plate S3 DSG, hesitation when accelerating between 3-4k RPM, Audi had it and said no problems but its doing it now more than ever!

    I'm gonna take it back and insist they do something more than plugging it in and taking it for a 5 min drive!

  9. #8
    paddy's Avatar
    Audi=No fault code, no idea

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Surrey
    Posts
    5,135
    Read my avatar.......Audi=No fault code, no idea
    Ibis white Revo S3 and now matching Vivaro LWB HR 2900 :-)

    Many people are alive because its illegal to shoot them.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO