Chris NottMonster Motorsport
Results 1 to 7 of 7
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    5

    Audi A3 Turbo problems

    Hello Guys,

    Sorry English is not my first language so if spelling mistakes please ignoreJ

    I Have an Audi A3 56, works fine driving through town centre, but when on motorway driving 70 or above – all of sudden loses power and wont go past 60mph. I have taken to a mechanic was plugged it on computer twice and no issues there. Doesn’t show an issue regarding turbo problems or any other related issues, someone today mentioned it that the mechanic might of not had the latest software to diagnose faults could that be the case or can anyone suggest what I might need to do next.

    Regards,

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Apr 2011
    Posts
    35
    sounds like either sticky vanes, or leak in boost hoses, firstly what engine? petrol or diesel? plus maybe engine code too may help people here diagnose

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    5
    Quote Originally Posted by n25gabe View Post
    sounds like either sticky vanes, or leak in boost hoses, firstly what engine? petrol or diesel? plus maybe engine code too may help people here diagnose
    Sorry for the late replay. my car is Audi A3 1.9 TDI on 56 Plate, i have no idea were i can find my engine code. i have taken my car to another mechanic and pluged into a computer he seems to think it could be this i have no idea what its called so i am going to attach some pictures.




  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    5
    anyone?

  6. #5
    Sheikh's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    Surrey
    Posts
    658
    Its an N75 valve, i was just told the same thing!

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    5
    Quote Originally Posted by Zo View Post
    Its an N75 valve, i was just told the same thing!
    Thank you for the replay, have you fixed yours Zo?

  8. #7
    Sheikh's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Aug 2011
    Location
    Surrey
    Posts
    658
    Quote Originally Posted by Faton Salihu View Post
    Thank you for the replay, have you fixed yours Zo?
    Not yet mate, im gonna go to audi tomorrow and find out how much the part is. I'm thinking of doing the o-ring seals at the same time aswell as the innotec turbo cleaner. Hopefully that should sort out the overboost... if not i guess im looking at a new/reconditioned turbo.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO