EM TuningChris Nott
Results 1 to 5 of 5
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2011
    Location
    Glasgow, Scotland
    Posts
    3

    8P Regular warning lights - ABS / Traction Control / Headlight range defective - HELP

    Hello,

    I've got a 2004 2.0 TDI 140.

    Just been getting three warning lights, illuminating at the same time and ONLY once I have passed 65-70mph for roughly TEN seconds. The lights will not come on if I make a small, slow trip - and the car is mechanically smooth, nothing noticeable.

    The lights are the ABS, Traction control and on the centre display a "HEADLIGHT RANGE CONTROL DEFECTIVE" light - not even sure what that means, or if i have range control.

    ANYWAY - the peculiar thing is, 2 months ago my ECU was water-damaged and I was getting sporadic and irregular warning lights as things were shorting, there was no abs light at this time but the Traction and the Headlight range lights would come on, but the behaviour was entirely different.

    The ECU was replaced by Audi to the tune of 839 quid, so it's still under warranty. I was just posting to ask if anything similar had happened to anybody else, and what it could be?

    Car is mechanically operating perfectly, and when the ECU was damaged before the car was running fine as well. I think perhaps this could be another electrical fault.

    Thanks!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    2
    Hi,
    I have a 2005 Sportback 2.0 TDI 140

    Yesterday the same thing happened to me, but it happened after driving for about 5 minutes in city speeds. Before this the "lamp broken" light has been turned on now and then for several months. Now this light is always on and the lamp is off (broken ? I have time at the garage next week).

    Strange thing is that today, only the "lamp broken" light was on. The other three didn't come on !

    What is going on ? Did you get an explanation ?

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    2
    The cause of all lights (except for "lamp broken" ) coming on was a bad rotation sensor at left rear wheel. Changing sensor and wheel bearing took care of it.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2011
    Location
    Glasgow, Scotland
    Posts
    3
    Quote Originally Posted by penoll View Post
    The cause of all lights (except for "lamp broken" ) coming on was a bad rotation sensor at left rear wheel. Changing sensor and wheel bearing took care of it.
    Yes! Wheel bearing was what it was!

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2007
    Location
    London
    Posts
    3
    Quote Originally Posted by eeeyann View Post
    Yes! Wheel bearing was what it was!

    Ok I just have exactly the same problem on my 05 A3 3.2 Sportback.

    ABS,TC, and headlight range defective just came up. Also comes on all together when driving over 70mph.

    After turning car off and starting again all goes away until next time - any idea?

    How wheel bearing got something to do with the head lights range?? wheel sensor makes sense for ABS and TC lights but headlights range control?

    Please help!

 

 

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO