Sky InsuranceJMB Retrofits
Results 1 to 31 of 31
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aberdeen
    Posts
    119

    Stage 2+ S3 8P Misfire

    Hi All,

    My car has started misfiring as soon as it comes on boost, should i book the car in with Audi or take it back to Motorwerks in Aberdeen who have done the mods for me?

    Audi may not even look at it what with it being modified!!



    Possible causes?

    Have had a look through some threads..some say coilpacks, plugs, injectors...where to start lol

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Feb 2010
    Posts
    42
    Whos map is it?

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aberdeen
    Posts
    119
    Custom Code Stage 2+

  5. #4
    jungleman's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    SW London
    Posts
    2,051
    Chances are it's something like coil packs, spark plugs or the MAF thats failing.
    A quick test to help work out where it could be is to unplug the MAF, take it for a blast, if it still misfires then it's the plugs or coilpacks, if not then it's the MAF.
    Also what age is your s3 as there have been reported problems with the 8P3's with their exhaust valve springs being weak which audi know about (if it's still misfiring with the MAF unplugged)
    Factory: Phantom Black S3, BOSE, RNS-E, Adaptive Lights, Interior Lights, Auto Lights

    Added: Evolve Stage 2 Map, Evoms CAI, Milltek TBE Non-res With Special Tips Now At 360bhp & 385lb/ft, VWR 4 pots, H&R Springs, H&R Spacers, Sachs Clutch, '09 Rear Clusters, Pressed Metal Plates, TT Air Vents

    To Do list: Now that would be telling




    PM me for Weitec & KW coilovers

  6. #5
    Moderator

    Status
    Offline
    Join Date
    Oct 2003
    Location
    South Wales
    Posts
    2,942
    Mine turned out to be a faulty injector.

    Can you get access to vagcom and monitor the cylinders for misfires?

    It would be good to find out if you are misfiring on one cylinder or all?
    Dolphin Grey Audi S3 8P

  7. #6
    4th Gear

    Status
    Offline
    Join Date
    Oct 2008
    Posts
    888
    Do you have a TBE?

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aberdeen
    Posts
    119
    yes TBE millte resonated, autotech fuel pump + dbilas

  9. #8
    4th Gear

    Status
    Offline
    Join Date
    Oct 2008
    Posts
    888
    l would say plugs and coils first. You can get audi to do the coils under warranty. Hopefully its not the valve springs. Audi havent claimed them as a fault yet. Not heard anything about the MAF doing this. But coils and plugs are the cheapest option.

  10. #9
    jungleman's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    SW London
    Posts
    2,051
    The MAF can cause problems... I know this as that's what was causing the misfire on mine, was misfiring like a pig, cleaned the MAF, problem gone.
    Factory: Phantom Black S3, BOSE, RNS-E, Adaptive Lights, Interior Lights, Auto Lights

    Added: Evolve Stage 2 Map, Evoms CAI, Milltek TBE Non-res With Special Tips Now At 360bhp & 385lb/ft, VWR 4 pots, H&R Springs, H&R Spacers, Sachs Clutch, '09 Rear Clusters, Pressed Metal Plates, TT Air Vents

    To Do list: Now that would be telling




    PM me for Weitec & KW coilovers

  11. #10
    akash_sky1's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Glasgow (Sheffield occas.)
    Posts
    1,209
    Injectors are the other but much less common cause, Steve Jnr of Statller is rebuilding an S3 motor with a holed piston, ran a a GIAC stage 2+ equivalent map with missfire, owner thought it was a minor, overheated and holed a piston due to failed injector!
    A3 2.0TFSI quattro Sportback Lava Grey | | GIAC K03 Extreme Map | Autotech HPFP | RS4 Fuel Regulator | Neuspeed P-Flo | BSH PCV Fix | MV Sport DP | S3 Intake Cam | 285 BHP & 320 lb Ft Torque
    Votex Kit | TD Pro race 1.2 | Schwarze Audi Rings | Alu Rails | Sachs Clutch | H & R Now gone. Current- A5 Cab 2012


  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aberdeen
    Posts
    119
    Apparently, there were misfires on cylinders 1 & 3 so the coilpacks have been replaced. I have not had the oppurtunity to properly test yet but will on the way home from work...re-fuelled at Shell Garage...wait for it...

    77...omg!

  13. #12
    Boydie's Avatar
    Boycie

    Status
    Offline
    Join Date
    Dec 2006
    Location
    Greenisland, Co.Antrim
    Posts
    4,814
    Anyone with the injector fault have the codes come up on vagcom?

  14. #13
    Moderator

    Status
    Offline
    Join Date
    Oct 2003
    Location
    South Wales
    Posts
    2,942
    Quote Originally Posted by Boydie View Post
    Anyone with the injector fault have the codes come up on vagcom?
    Mine showed no codes that were specific to the injector. Only codes showing the misfire on the particular cylinder.

    If you are only getting the fault on 1 cylinder and u have replaced the coil and plug, I would try the injector next.

    Mine is now running spot on since it was changed last week
    Dolphin Grey Audi S3 8P

  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2007
    Posts
    22
    I had this after Revo stage 1. After heaps of coil packs and injectors Audi replaced my valve springs under warranty. Problem solved for me

  16. #15
    S.
    S.'s Avatar
    5th Gear

    Status
    Offline
    Join Date
    Mar 2009
    Location
    N/A
    Posts
    1,422
    go for colder spark plugs. bet old ones are bad.
    s3 Ibis White ... Build Thread

    / Black Grill / FbMfSw / Sunroof / Hill Hold / Armrest / Black Leather-Alcantara interior / Rear Parking Sensors / Heated Seats / Folding Mirrors / Cruise / Rns-e mk2 // ttrs-Brembo Brakes / 12mm spacers / Forge Short + Side Shift / 42dd's / ITG CAI / GfB DV+ / Forge Catch Can / Milltek TBE / Forge Twin IC/ Autotech HpFp / H&R ARB's / WALK / KW v3's / RS4 fpr / Loba&Sachs clutch / Revo Stage 2+ / ...


  17. #16
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aberdeen
    Posts
    119
    Car is still running like a bag of bloody nails....aarrrghhhh!

    Ok, its not that bad but still misfiring...

    Back to the garage!

  18. #17
    Neutral

    Status
    Offline
    Join Date
    Dec 2010
    Posts
    62
    have you tried disconnecting the maf sensor and seeing if it still missfires?

  19. #18
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aberdeen
    Posts
    119
    Where is the MAF sensor....i did take a look but couldnt see it!

    Apologies


  20. #19
    jungleman's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    SW London
    Posts
    2,051
    Quote Originally Posted by Dazzeroo View Post
    Where is the MAF sensor....i did take a look but couldnt see it!

    Apologies


    haha its pretty easy to find, if you look at your CAI its the bit that sticks out towards where it turns down towards the turbo inlet pipe. just unclip it and take for a blast and see what happens

    edit:-
    this may help

    Last edited by jungleman; 27th April 2011 at 13:23.
    Factory: Phantom Black S3, BOSE, RNS-E, Adaptive Lights, Interior Lights, Auto Lights

    Added: Evolve Stage 2 Map, Evoms CAI, Milltek TBE Non-res With Special Tips Now At 360bhp & 385lb/ft, VWR 4 pots, H&R Springs, H&R Spacers, Sachs Clutch, '09 Rear Clusters, Pressed Metal Plates, TT Air Vents

    To Do list: Now that would be telling




    PM me for Weitec & KW coilovers

  21. #20
    S3RYE's Avatar
    Interior Next!!

    Status
    Offline
    Join Date
    Apr 2009
    Location
    London/Essex
    Posts
    3,456
    Quote Originally Posted by Marc_86 View Post
    I had this after Revo stage 1. After heaps of coil packs and injectors Audi replaced my valve springs under warranty. Problem solved for me
    what Audi dealer did you use mate?
    Gone but not forgotten......
    S
    3 - Phantom Black - Black Optics - Most Extras

    Mods: Revo Stage 2+ - 18" BBS ch/Michelin PS2 - Recaro OEM Buckets - Milltek TBE NonRes/Sports Cat - Evoms Intake - APR hpfp - H&R Springs/ARBS F&R - Sachs Clutch/Luk DMF - AP Racing 6 Pot BBK - 10mm Spacers - Black Rings
    Mods To Do: Full Retrim - MY11 RNSe - Coilovers- Plenty Carbon




  22. #21
    Paullie's Avatar
    Banana Menace!

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Aberdeenshire
    Posts
    2,088
    Any joy with this yet, Dazzeroo? Did you contact Motorwerkz about the probs you're having? I'd have given them the opportunity to sort it out for you first. Hope it gets fixed for you soon, Bud.

    Paulie.
    MY10 S3 8P3 S-TRONIC, IMOLA YELLOW
    SHARK PERFORMANCE STAGE 2
    - GONE BUT NOT FORGOTTEN!

  23. #22
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aberdeen
    Posts
    119
    Quote Originally Posted by PaulieMB View Post
    Any joy with this yet, Dazzeroo? Did you contact Motorwerkz about the probs you're having? I'd have given them the opportunity to sort it out for you first. Hope it gets fixed for you soon, Bud.

    Paulie.
    I'll unclip the MAF sensor at lunch today and take it for a blast. Motorwerks are a good bunch of blokes and have already looked at the car and changed out two of the coil packs but the misfire remains! I'll let you all know how i get on with the MAF sensor...fingers crossed!

  24. #23
    jungleman's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    SW London
    Posts
    2,051
    fingers crossed!
    Factory: Phantom Black S3, BOSE, RNS-E, Adaptive Lights, Interior Lights, Auto Lights

    Added: Evolve Stage 2 Map, Evoms CAI, Milltek TBE Non-res With Special Tips Now At 360bhp & 385lb/ft, VWR 4 pots, H&R Springs, H&R Spacers, Sachs Clutch, '09 Rear Clusters, Pressed Metal Plates, TT Air Vents

    To Do list: Now that would be telling




    PM me for Weitec & KW coilovers

  25. #24
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aberdeen
    Posts
    119
    Hey presto, removed the MAF sensor and the car runs amazing. I actually cannot believe the difference, it feels like its been remapped again lol!

    Presumably then, the MAF itself goosed?

    Perhaps there was nothing wrong with the coil packs which were replaced after all?

  26. #25
    jungleman's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    SW London
    Posts
    2,051
    result!
    yea sounds like your MAF is a bit FUBAR get a new one in there and you should be good to roll! think they are about the £137 mark (not cheap!)
    Factory: Phantom Black S3, BOSE, RNS-E, Adaptive Lights, Interior Lights, Auto Lights

    Added: Evolve Stage 2 Map, Evoms CAI, Milltek TBE Non-res With Special Tips Now At 360bhp & 385lb/ft, VWR 4 pots, H&R Springs, H&R Spacers, Sachs Clutch, '09 Rear Clusters, Pressed Metal Plates, TT Air Vents

    To Do list: Now that would be telling




    PM me for Weitec & KW coilovers

  27. #26
    Paullie's Avatar
    Banana Menace!

    Status
    Offline
    Join Date
    Jan 2011
    Location
    Aberdeenshire
    Posts
    2,088
    Nice one! We're so lucky to have the benefit of the vast technical knowledge the guys on here have. It may not be the cheapest of fixes, having to buy a new MAF and all, but it would be a lot more expensive to get Audi to diagnose and fix the fault. Well done Jungleman and glad it's all better, Dazzeroo

    Paula x
    MY10 S3 8P3 S-TRONIC, IMOLA YELLOW
    SHARK PERFORMANCE STAGE 2
    - GONE BUT NOT FORGOTTEN!

  28. #27
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aberdeen
    Posts
    119
    Yes thanks Jungleman, you always were one of the boys!



    One last question where is the MAF located and can I change myself?!!!

    Thanks

  29. #28
    jungleman's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    SW London
    Posts
    2,051
    haha cheers mate

    the MAF is the entire section that the plug was clipped in to, its held in by 2 torx screws, so as long as you have a torx set you can whip it out yourself and change it, its 5 min job tops

    looks like this once youve pulled it out of your CAI

    http://www.atpturbo.com/mm5/graphics...S-ELEM_450.jpg


    also with the new MAF dont scrimp, get it from a reputable source (NO EBAY lol) as there are lots of knockoff ones kicking around your be left in the same boat a couple months down the line
    Factory: Phantom Black S3, BOSE, RNS-E, Adaptive Lights, Interior Lights, Auto Lights

    Added: Evolve Stage 2 Map, Evoms CAI, Milltek TBE Non-res With Special Tips Now At 360bhp & 385lb/ft, VWR 4 pots, H&R Springs, H&R Spacers, Sachs Clutch, '09 Rear Clusters, Pressed Metal Plates, TT Air Vents

    To Do list: Now that would be telling




    PM me for Weitec & KW coilovers

  30. #29
    1st Gear

    Status
    Offline
    Join Date
    Aug 2007
    Location
    Aberdeen
    Posts
    119
    Nice one, phoned Audi and its ~£130 so will get it done next week...thanks again Jungleman


  31. #30
    jungleman's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    SW London
    Posts
    2,051
    no worries mate
    Factory: Phantom Black S3, BOSE, RNS-E, Adaptive Lights, Interior Lights, Auto Lights

    Added: Evolve Stage 2 Map, Evoms CAI, Milltek TBE Non-res With Special Tips Now At 360bhp & 385lb/ft, VWR 4 pots, H&R Springs, H&R Spacers, Sachs Clutch, '09 Rear Clusters, Pressed Metal Plates, TT Air Vents

    To Do list: Now that would be telling




    PM me for Weitec & KW coilovers

  32. #31
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2011
    Posts
    11
    Quote Originally Posted by Dazzeroo View Post
    Nice one, phoned Audi and its ~£130 so will get it done next week...thanks again Jungleman
    Did you change the MAF at last, was it determined to be the real issue?

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO