Volks AutosMonster Motorsport
Results 1 to 6 of 6
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Wolverhampton
    Posts
    125

    P0180 Dashboard lit up like a christmas tree!!

    Hi guys im new to the forum, i have been scanning it like theres no tomorrow, all week about retro fitting components.

    Il start by saying im 19, a technician for subaru and i bought my beautiful audi a3, 2.0tdi quattro hatchback.

    The guy who i had it off had got it remapped and had a panel filter put on. Also the common rear wiper motor doesnt work!

    Now, i was driving my car home yesterday and just as i was passing where i work my 'esp' and 'abs' lights came on. Damn!

    Shortly followed by a fluctuaiting rev and speedo counter, followed by every single light flashing on the dashboard!

    I pulled over at work and switched off and on the car and the lights were still on. Drove home, switched the car off and on and then the immobiliser cut in after 1 second!

    I started it this morning sweet as a nut and only the esp and abs light on the dash. Plugged my scanner in and found the fault codes as follows :

    ERRORS PRESENT SINCE THE BEGINNING OF COMMUNICATION
    P0180 Data Bus control missing communication from combined tool 018058 MEM
    P0180 Bus/data transmission- message from ECU missing 018045 MEM
    P0180 Bus/data transmission-message from A/C system ECU missing 018043 MEM
    P0180 Data Bus control defective 018056 MEM
    P0180 Bus/data transmission-message from Airbag ECU missing 018044 MEM
    P0180 Data Bus control missing communication from ABS ecu 018057 MEM

    I took it for a short run and by the end of my drive it was all lit up again!

    P0180 is the single code staying on and now i am having difficulty connecting with any systems, i.e it is loosing connection when connecting. I have tested dashboard actuations and all is good. My initial thought is the main ECU?

    I jet washed my engine off about a week ago and it has been fine until now. Anybody think it could be the ecu?

    Thanks guys n girls!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    You need to scan it with VCDS to get the proper fault codes however here is the Ross Tech fault code diagnosis.

    Seems like the jet wash may not have helped !! :-

    16564/P0180 - Ross-Tech Wiki

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Wolverhampton
    Posts
    125
    Cheers mike, i just took the panel off to look at the ecu and it is pretty loose, so i am guessing that it wasnt properly put back when they remapped it! It wouldnt start half an hour ago again, now since i have tried removing the ecu it will start! Headache or what?

    Im going to try and figure out how to remove the ecu then just try another i think :/

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Wolverhampton
    Posts
    125
    Thought i would updater you guys. Took ecu out and found a bit of corrosion on the connections, cleaned them up, stripped ecu, cleaned it up, put it back together, (doesnt feel as quick :/) but all working well now touch wood! I took lots of photos through the process so if anybody thinks an ecu removal guide should be made, i will. Thanks!

  6. #5
    Khufu's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    West coast of Scotland
    Posts
    5,693
    Fingers crossed you got it sorted! Welcome to the forum, any reason why you bought an Audi & not a Subaru ;-)
    2003-2008 1998 Red A3 8L 1.8 Sport
    2008 -> 2003 Akoya Silver A3 8P1 2.0 FSi Sport

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    Mar 2011
    Location
    Wolverhampton
    Posts
    125
    Thanks Khufu! Yeah, well insurance is one, and subarus are cheap and tacky inside to be honest. The audis are just a different league in my opinion, solid and no road noise! although i wish it could have the reliability of a subaru!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO