Chris NottMonster Motorsport
Results 1 to 24 of 24
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14

    Fans run on 2004 TDi

    hello

    I have a problem whith my Audi a3 2.0 tdi 2004
    when I stard the engine after a few minutes or a minute some times the fans turn on even if the engine is cold.Every time the fans turn on the engine changes the working increaes form 900 rpm to 1000-1200rpm while the fans are working.After the fans stop the rpm goes down to 900rpm only if u give a little thrust .and also it throas a little white smoke behind.the mechanics sad that it was the engine ecu because in the diacnostic it apears Electronic load computer p1643.I changed the ecu and still the same problem apears.I need help ca anybody help me or point me what the problem might be>???

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    olliea3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2011
    Location
    lichfield ,staffordshire UK
    Posts
    215
    turn off your climate control ????

    ino it sounds daft but trust me , i always used to think , why is the fan on even on start up and its because my climate is always on , just try it mate

    A3 8p , 2.0 Tdi 140 , Bose , Symphony , Climate

    Mods = Gloss Black grilles , De-Wipered , De-Badged , MY11 Rear With Black Gloss Diffuser , TT vents , Coilovers , A4 Avant wheels

    To Come = More smoothing , Xenon , Rims

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    its not the climate controll i always keeping it of is winter now in my country even if the climate controll is off the fan turns on sometimes 4 or 5 timmes per 1 minute even .......

  5. #4
    paddy's Avatar
    Audi=No fault code, no idea

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Surrey
    Posts
    5,135
    Are you sure about that fault code ? what weere the first numbers ie: ?????/P1643

    That code is from a "Electric Load Controller" telling you there is another fault code in the "Electronic Control Module" as far as i can make out.

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    "electronic load computer" P1643 thats all the mechanic told me ..... what is the electronic controlle module is some kind of sensor or computer....
    they doubt was that the car is losing electronic power some times they checed the alternator power was good... the battery is new also,i have a doubt abaut the sensore of humidity measure the mechanic says not but tomorow i will sny way chsnged i will see if the problem still apears

  7. #6
    S3 MRU's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Luton, Bedfordshire
    Posts
    756
    My 2004 does this. Fans run alot faster when stationary when the climate controll is on . I thought this was normal
    Audi S3 8P2 Silver
    BI-Xenons - FBMFSW - Rain/Light Pack - Auto dim package - iPod Integration - 2011 Nav - Electric Folding Mirrors - Rear Park Sensors - Full Heated Leather - BOSE - Privacy Windows - 2011 Console Conversion - My11 Rear Lights - RevD Diverter - Forge DMV14T BOV - ITG Maxogen CAI - BBS CH 18s





  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    mayby iss normall i dont hsve that problem if u read above other threads u will see russo2k5

  9. #8
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    Paddy u think I should change 'electronic controlle module' It might be that can u tell me how can I changed and where is the position of that part in the car I mean location.

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    audi a3 2.0 tdi fans start even when the engine is cold also when the engine needs fan to start and every time they start increases rpm from 900 rpm to 1000-1100 rpm diagnostics give ;"" engine fault 18051 DTC MEMORY OF ELECTRIC LOAD CONTROLLER P1643
    CAN ANYBARY HELP ME WHITH THIS.......

  11. #10
    Neutral

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    41
    change your coolant temp sensor

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    I allready did still the same,,,,

  13. #12
    paddy's Avatar
    Audi=No fault code, no idea

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Surrey
    Posts
    5,135
    Follow this link

    Category:Fault Codes - Ross-Tech Wiki

    and click on 18051.
    The fault code 18051 is saying there is another fault code stored in the Elec control module. The module is fine but you need the garage to retrieve that second fault code.
    Print out the 18051 code page and take it to them so they can see.

  14. #13
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    I allready checed yesterday that web it tells good expleans the pro
    18051/P1643/005699 - Please check DTC Memory of Electric Load Controller

    Possible Causes


    • Fault Code stored in Central Electronic Control Module (J519/#09)
    Possible Solutions


    • Check Central Electronic Control Module (J519/#09) for Fault Codes
    Special Notes


    • This Fault Code is only a Note referring to relevant Fault Codes stored in another Control Module.
    • When found in 2.0l TFSI (AXX/BPY/BWA etc.), check Steering Wheel Electronics for Cruise Control related Fault Codes and general Cruise Control Functionality. See TPI 2017317 for Details.
    • BUT sholud I change a code whith some kind of computer or to changhe a part ????

  15. #14
    paddy's Avatar
    Audi=No fault code, no idea

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Surrey
    Posts
    5,135
    You need to get your garage to clear this code and run the car for a while and re check for new codes.

  16. #15
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    when the engine is runing normal the code doesnt apear after the fans start it apers this fault and while its runing the fans engine increases 900 rpm to 1100 rpm unable to clear the fault and code when the fans stops then u can cleare the error or fault code and doesnt apear untill the funs start working again

  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    Paddy I think u have an idea the cars problem is please help me I did all u said but the mechanics say is allreadyone everythik of than just in case i will try it by my self so to clear the fault code what I have to do for exp.:whith VAG I need to go OBD-II hen MOde 4 clear DTCs will I do any other problems or I need to do something else?
    Last edited by hekri; 28th February 2011 at 14:27.

  18. #17
    Dec
    2nd Gear

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Colchester, Essex, United Kingdom
    Posts
    318
    My 04 does it too, it annoyed me so just turned off climate control and opened the windows lol


    '04 A3 2.0 TDI.

  19. #18
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    its not the same ?/// dec is something else...........

  20. #19
    paddy's Avatar
    Audi=No fault code, no idea

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Surrey
    Posts
    5,135
    I dont think the engine revs increasing with the fan coming on is a problem. the re occurring fault code is odd. I am hoping NHN (Nige ) will happen by and maybe he can help you with the meaning of the fault code and your post 16

  21. #20
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    27,072
    Please check module 09 with vcds & see what faults are shown in there as J519 is the central electrics module.

    We need to see a scan of your cars modules, only show us the faulting modules logs, dont need to see any non faulting modules atm.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  22. #21
    Reverse Gear

    Status
    Offline
    Join Date
    Feb 2011
    Posts
    14
    the car is at the garage and they say there are no faults I wailting for them to se or the coils check an I will tell them to check Adress 09 for J519 if there is any faulty code and I will write to u back thanks once again Paddy and NHN>>>>>

  23. #22
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2012
    Posts
    4
    Hi
    have you been able to sort the issues ? Only I have exactly the same problem on my A3 tdi 140 2004.

  24. #23
    BBlackburn's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2011
    Location
    Epsom, surrey
    Posts
    395
    I'm having a similar issue when my car parked on the drive, the fans are running then stopping then running again. First time this has happened need a scan anyone near Epsom Surrey with vcds?
    SPEC: ebony pearl black ~ auto lights ~ auto wipers ~ half leather/suede interior ~ armrest ~ anti dazzle rear mirrior ~ coming home/ leaving home function.

    MODS: flat bottom steering wheel ~ bluetooth ~ cruise control ~ rns-e ~ MY09 rear lights ~ s3 pedals ~ s3 air vents ~ LED interior light pack ~ facelift buttons ~ dension ~ SDS ~ Aliminium inlays ~ full grille conversion.

    FUTURE MODS: lower ~ black edition rear ~ s-line/facelift front ~ black headlining ~ BBS CH-R or Speedlines.

  25. #24
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2012
    Posts
    4
    I have now believe I have solved my problem today,I have had the battery checked out after reading another post and believe it or not it was shafted which was causing the ecu to fault .i have now done 100 miles since changing the battery ,no fault codes ,no fans running and no increase in revs yippee .i hope this info helps others out there.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO