AH FabricationsJMB Retrofits
Results 1 to 2 of 2
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2009
    Posts
    4

    Question MAF/wiring CEL problem..but only with the bonnet shut?!!

    Dear all,

    Just stumbled upon what's been causing my CEL to come on...closing the bonnet! But how to fix it?

    Diagnostics showed an fault P0100 (MAF circuit problem). Problem is it's been intermitent and not very predicable so tried to see if it was the wiring from the MAF by wriggling the wire. Nothing. Levels didn't fluctuate from their ~3g/s at idle. So I shut my bonnet in mild disappointment and just by chance I looked over at the code-reader data to see the MAF readings shoot straight up to 655g/s and stay there, then back to normal, then back to 655g/s... you get the idea. Then the engine started to hunt and peak so something definately wrong.

    Opened the bonnet again, everything back to 3g/s, engine idles as normal. Shut it again and it goes full scale to 655g/s over and over again. Repeat as required.

    Possibles then:

    • Bonnet support arm pressing on the wiring when the bonnet is shut, causing a short circuit somewhere I guess, but it's not obvious where. Wiggling the wire doesn't seem to replicate problem.
    • Bonnet pressing down on the MAF itself? All seems solid enough.

    Any ideas? What's the going rate for either a) finding/repairing the break; or b) Replacing the MAF wiring from the MAF through to the bulkhead? (2007 2.0 TFSI by the way).

    ps. have had to replace both the MAF and the boost pressure valve recently in an effort to pin down this damn CEL fault (its clear now that the MAF fluctuations made the car overboost and hence trigger overpressure fault as well as a MAF circuit fault). Glad it's getting close to resolution though.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Khufu's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    West coast of Scotland
    Posts
    5,693
    Thats an odd one! I'd do as much investigation as possible even just to eliminate options as it could take a while to find = . I'd also take it to an auto electrician, not Audi. I will have a look under my bonnet & see how mine is layed out though its not a turbo version.
    2003-2008 1998 Red A3 8L 1.8 Sport
    2008 -> 2003 Akoya Silver A3 8P1 2.0 FSi Sport

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO