EM TuningJMB Retrofits
Results 1 to 15 of 15
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Staffs
    Posts
    33

    Hazard Warning Light On

    Guys,
    Just tried to fit an aftermarket stereo to a 2005 audi a3, its a rear amped non bose system, got all the correct autoleads to do the job, the stereo came and seemed to work fine, all though the rears were very low on sound, which seems to me the rear amp wasn't working, during this i noticed the hazard warning light was lit up, not flashing, just on all the time, even with the keys out, I also noticed the aircon system seem to fire up briefly and flickered all of the lights on the aircon system, so i took the battery off, and after putting it back on the aircon prob seemed to have stopped, but the hazard warning light was still lit, and when starting the car the eps and power steering warning lights are now lit, and to top it off I put the concert radio back in, which works, but now powers on with the ignition off which it never did before, so all of this after trying an aftermarket radio, wish I hadn't bothered.
    Hopefully get it on a vag machine in the week.

    Gaz

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    EPS and power steering lights will go off after you have driven a few hundred yards.

    This always happens after the battery has been disconnected.

    Sorry - can't help with the other problems.

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Staffs
    Posts
    33
    Nice one Mike will take it for a quick spin now.

    Gaz

  5. #4
    pi quattro's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Ayrshire
    Posts
    127
    When you lock car the hazard light stays on for a bit. Not sure why but it did on my last a3, like it's on a delay? Doesn't hazard light go off after a few minutes
    current -
    07 A3 TDI 170 quattro
    rnse,leather,auto lights & mirrors,bose,sunroof,xenons, etc

    previous-
    06 A3 2.0TDI sport quattro - rolled & gone
    06 A3 2.0T sportback dsg leather - gone
    06 A3 2.0TDI sport -gone
    01 1.8T GTI -gone
    01 A4 TDI 130 - gone

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Staffs
    Posts
    33
    The eps and Power steering light have now gone off after a quick spin, cheers Mike for that, and the hazard warning light goes off after a few minutes, never noticed that before to be honest, all I have to do now is found out why the aftermarket stereo caused the aircon panel to flicker and stay active after the key was out, thats what was making the hazard light stay on, that system was staying active for some reason, but a battery reset seems to have cured it.

    Gaz.

  7. #6
    FranA3's Avatar
    events moderator

    Status
    Offline
    Join Date
    Dec 2008
    Location
    south wales
    Posts
    7,124
    the hazzard light is perfectly normal mine does it too even after i lock the car so i wouldnt worry about it if yours didnt go off then i would be worryed lol
    ​She is back on the road yay!!

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    27
    Hi Guys, can I jump on this thread.

    I have an A3 TDi with totally standard Audi Stereo set-up, but my Hazard Light switch is remaining illuminated ALL the time. You lock the car and the switch remains illuminated all day and night... ....until the battery runs flat after a couple of days. I'm having to tricle charge the car every night at the moment!

  9. #8
    FranA3's Avatar
    events moderator

    Status
    Offline
    Join Date
    Dec 2008
    Location
    south wales
    Posts
    7,124
    dont know what could cause that they are supposed to turn off after a set amount of time
    ​She is back on the road yay!!

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    27
    I've removed the hazard switch, but now think this is the symptom rather than the cause.

    I've sat in the car and locked it, and although courtesy lights & dash mileage switch-off, after about 20 seconds there's an electrical buzzing from behind the dash suggestingn the car hasn't fully gone into 'sleep mode'.

    In addition to the hazard switch remaining constantly illuminated, I've also noticed the switch for 'weclome home' lights also has it's background illumination on all the time too.

    Having looked at the Haynes wiring diagram, I'm wondering if the problem is coming from the 'On-board supply control unit' via the 'Convenience CAN bus' - not really sure what I'm talking about here, but think for some reason this supply is remaining perminently live.

    Appreciate any thoughts on this!

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2011
    Posts
    27
    Solved it! Hope this will be useful to others: it was the 'welcome home' light-switch causing the problem.

    Disconnecting it cures all other problems, the Hazard Switch illumination turns off after the delay, and the nav/radio powers down.

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2011
    Posts
    1
    Where is the "welcome home" light switch located? I have a 2002 Audi A4 3.0L I'm not sure if it will cure my problems but I am have the same issues. My hazard switch stays illuminated and my Nav unit stays on as well.
    Last edited by FrankieJ05; 4th June 2011 at 03:24.

  13. #12
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    Frankie - this is the A3 8P forum. That means post 2003/4.

    Suggest you try the A4 section.

    The CH/LH switch on an A3 with auto-lights/wipers etc. is in the lighting control switch.

  14. #13
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2011
    Posts
    1
    Hi, I am having the same problem with my 2003 A3, the hazard warning light stays lit all the time. it doesn't however have "Welcome Home" lights, what else could this be? Any help would be greatly appreciated, I'm no electrician and the Audi is new to me!

  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2012
    Posts
    14
    pls where is this welcome home light located, cant seams to find it.. have got a 2004 audi a3 2.0 fsi

  16. #15
    Fossie

    Status
    Offline
    Join Date
    Jan 2010
    Location
    Rhubarb Triangle
    Posts
    3,969
    Quote Originally Posted by edirance View Post
    pls where is this welcome home light located, cant seams to find it.. have got a 2004 audi a3 2.0 fsi
    They're not actually talking about 'welcome home' light, it's actually the auto lights position on the lighting switch.

    If you haven't got auto lights and auto wipers then your switch will not have this position ! It is possible, however, to enable coming home lights without having auto lights. Just do a search for 'CH/LH lights' if that's what you are after.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO