AH FabricationsChris Nott
Results 1 to 6 of 6
  1. #1
    micasb's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    310

    Retrofit CH/LH Issue.

    So regarding CH/LH OEM switch i've got these 2 options that ELSA gives me:

    For an 04 car:

    Coming home button –
    Pin 1 6-pin connector, black (C) (back of light switch) > Earth
    Pin 2 6-pin connector, black (C) > pin 4 12-pin connector, brown (C) onboard power supply
    Pin 3 6-pin connector, black (C) > pin 12 16-pin connector, black (E) onboard power supply
    Pin 4 6-pin connector, black (C) > pin 3 12-pin connector, black (B) onboard power supply

    For an 05/06/07/08 car Elsa gives this pinout:

    Coming home button –
    Pin 1 6-pin connector, black (C) (back of light switch) > Earth
    Pin 2 6-pin connector, black (C) > pin 4 12-pin connector, brown (C) onboard power supply
    Pin 3 6-pin connector, black (C) > pin 12 16-pin connector, black (E) onboard power supply
    Pin 4 6-pin connector, black (C) > pin 10 10-pin connector, black (K) onboard power supply

    So where should i connect the switch's PIN 4?
    Note i have K rev of J519 (09 module).

    Regards.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    micasb's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    310
    Hi,

    Anyone people?

    Hope you can help

    Best regards

  4. #3
    Smoothie's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Lurgan N.I
    Posts
    1,431
    wish i could help mate but don't know what would work on the 09module as haven't heard anyone done it yet
    Moved to the Darkside click below:

  5. #4
    micasb's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    310
    Quote Originally Posted by Smoothie View Post
    wish i could help mate but don't know what would work on the 09module as haven't heard anyone done it yet
    I've seen on ELSA that it just wires to the LED in the switch... So it can't be armfull if i try it on both connectons .
    In think i'll wire it like the most recent cars because i have a rev K central electrcis module.
    I'll do this today and then i'll post it here.
    Meanwhile if someone could help...

    Regards.

  6. #5
    micasb's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    310
    Hi.

    So i've oppened my old central electrics module and managed to figure out something usefull...
    So PIN 10 on K connector goes to the KL30 relay wich i checked on ETKA as being a relay for interior lights...
    Think i'll just follow the most recent wiring...

    Regards.

  7. #6
    micasb's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    310
    Hi,

    So this is solved.
    I've connected as the more recent car and everything seemedto work fine, except the LED on tha CH/LH switch didn't work...
    So i already had the rain/light sensor installed and had the wiring loom to put in. Done it and everything works like an OEM option
    I also had to activate confort menu on 09 module so i could access DIS options, but now when i want to put front wiper into service mode it does not work... Any opinion?

    Regards

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO