EM TuningBadger5
Results 1 to 11 of 11
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    28

    Cool hazard lights stuck on

    hi
    earlier today i flashed my hazards at a mate as he went the other way and about 5 mins later, the hazard switch lit up and all the indicators were permenantly on. i pulled over, whipped the fuse out (#39 iirc) and the lights went off. the indicators work as normal, but its mot time soon so i need it sorted, any ideas??
    everyone seems to say the switch / relay is a common fault... sound likely?
    oh if it makes a difference its a '51 S3
    cheers
    Andy

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    voorhees's Avatar
    Moderator

    Status
    Offline
    Join Date
    Dec 2005
    Location
    Leafy Warwickshire
    Posts
    14,914
    Relay switch is a common issue to go ,the hazard switch needs replacing Mel

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Jun 2010
    Location
    Glasgow
    Posts
    113
    yes the hazzard relay is very common

  5. #4
    voorhees's Avatar
    Moderator

    Status
    Offline
    Join Date
    Dec 2005
    Location
    Leafy Warwickshire
    Posts
    14,914
    Quote Originally Posted by GAudiTech View Post
    yes the hazzard relay is very common
    yes us Audi drivers turn our noses up at it

  6. #5
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,092
    As already mentioned, it will be your hazard, cost about 40 from Audi and it takes about 20-30mins to change, you will have to take the centre piece out unclip the current one and clip the new one in...job done

  7. #6
    Effect's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2007
    Location
    Derbyshire
    Posts
    469
    takes about 5 minutes to change. lol.

    There is another not so common fault as well, so if this doesnt solve it, start looking at your ECU.

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    28
    haha 5 mins sounds a lot more up my street! now the inevitable question... how do i get the shiny black trim off lol?
    oh and my cup holder decided it didnt want to push back in today so i need to whip that out for a gander whilst im there haha
    cheers guys

  9. #8
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,092
    Just screwdriver it off, but see if you can put a cloth or something in between as not to scratch ot.

    The cup holder is yet another common problem, once mine goes in, it doesnt want to come back out!!!

  10. #9
    Effect's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2007
    Location
    Derbyshire
    Posts
    469
    yeh the black trim is just clipped in, carefully get a cloth +flat-headed screwdriver behind it, it doesnt take much force IIRC to prise it off.
    It should all be clear from there.

    As for the cup holder, mind was a bit iffy going back in sometimes so i priced a new one up from Audi it was over 30 so I just stuck with the one I had seeing as mine did actually still work fine.

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    28
    36 for the new hazard switch and 33 for a new cupholder... spontaneous payday purchases will be the death of me!!
    il findd out tmrw if it fixs the hazards... ready for the mot friday!

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    28
    good work people, i got the hazard switch today, fixed it!! mot tiiiiime!
    cheers for your muchos helful advise!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO