EM TuningAH Fabrications
Results 1 to 23 of 23
  1. #1
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264

    Help with xcarlink on a Symphony 2 stereo

    Firstly, Mods please dont move this thread to the ice forum just yet, I get more coverage on this board

    I know a few of you have xcarlinks in your cars so if you've seen the following problem please let me know:

    I have just purchased an xcarlink ipod interface with the bluetooth module. I bought it off of a mate who also has an 8L S3 with symphony 2 stereo. Now it worked fine in his car with his iphone 3G but in my car I cant get my iPhone 3GS (which xcarlink swear is compatible) to pass any music to the speakers!

    The manual tells me to press the CD button till the display shows "CDC" then I should be able to use the cd changer buttons to select "CDC1" to give me full control from the iphone. For some reason mine is stuck displaying "CDC4" and none of the buttons do anything.

    If anyone has any ideas, I'd love to hear them.

    Thanks,
    Westle
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    So much for the extra coverage lol 6 views!

    Anyone
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  4. #3
    JD09's Avatar
    I'm not modding, I'm improving

    Status
    Offline
    Join Date
    Dec 2009
    Location
    Cheshire, Alderley Edge
    Posts
    3,080
    Lol. I'd PM Tim aka 1Animal1 on here fella. He's very knowledgeable on these and other ipod - car links. Will be bobbing over to see him if and when I get my Parrot one purchased!

  5. #4
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    Yeah I know Tim used to have one of these kits. I was hoping he'd spot this thread so I can keep the info public as there is nothing on the net. I i dont get anywhere here I'll have to contact xcarlink.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  6. #5
    JD09's Avatar
    I'm not modding, I'm improving

    Status
    Offline
    Join Date
    Dec 2009
    Location
    Cheshire, Alderley Edge
    Posts
    3,080
    I don't know where Tim is at the moment. Been a little quieter recently!

  7. #6
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    Its ok i've PMd him and pointed him to this thread.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  8. #7
    alijames's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Oxford
    Posts
    1,017
    Hi Westle,

    I've got the same set-up, and had a few issues at first, which were resolved by making sure the ground wire went to the chassis, as the changer connector ground did not seem to work properly. Mine still occasionally suddenly stops playing music from the USB stick, shows CDC4 Track 1 for a few seconds, then starts working fine again.

    Must admit, I've never tried streaming music from my iPhone 3GS via the xCarlink over bluetooth, however the handsfree functionality works OK, but only cuts in if playing music from the xCarLink, if that makes sense...

    I'll give the iPhone streaming a go this evening.

    Cheers,
    Last edited by alijames; 7th June 2010 at 10:57.
    Alistair

    "Why don't you listen to something really classical, like Mozart, Mendelssohn or Motorhead?"
    Arnold Rimmer, 1988

    Commuting & Weekend Fun:
    Yamaha YZF-1000R Thunder Ace in Blue/Black

    Practical Alternative (Still fun though!!):
    S3 2002/51 AMK Silver, Symphony II + Bose + xCarLink + AndyMac Stealth Sub, Metallic Mirrors, Heated Black Leather, Cruise control.

  9. #8
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    Cheers Ali

    I'm not trying to stream the music via blutooth but via the ipod cable, but the bluetooth calling function wasn't passing the sound to the speakers either. I also get a message on the phone saying that the car kit isn't compatible or something. My mate gets the same error in his S3 but it still works ok for him.

    Where have you put the 2 earth terminals? I had screwed the main (bigger) terminal to the head unit and was then testing the kit by holding the smaller terminal to the inside of the cage and onto the head unit.

    I have just emailed xcarlink's support team to see if they have any ideas too.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  10. #9
    alijames's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Oxford
    Posts
    1,017
    Quote Originally Posted by Westle View Post
    Cheers Ali

    I'm not trying to stream the music via blutooth but via the ipod cable, but the bluetooth calling function wasn't passing the sound to the speakers either. I also get a message on the phone saying that the car kit isn't compatible or something. My mate gets the same error in his S3 but it still works ok for him.
    Ah OK. Does your Bluetooth kit have a round plug to connect to the xcarlink or a micro USB? I have the older round plugged one, and I don't recall ever getting a compatibility message.

    Quote Originally Posted by Westle View Post
    Where have you put the 2 earth terminals? I had screwed the main (bigger) terminal to the head unit and was then testing the kit by holding the smaller terminal to the inside of the cage and onto the head unit.
    I just bolted them to the metal strut behind the HU cage. Improved things no-end.

    Cheers,

    Alistair
    Alistair

    "Why don't you listen to something really classical, like Mozart, Mendelssohn or Motorhead?"
    Arnold Rimmer, 1988

    Commuting & Weekend Fun:
    Yamaha YZF-1000R Thunder Ace in Blue/Black

    Practical Alternative (Still fun though!!):
    S3 2002/51 AMK Silver, Symphony II + Bose + xCarLink + AndyMac Stealth Sub, Metallic Mirrors, Heated Black Leather, Cruise control.

  11. #10
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    Yeah I have the micro usb connection. I did try unplugging it and just tried to get the music side of things to work but still just had "CDC4" on the display. Maybe I need to experiment with the earthing connections
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  12. #11
    1animal1's Avatar
    The Clar!! it mouves!!!

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Sheffield
    Posts
    9,990
    sorry fella, i had the Dension kit..... and then moved to the Parrot MKI9200 bluetooth

    theres several things which i think will be relevant..... firstly make sure you have the correct ignition feed if the kit requires, also earthing as mentioned (should be ok connected to the HU in my experience)..... what exactly comes with the kit in terms of wiring?...ie is it just a plug in the back of the sym 2?

    sounds like it will have a plug the same as the vertical plug on the back of your HU? this allows it to tap into the CD changer.... have you pressed the CD changer button several times?
    Xbox 360 gamer ID : Timffy

    Grey Triumph Sprint 1050 ST
    Silver BMW 535D Tourer - Fully loaded 340BHP 700NM torque
    2009 8P3 S3 Brilliant Red - Sold
    2001 F/L S3 Dolphin Grey - Sold
    1999 Pre F/L Silver A3 1.8T - Sold

  13. #12
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    It's a very simple plug and play system which is pretty much idiot proof which is why I'm sure I havn't done anything wrong!

    Basically you take out the main block connector from the back of the HU then plug the kit into the vacant slot. Then the original connector you just removed goes into the kit loom. You then just earth the thing and it should work!

    I press the CD button once to get to the HU CD changer then press it again to get "CDC4" on the display. This is the kit but it sticks on CDC4 when its supposed to let me use the CD change buttons to set it to CDC1 for full control from the iPhone.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  14. #13
    1animal1's Avatar
    The Clar!! it mouves!!!

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Sheffield
    Posts
    9,990
    hmmm, it could have some sort of button combo to get to the controls you need, you tried uploading a guide?

    i know the Dension had a few button combo's on the HU to get it to do certain things....only thing i can think of, might also be worth trying a normal ipod to see if its the 3G messsing things up?
    Xbox 360 gamer ID : Timffy

    Grey Triumph Sprint 1050 ST
    Silver BMW 535D Tourer - Fully loaded 340BHP 700NM torque
    2009 8P3 S3 Brilliant Red - Sold
    2001 F/L S3 Dolphin Grey - Sold
    1999 Pre F/L Silver A3 1.8T - Sold

  15. #14
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    Cheers Tim. I was going to try a normal iPod to eliminate my phone as being the problem.

    I think the earthing has a lot to do with it. For some reason the VW/Audi kits are the only ones that need earthing from xcarlink! I had one earth screwed to the head unit and my mate was holding the other one against different bits of metal and different things were happening on the HU!

    I read the operators manual cover to cover and cant find anything about any button combos, its supposed to be as easy as changing CDs up and down.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  16. #15
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    Ok I've had another go with this and its still the same. The earth terminals seem to be very important as when they weren't grounded I was getting loads of strange errors on the phone. I dont have a normal ipod to try yet but i'm getting one tomorrow. And i'm also still waiting on a response from the xcarlink support team.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  17. #16
    1animal1's Avatar
    The Clar!! it mouves!!!

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Sheffield
    Posts
    9,990
    good luck matey...
    Xbox 360 gamer ID : Timffy

    Grey Triumph Sprint 1050 ST
    Silver BMW 535D Tourer - Fully loaded 340BHP 700NM torque
    2009 8P3 S3 Brilliant Red - Sold
    2001 F/L S3 Dolphin Grey - Sold
    1999 Pre F/L Silver A3 1.8T - Sold

  18. #17
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    Just tried with a normal iPod (classic I think) and it does exactly the same! The screen says "CDC4 LOAD" which to me sounds like it wants me to load the device to the CD Changer!
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  19. #18
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    Got a reply from xcarlink. The told me to unplug the thing to reset it then plug it back in! Thanks for nothing! They wont help me any more unless I provide them with an order code. I bought this kit off my mate so i'm waiting for him to try and find the code.

    Anyone else got any ideas?
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  20. #19
    1animal1's Avatar
    The Clar!! it mouves!!!

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Sheffield
    Posts
    9,990
    sorry fella..im not entirely familiar with it
    Xbox 360 gamer ID : Timffy

    Grey Triumph Sprint 1050 ST
    Silver BMW 535D Tourer - Fully loaded 340BHP 700NM torque
    2009 8P3 S3 Brilliant Red - Sold
    2001 F/L S3 Dolphin Grey - Sold
    1999 Pre F/L Silver A3 1.8T - Sold

  21. #20
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    I dont even know if I'll be able to bang it up on ebay because if it doesn't work on mine it might not work on someone elses stereo! I need to go see my mate and maybe pinch his symphony2 as he's just replaced it.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  22. #21
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    FIXED!

    At no point had I removed the power connector from the back of the head unit. I did and it reset the head unit and the xcarlink and it all works fine now. Just need to sort out the choones on my iphone

    Can anyone explain to me how to get the a pillar trim off so I can run the speaker wiring up there?
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  23. #22
    1animal1's Avatar
    The Clar!! it mouves!!!

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Sheffield
    Posts
    9,990
    nice mate...... makes a massive difference to using them darn CD's dunt it

    to be fair i just pushed my speaker cable behind it without removing...although if you want it off it's on spring clips....but id leave it, levering it might bend it a little making it a none flush fit when replaced
    Xbox 360 gamer ID : Timffy

    Grey Triumph Sprint 1050 ST
    Silver BMW 535D Tourer - Fully loaded 340BHP 700NM torque
    2009 8P3 S3 Brilliant Red - Sold
    2001 F/L S3 Dolphin Grey - Sold
    1999 Pre F/L Silver A3 1.8T - Sold

  24. #23
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,264
    NOT FIXED!

    Just went to run in all the wiring behind the dash and the flipping thing had stopped working again! I had to take the head unit out and reseat the power about 10 times before it started working again! I swear the electrics in my car dont like me. First the alram and now this!

    It is now currently working but I wonder for how long!
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO