EM TuningAH Fabrications
Results 1 to 5 of 5
  1. #1
    1st Gear

    Status
    Offline
    Join Date
    May 2010
    Location
    West Sussex
    Posts
    157

    yellow oil light & I think 'sensor' next to it

    I have had a light come up where the low petrol light comes on, it looks like it may be an oil can with the word 'sensor' next to it (lost some pixels so it's harder to tell exactly), does this sound about right, it's a 99 S3.
    I have oil in the car as I checked right away.

    Any advice would be great.

    Oh & while we are on the subject of oil, is the turbo easy to access on the S3, I have an oil leak over that way somewhere I think as I get a little bit of smoke after a good hard run.

    Cheers
    Steve

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    vetch's Avatar
    S3

    Status
    Offline
    Join Date
    Apr 2009
    Posts
    412
    That would be the oil level sensor.

    See here - http://www.audi-sport.net/vb/showthr...ght=oil+sensor
    Audi S3

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    May 2010
    Location
    West Sussex
    Posts
    157
    Nice one, looks like I may have a sensor on the way out as it comes on, goes off, comes on.. all at random times, thought it was something to do with the dipstick as I just replaced the plastic sleeve as mine was busted up & had been bodged with sealant, ffs it only cost 3.50 & took 10 mins to replace, lol.

  5. #4
    luke2702's Avatar
    2nd Gear
    Chopper Challenge Champion

    Status
    Offline
    Join Date
    Apr 2010
    Location
    Bolton
    Posts
    446
    Mine had same problem when i got it sometimes was on sometimes wasnt this is what i bought not had problem since and 40 quid cheaper than Audi

    http://cgi.ebay.co.uk/ws/eBayISAPI.d...#ht_2241wt_732
    2002 S3 8L, FORGE 007, R-TECH RE-MAPP, MILTEK CAT BACK NON-RESONATED, JETEX CONE FILTER AND 260 BHP ISH.......

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    May 2010
    Location
    West Sussex
    Posts
    157
    Quote Originally Posted by luke2702 View Post
    Mine had same problem when i got it sometimes was on sometimes wasnt this is what i bought not had problem since and 40 quid cheaper than Audi

    http://cgi.ebay.co.uk/ws/eBayISAPI.d...#ht_2241wt_732
    Nice one

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO