Badger5Volks Autos
Results 1 to 18 of 18
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    kendal
    Posts
    18

    HALDEX NOT WORKING

    help i got no 4 wheel drive,had it scanned no faults reported and haldex communicating with ecu and abs anyone know what to check next
    thanks

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Chugger

    Status
    Offline
    Join Date
    Nov 2009
    Location
    North Devon
    Posts
    2,716
    earth strap on rear diff?
    57 A3 2.0 TDI Sportback (140)

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    kendal
    Posts
    18
    Thanks for the idea, the earth strap is connected also on measuring blocks the brake light and handbrake switch work.

  5. #4
    barters3's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    May 2008
    Posts
    440
    It was the pre charge pump that failed on mine and it prevented the haldex unit from operating completly. It's the small pump with a black plastic tube and plug in connections. It won't show any fault codes if it has packed up. It's in the region of 250 quid new and nobody seems to want to split one from the rear diffs that are for sale on eBay. It would be worth contacting a vag tuner in Bridgwater called tsr performance (details on google) they do a lot of 1.8t conversions and the guy informed me whilst i was having other work done there that they have got complete rear diffs just lying around. So maybe worth a try. Good luck.

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    kendal
    Posts
    18
    Thanks very much for replying,does anybody know how to test if the pre charge pump is working or not?

  7. #6
    barters3's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    May 2008
    Posts
    440
    I don't know how to test it I'm afraid. If you do a search there was a thread on here not so long ago on a similar subject. However I think most of the sugestions have been covered in this thread. Worth checking the fuse for the haldex if you haven't already. If you do end up changing the pump you will need some replacement haldex oil.

  8. #7
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Durham NE
    Posts
    578
    you can test the pump is working with vagcom under simulation tests? cant remember,i was playing around in vagcom and found this,heard mine come in and out etc.
    James
    Silver Audi 8L S3
    97 Fireblade fully restored ...just for summer!
    My old Corrado VR6 Turbo... Click me for the build DIY style!
    and many many cars and bikes in the past!!

  9. #8
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Durham NE
    Posts
    578
    like this...drivetrain, 22 AWD ,then 03 output tests

    http://www.ross-tech.com/vcds/tour/open_screen.html
    James
    Silver Audi 8L S3
    97 Fireblade fully restored ...just for summer!
    My old Corrado VR6 Turbo... Click me for the build DIY style!
    and many many cars and bikes in the past!!

  10. #9
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    kendal
    Posts
    18
    i tried the output tests but nothing seemed to happen but a little click.
    if a rear wheel is jacked up then the output clutch is engaged should the wheel be locked or spin ?

  11. #10
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Durham NE
    Posts
    578
    dont know what will happen if jacked up,i suspect even with the pump working and the coupling engaged it will still act like a normal open diff and with one wheel in the air still turn regardless,mine i could hear the pump working when sat in the car,if yours is not making any noise when activated in output tests its probably dead or a bad connection.
    James
    Silver Audi 8L S3
    97 Fireblade fully restored ...just for summer!
    My old Corrado VR6 Turbo... Click me for the build DIY style!
    and many many cars and bikes in the past!!

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2009
    Location
    kendal
    Posts
    18
    cheers for the help, i think i will have to be climbing under and having a closer look

  13. #12
    Welly's Avatar
    VX220 SC Driver :)

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,695
    Agreed, the fuse for the Haldex would be my first port of call, followed by the plug for it - I believe it's on the engine bay somewhere.
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson





  14. #13
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    4
    hi i had the same problem with the haldex pre charge pump and in vw or audi these little pumps cost 400 quid i i was looking to get that pump for a month and i found company or something like that i sended them my old pump and they replaced new engine and other parts needed for that pump it costed me only 150 quid and i got new pre charge pump new engine new seals and now almost three years and no rpoblems at all

  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    4
    and i forgot i think they fixing haldex computers and does all sorts with the haldex

  16. #15
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    4
    to test pre charge pump just take it of and do bench test with car batery

  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2010
    Posts
    4
    performance.parts.haldex@gmail.com thats these lads email i dont know it might help you

  18. #17
    S3KO4's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Aug 2009
    Location
    London
    Posts
    850
    most of the time is the pump, cost nearly 120 second hand, I changed 2 controllers before this with no joy, I could hear it working even if the car is not moving. the wheels should spin if the car is jacked.
    S3-8L REVO stage 2, Milltek, 3" DP & custom 3" decat, RS2 spark plugs, 4 bar FPR, Green-Cotton uprated upper/lower boost hose & TIP, Front Zimmerman & Ferrodo. LCR spliter. boost gauge, smoothed AB. Aero blades, H&R 5mm spacers. Best time 14.03sec, 0-62 in 5.7sec. 207gs @ 25psi , polished inlet mani. VAGCOM 805.1

  19. #18
    The Slug's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2004
    Location
    UK
    Posts
    1,853
    Quote Originally Posted by bogard View Post
    help i got no 4 wheel drive,had it scanned no faults reported and haldex communicating with ecu and abs anyone know what to check next
    thanks
    Have you checked the fuse?
    Vehicle wrapping specialist

    NOW SOLD S6 Avant 4.2 V8....ooooo the noise hehe

    NOW SOLD '03 A3 TDi Quatty Sport Mods so far: Aerowipers front & Rear, Type R Sting ariel, 18" RS-TT Alloys, Superchips remap, Eibach Pro Springs -40mm, Bilstein B8 dampers, R32 ARB's Front & Rear, Pipercross panel filter

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO