Sky InsuranceEM Tuning
Results 1 to 30 of 30
  1. #1
    mark_sarah's Avatar
    Limp mode!

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Norwich
    Posts
    203

    Stereo volume fault - Repair or replace?

    I recently bought an S3, and was informed before purchase that the stereo was faulty..

    The stereo works fine except the volume. If you touch the volume up or down, it just goes to full blast!
    I've been told this is a common fault, but is there a fix available for it?

    Otherwise has anyone got a factory fitting CD for sale? As i want to keep it original.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    fran-s3's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jan 2008
    Posts
    1,090
    No it has to be replaced from what I've read on here.

  4. #3
    snowed under

    Status
    Offline
    Join Date
    Jul 2007
    Posts
    162
    Yes mate it can be fixed, i took mine to a local car radio shop i think it was 40 to sort it. I wanted to keep the dash stock looking so i got it fixed

  5. #4
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    BBA Reman do this as well -

    See here: http://www.bba-reman.com/content.asp...-TT-2000-Radio

    Best to give them a phone....
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  6. #5
    fran-s3's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jan 2008
    Posts
    1,090
    I stand corrected then! Sorry

  7. #6
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    Quote Originally Posted by fran-s3 View Post
    I stand corrected then! Sorry
    LOL, it's a problem with the actual chip they used, and the way that the software was programmed. The chip used is an old type of EEPROM ( Electrically Erasable Programmable Read-Only Memory) chip which only has a limited write cycle (meaning that it only has a finite amount of times it can be written to before it breaks down and doesn't work any more). This write cycle is approx 10,000 writes or more.

    Then the dingbats at Blaupunkt programmed it a bit wrong.

    The EEPROM chip in question is designed to store the volume level when the stereo is turned off, so that when you turn it back on, it comes back to the same volume. Simples. This way, it only gets used infrequently, and the limited write cycle never becomes an issue, as turning the thing of 10,000 times will take a while.

    Instead of doing this, what Blaupunkt did was program the system so that EVERY movement of the volume knob meant that the chip was flashed and reprogrammed. That means every single movement. If you turn the volume up 10 notches - 10 flash and rewrites. Think about how many times a week you adjust the volume, et voila, there is the problem.

    What they should of done there was write the software to save this data to the stereo's RAM which has an infinitive write cycle, and then store the final volume in the EEPROM chip when the system was turned off.

    As you can imagine, the life cycle of the chip in an average A3/S3 was about 3-5 years before the chips started to break down. In Audi Concert head units that haven't been fixed up with a new chip and software, its not if you have this problem. But when.

    Well done Blaupunkt.

    Not.
    Last edited by Welly; 4th May 2010 at 16:19.
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  8. #7
    fran-s3's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jan 2008
    Posts
    1,090
    Wow great explanation their Welly. So the chip itself can obviously be replaced for another 10,000 adjusts? (not that I have the OEM stereo just curious)

  9. #8
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    Quote Originally Posted by fran-s3 View Post
    Wow great explanation their Welly. So the chip itself can obviously be replaced for another 10,000 adjusts? (not that I have the OEM stereo just curious)
    They put a new chip in and then flash the stereo with updated - non ****e - software to rectify the problem AFAIK.
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  10. #9
    Neutral

    Status
    Offline
    Join Date
    May 2010
    Posts
    34
    My one is doing the same. I think i will end up putting in my own stereo though.

  11. #10
    Neutral

    Status
    Offline
    Join Date
    Feb 2010
    Location
    Torquay, United Kingdom
    Posts
    30
    mine started this morning so i think a new headunit is needed thanks for the explanation welly.

  12. #11
    A3Tom's Avatar
    Smell my finger.

    Status
    Offline
    Join Date
    Mar 2009
    Location
    Solihull
    Posts
    3,509
    cool, looks like I can get mine sorted then

    To be fair mine only does it when its cold....random!!. When the cars warm its spot on...very odd.
    2000 Audi A3 1.8T Sport - Custom Code Phase 1 remap / Custom Stainless Catback Exhuast / MKII 18" RS4 Reps / Wietec Ultra GT40mm / KW ARB's / Forge TIP / Forge 007 / Green Panel Filter / EBC Greenstuff pads / 312mm S3 front brake upgrade / Aero Wipers / LED Interior Lights / LED Side Repeaters / Face Lift Rear Lights and covered in Dodo Juice

  13. #12
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    Not random at all mate, these EEPROM chips work by passing electrons through a gate made of oxide gas.

    That is how they become programmed, and then reprogrammed. What happens when it is programmed and re programmed over periods of time, is that the gas breaks down and the electrons can't pass the gate any more. That is why we have the problem with the stereos.

    However, when they are in the early stages of failure, heat can cause the electrons that are stuck/sticking to free and pass as they should resulting in the working state when warm, and the FUBAR state when cold.

    Some 'stereo repair shops' take the Audi Concert Stereos to bits, heat the chip to a high temp with a heat gun and refit. This results in them working again - however the fix is short term.
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  14. #13
    Neutral

    Status
    Offline
    Join Date
    Jul 2010
    Posts
    40
    Quote Originally Posted by Welly View Post
    BBA Reman do this as well -

    See here: http://www.bba-reman.com/content.asp...-TT-2000-Radio

    Best to give them a phone....
    Tried calling them a few times but nobody ever picks up..

    How much do they charge and where are they based?

    Cheers

  15. #14
    Neutral

    Status
    Offline
    Join Date
    Jul 2010
    Posts
    40
    Ok finally got through, there saying 140gbp including postage back to me and vat included.

    For anyone else in my boat it's worth noting that the details on the link below are incorrect. They won't send you out a working stereo first, you actually have to send yours in and they keep it for 7-10 days then post it back to you. The work is guaranteed for 2 years though...

    http://www.bba-reman.com/catalogue/D...edProduct=1895

    I'm still mulling it over... 140 all in sounds expensive, but a replacement HU of this type on ebay is apx 80 gbp and then who's to say that won't have the same fault in a few weeks? So maybe this is the best bet?

    I also need to have something fitted so I can plug my ipod in, has anybody got any idea's where I can get this part from for cheap'ish?

  16. #15
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    Quote Originally Posted by mary_q View Post
    Ok finally got through, there saying 140gbp including postage back to me and vat included.

    For anyone else in my boat it's worth noting that the details on the link below are incorrect. They won't send you out a working stereo first, you actually have to send yours in and they keep it for 7-10 days then post it back to you. The work is guaranteed for 2 years though...

    http://www.bba-reman.com/catalogue/D...edProduct=1895

    I'm still mulling it over... 140 all in sounds expensive, but a replacement HU of this type on ebay is apx 80 gbp and then who's to say that won't have the same fault in a few weeks? So maybe this is the best bet?

    I also need to have something fitted so I can plug my ipod in, has anybody got any idea's where I can get this part from for cheap'ish?
    Spend the money, get it repaired PROPERLY, and then drive around and sit back enjoying your controllable volume, knowing you have 2 years guarantee.

    Buy a second hand one at your peril, it will always be in the back of your mind wondering when it's going to break....

    Worth the extra 60 IMO....
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  17. #16
    NHN
    NHN's Avatar
    Modmetractor

    Status
    Online
    Join Date
    Jan 2008
    Location
    Coding Something
    Posts
    26,719
    Stafford Audi usually sell new/refurbs on ebay for 99, I wouldnt spend 140 on repair tbh, sell with fault & buy another thats what I did & still got some fair money on faulty one.

    OEM RETROFITS - CRUISE CONTROL - SAT NAV - BLUETOOTH - AMI - HEADLIGHT SYSTEMS

    PARKING SYSTEMS - DIAGNOSTICS - FAULT FINDING - BODYWORK - PAINTWORK

  18. #17
    mark_sarah's Avatar
    Limp mode!

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Norwich
    Posts
    203
    Update to learn from..

    I decided to put my Kenwood masked stereo in which to be honest looked no where near as tidy as the standard unit, but it died a miserable death last week, so i purchased a standard replacement off ebay.

    AUDI CONCERT RADIO CASSETTE FITS 98 + VERY GOOD ORDER on eBay (end time 12-Sep-10 18:39:29 BST)

    The listing stated the volume was in full working order! It lasted one day, now i have one volume level, which is full volume.
    I have contacted the seller, but had no response as yet. Would'nt be surprised if they heated the chip to boost some life into it.

    Wish i had got my original unit repaired now......................
    It's better to burn up, than to fade away...

  19. #18
    mark_sarah's Avatar
    Limp mode!

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Norwich
    Posts
    203
    Has anyone sourced a reasonably priced technician, that can replace the faulty eprom chip..?

    I've obviously used the search function before anyone suggests it LOl, 140 is still a lot of money just for a fix..
    It's better to burn up, than to fade away...

  20. #19
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  21. #20
    mark_sarah's Avatar
    Limp mode!

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Norwich
    Posts
    203
    Cheers welly.

    Anyone tried these?
    It's better to burn up, than to fade away...

  22. #21
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    Not here mate I'm afraid. Been trying to find the dosh to actually get mine done and was planning to use them to no avail. Other, more important stuff keeps breaking! lol
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  23. #22
    Swornd's Avatar
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Posts
    50
    Mine has always done this but I have a fix that works for a few months on mine! When it happens, turn off the stereo, then take the keys out of the ignition. Now switch the stereo back on before you put the keys back in, then put the keys in and turn the ignition, then try the volume! This works for mine every single time it has happened, I went weeks with it being knackered before I figured this out. Can't say for sure if this will work for everyone but I went weeks with having it dodge and this is always a immediate fix. You can also do a order to break it I found out but I guess that isn't much use.

  24. #23
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    The problem being that it happened every single time I use the stereo now mate. It will only get worse once it's started....
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  25. #24
    Swornd's Avatar
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Posts
    50
    That's what mine was like, I couldn't adjust it off full volume for weeks but doing that order solves it for me every time.

  26. #25
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    Quote Originally Posted by Swornd View Post
    That's what mine was like, I couldn't adjust it off full volume for weeks but doing that order solves it for me every time.
    I shall give it a go....
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




  27. #26
    Swornd's Avatar
    Neutral

    Status
    Offline
    Join Date
    Mar 2009
    Posts
    50
    Good luck! Hope it solves it for you.

  28. #27
    mark_sarah's Avatar
    Limp mode!

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Norwich
    Posts
    203
    How do i find out if this unit will fit my 2000 model S3: 8L0 035 186 G

    It was originally fitted in a TT
    It's better to burn up, than to fade away...

  29. #28
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2010
    Location
    Derby
    Posts
    27
    Quote Originally Posted by Swornd View Post
    Mine has always done this but I have a fix that works for a few months on mine! When it happens, turn off the stereo, then take the keys out of the ignition. Now switch the stereo back on before you put the keys back in, then put the keys in and turn the ignition, then try the volume! This works for mine every single time it has happened, I went weeks with it being knackered before I figured this out. Can't say for sure if this will work for everyone but I went weeks with having it dodge and this is always a immediate fix. You can also do a order to break it I found out but I guess that isn't much use.
    Don't know how this works- nor do I really care to know.. but it works!! cheers

  30. #29
    leighlo's Avatar
    Audi Newbie...

    Status
    Offline
    Join Date
    Jan 2011
    Location
    South Wales
    Posts
    17
    Mine's the same mate - it only fails when it's cold.

    Within 10 minutes of being in the car in the morning, it works fine... but for the first 10 minutes (when there's still frost on the side windows!) it will only go to silence, or full blast.

  31. #30
    Welly's Avatar
    Testing dodgy Chinese gear...

    Status
    Offline
    Join Date
    Aug 2009
    Location
    Gloucestershire
    Posts
    10,680
    Quote Originally Posted by leighlo View Post
    Mine's the same mate - it only fails when it's cold.

    Within 10 minutes of being in the car in the morning, it works fine... but for the first 10 minutes (when there's still frost on the side windows!) it will only go to silence, or full blast.
    It's one of those problems that only gets worse with time mate I'm afraid. These head units in standard form are simply rubbish. Epic, epic fail on Blaupunkt's side.

    It's a shame the issues are only being realised now after all this time.

    Happens to them all eventually.
    ------------------------------------------------------------------------------------------
    "Marriage is like a coffin and each kid is another nail."
    Homer Simpson

    Quote Originally Posted by Prawn View Post
    Wellyboots, you are quite literally my most favourite pikey in the entire world




 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO