EM TuningBadger5
Results 1 to 15 of 15

Thread: Vague Steering

  1. #1
    3rd Gear

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    520

    Vague Steering

    Lately I have been finding the steering on my A3 very vague and sloppy. For example, I will go turn around a corner and if I come across a small bump in the road during the cornering the front end feels like it skips slightly. I am also getting a slight squeal during turning at slow speed.
    I have also noticed that I am getting a juddering when breaking heavily, I know this could be warped discs but could it be related to the vague steering issue?

    Has anybody elso exoerienced anything like this? any advice would be appreciated.

    Cheers

    Liam

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Sandip's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Greater Manchester
    Posts
    2,379
    Front shocks
    3.2 V6 with Custom Code VVT Attack Software


  4. #3
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    worn ball joints

  5. #4
    martin g's Avatar
    [censored]

    Status
    Offline
    Join Date
    Feb 2010
    Location
    somerset
    Posts
    154
    I think so too ...i know my front shocks need replacing and i get a couple of those same symptoms buddy

  6. #5
    3rd Gear

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    520
    not cool, i hope this dosnt mean new shocks as mnie are coilovers which arnt that old to be honest, could wishbone bushes cause this? or top mounts?

  7. #6
    Sandip's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Greater Manchester
    Posts
    2,379
    Ahhh not sure then if you got coilovers bud, could be the anti roll bar bushes
    3.2 V6 with Custom Code VVT Attack Software


  8. #7
    ALPINE's Avatar
    Yes its diesel, now cry u lost

    Status
    Offline
    Join Date
    Apr 2008
    Location
    S/E LONDON / KENT
    Posts
    3,086
    i had this prob and it was my wishbones. do your track rod ends too,, as i now have to replace mine 2 weeks after doing my wishbones! lol Dam car!

    Now to many mods to list! Lots of power, torque and Leather!

  9. #8
    mattyboy199's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2005
    Location
    UK
    Posts
    1,689
    i think a number of things contribute to this worn ball joints, top mounts, front wish bone bushes

    not sure about track end rods ?
    2002 Dolphin grey S3 - Sym2+bose, heated leather, ally mirrors, R32 ARB's with superpro, Jabba stage 2 map, TFSI coils, Samco TIP, Forge DV & privacy glass

    2010 Green Kawasaki Ninja ZX6R - Akrapovic baffleless race can, LED cluster & HID's

    wanted for 8L S3:
    Unmarked grey rear bumper panel
    Milltek system

  10. #9
    ALPINE's Avatar
    Yes its diesel, now cry u lost

    Status
    Offline
    Join Date
    Apr 2008
    Location
    S/E LONDON / KENT
    Posts
    3,086
    i done everything when fittin my coilovers. ARB bushes, wishbones, sub frame mounts. Still get me stupid clonk and funny feeling steering. the only thing left is the steering rack.. its either the racks fobard or the tie rods are mullerd. Cant really think what else there is. ??

    Now to many mods to list! Lots of power, torque and Leather!

  11. #10
    3rd Gear

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    520
    Going to replace the wishbones, inlcuding all the bushes and ball joints. If this dosnt help then will change top mounts etc..

  12. #11
    gumball b's Avatar
    [OLD SKOOL CRUISER]

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Harrow England
    Posts
    72
    i had simular sort of thing a bit vague even when on a straight road,changed drop links and roll bar bushes,much more responsive now.good luck.

  13. #12
    3rd Gear

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    520
    ok thanks mate, i will definately be changing those parts.

    I had a look at the arb yesterday and noticed i could see a small gap between the bush and the arb so im guessing the bushes have had it

  14. #13
    gumball b's Avatar
    [OLD SKOOL CRUISER]

    Status
    Offline
    Join Date
    Oct 2009
    Location
    Harrow England
    Posts
    72
    Quote Originally Posted by Plunky View Post
    ok thanks mate, i will definately bethe bush and the arb so im guessing the bushes have had it
    USE UPRATED POWERFLEX BUSHES HARDER WEARING LONGER LIFE AND NOT TO EXPENSIVE FRONTS CAN BE A BIT AWKWARD TO GET TO BACKS A BIT EASIER OK MATEY...

  15. #14
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,523

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    Get the tracking checked tbh, mine was toeing out massively and caused pretty much the same symptons. Either way if you go changing parts you should get tracking done anyway

  16. #15
    3rd Gear

    Status
    Offline
    Join Date
    Jul 2009
    Posts
    520
    Decided im just going to change all the suspect parts..cant be a bad thing and then get the tracking done afterwards

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO