Monster MotorsportSky Insurance
Results 1 to 14 of 14

Thread: BIG RED LIGHT!

  1. #1
    ssbnreso's Avatar
    Neutral

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Sunny Sunderland
    Posts
    80

    BIG RED LIGHT!

    Got the big red brake warning light on display!

    Sometimes comes on when you start car but other times doesn't come on until you drive off?

    In manual says check brake fluid but this top up to max mark?

    Anybody any ideas?

    Cheers

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,283
    Could be the brake fluid sensor playing up!
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  4. #3
    ssbnreso's Avatar
    Neutral

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Sunny Sunderland
    Posts
    80
    Quote Originally Posted by Westle View Post
    Could be the brake fluid sensor playing up!
    Does the light relate to the abs in any way?

    Changed a sensor last week

    Thanks for the reply

  5. #4
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,283
    did you change a wheel speed sensor? The normal light(s) that appear when you have a dicky wheel speed sensor are the ABS and ESP lights.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  6. #5
    ssbnreso's Avatar
    Neutral

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Sunny Sunderland
    Posts
    80
    Yes was a wheel speed sensor as yellow abs light was on.

    Now both lights on and when i try to read codes with vag com it says 'no response from contoller'

    Check all fuse, all ok, so now thinking it may be abs ecu, but how do i check before a fork out for a replacement

  7. #6
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,283
    Ahh I had a similar issue with one of my wheel speed sensors after I fitted a new one. I was able to read the sensor but if you monitor all 4 sensors in VCDS (sorry cant remember what block number it was) the readings for that sensor was all over the place. All 4 should be the same if just going down the road normally. I took another look at the sensor and it turns out that I hadn't pushed it in far enough so the gap between the sensor and the abs spindle was too wide. I hammered the sensor into place a bit more from behind so that it was only 2-3 mm away from the spindle and it started working.

    Also did you get a genuine audi sensor? I bought one from Euro Car Parts and it packed in after 2 months! I then bought an Audi one and its been fine for 9 months so far.

    Hope that helps
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  8. #7
    ssbnreso's Avatar
    Neutral

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Sunny Sunderland
    Posts
    80
    Thanks,

    Wasn't a genuine part

    Will check the fit of sensor again

    Cheers

  9. #8
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,283
    Quote Originally Posted by ssbnreso View Post
    Thanks,

    Wasn't a genuine part

    Will check the fit of sensor again

    Cheers
    Just compare it with the distance of another sensor. They can be difficult to get back into place because the metal hole that they sit in gets rusty and makes it a tight fit. I filed some of the rust off the inside of the hole.

    good luck and let me know how it goes.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  10. #9
    ssbnreso's Avatar
    Neutral

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Sunny Sunderland
    Posts
    80
    Will do

  11. #10
    ssbnreso's Avatar
    Neutral

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Sunny Sunderland
    Posts
    80
    Well checked all the sensors and the gaps all look the same.

    Vag com can't get a response from the abs module, so i'm starting to think it's the abs ecu that's at fault

    Watching one on flea bay at the minute so if it stays cheap might try that.

    Otherwise i'll have to cover the abs light with toilet roll like the previous owner did

  12. #11
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,283
    Try disconnecting the new sensor so that you only have 3 connected and see if the ABS module comes back alive.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  13. #12
    ssbnreso's Avatar
    Neutral

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Sunny Sunderland
    Posts
    80
    Well got it sorted

    Don't know what i did but both lights are now out and abs controller is talking again

    Just took fuses out and diconnected ecu and pluged back in!

    Showing a intermittent fault on right front sensor now though (changed left)

    Think i'll leave it for the minute unless orange abs light comes on. Don't want to tempt fate

    Cheers for your input

  14. #13
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,283
    Good man. Restting everything is a lot cheaper than buying a new unit
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  15. #14
    ianysm's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Oct 2008
    Location
    Midlands
    Posts
    1,002
    Most things that are 'puter related respond well to a reset!
    AUTOMAP
    Mobile ECU Remapping Services

    automap.remapping@gmail.com
    www.eliteremaps.com

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO