AH FabricationsChris Nott
Results 1 to 9 of 9
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    7

    Problem, door sensor?

    Hi, Ive got Audi a3 1.8t sport 02 plate.

    Think got problem with door sensor and most of time seems to be the passanger side, when ever I lock car or driving the interior light
    flashs on and off all the time and can hear a clicking noise and if car is locked it will set alarm off. Somtimes open and closing the door fully stops it but takes a while. Nothing shows up on the dash to say its open.

    Anyone help thanks

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Offline
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,272
    See if slamming the door helps. I had similar issues with interior lights and door sensors. I had the door lock changed which helped but after further investigation it turned out I had a faulty central locking pump.

    You need to get VAGCOM on the car to find out if you have any errors.
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    7
    Thanks for helps, yea tryed slamming it still does it lol,

  5. #4
    S3 Paul's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2006
    Posts
    2,764
    I had this problems.
    The pin switch that controls the light is inside the door lock, If you look into the door catch you can see the pin switch, Push it in and out a few times with a thin screw driver and maybe spray a little wd40 or something like into the catch. If doing this help ... good times , if not maybe the swich is completely dead.
    Noggy Blue 2001 S3

    I ask questions because i change my mind so much. If i ask questions you have already covered... just leave it be?

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2009
    Posts
    7
    Thanks! it dont do it all the time, will give it a try thanks

  7. #6
    Spec's Avatar
    Currently just a Clio owner :(

    Status
    Offline
    Join Date
    Jul 2008
    Location
    Birmingham, In the Yellow Clio
    Posts
    84
    Can I bump this thread for further help please..?
    I have this problem. Sometimes the alarm goes off after about 40 seconds.

  8. #7
    Ian W's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Oct 2007
    Location
    Wirral, Merseyside
    Posts
    1,054
    Had it a few times myself, nothing a good old slam of the door hasn't fixed yet

  9. #8
    Nilz's Avatar
    Defo worth the wait :)

    Status
    Offline
    Join Date
    Apr 2006
    Posts
    10,087
    Spec, dont know why your alarm is going off, it should do and wont have anything to do with the door sensor.

    I normally slam the door or just leave it as it is.

  10. #9
    s3 Hoggy's Avatar
    Whats going on???

    Status
    Offline
    Join Date
    Apr 2009
    Location
    Oxford
    Posts
    1,653

    My Social Networking

    Visit s3 Hoggy's Instagram Channel
    I had this same problem recently, the alarm would somtimes wake me in the night! Making me rush out to my car expecting the worse only to find the display showing the door was open? I had a local specialist replace the lock which has the micro switch in it cost about 50 for the part plus 30-45mins labour, Think these micro switches are not the best, had the boot do the same thing bout a month later but replaced that myself and was only 28 part, the new boot latch was actualy an 8p part but seems to have done the trick!

    cheers Matt
    Last edited by s3 Hoggy; 28th July 2009 at 23:19. Reason: Spelling
    2002 S3 REVO
    Milltek, Sachs Organic clutch, 007p, Genuine RSTT's, BBS RS2's
    Koni FSD & H&R springs, Neuspeed 22mm rear ARB, KW tie arms
    LCR Brembo's with DS2500's & Paul's 300mm Rear disc kit,
    Michelin Pilot Sport 3's,Badger5 V2.2 Jetex filter & heatshield


 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO