Chris NottJMB Retrofits
Results 1 to 7 of 7
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2009
    Posts
    11

    Update on oil light on Audi A3.

    I have previously posted about the oil light on my Audi A3. dlakster came and did a vag-com on my car. It showed up no faults. Any suggestions from anyone. Getting desperate now.
    SUE341W

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    thorsy22's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2008
    Location
    West Sussex
    Posts
    307
    Possible short on the lead or dirty contacts to bring the light on if the oil level is fine?
    (Just guessing tho)
    2001 Audi S3 - AMK 210bhp
    Tarox F2000 discs front - Tarox 401 Rallye+ pads
    Tarox F2000 discs rear - Tarox 112 Strada pads
    Goodridge brake lines
    TT pedals
    N249 bypass

    Finally back on the road, have a HUGE list of mods and things to do now!


  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2009
    Posts
    11
    Thanks I will check that. Sue.
    SUE341W

  5. #4
    Andy_S3's Avatar
    4th Gear

    Status
    Offline
    Join Date
    May 2007
    Location
    Teesside
    Posts
    719
    The oil pressure light was only coming on past 2000rpm, so does anyone know if that rules out a sensor related problem?

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Apr 2009
    Posts
    1
    HI,I HAD EXACTLY THE SAME PROBLEM WITH MY 1999 A3 1.8T.THE OIL PRESSURE LIGHT CAME ON ABOVE 2000RPM AND WENT OUT AT TICKOVER.I CURED IT BY RUNNING THE CAR AT TICKOVER WITH A BOTTLE OF FORTE ENGINE FLUSH IN IT FOR 45 MINS THEN CHANGING THE OIL AND FILTER.THESE ENGINES ARE BAD FOR BLACK SLUDGE IF OIL IS NOT CHANGED REGULARLY.

  7. #6
    abdus's Avatar
    Top Gear
    Cell-Out Champion

    Status
    Offline
    Join Date
    Apr 2007
    Location
    On an Island
    Posts
    1,810
    Quote Originally Posted by djakster View Post
    The oil pressure light was only coming on past 2000rpm, so does anyone know if that rules out a sensor related problem?

    Not sure where I read that, but I think there are 2 sensors. One is at the bottom and the one that controls the oil pressure if it falls below a certain pressure. and then the other one controls above a certain pressure.

    I'll look for the link and post it (not sure how much help it will be though)
    ^^ In my opinion


  8. #7
    leshkin's Avatar
    Speeding in reverse gear

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Northwood
    Posts
    678
    Hi John, thanks for your input on this and it may well be a dirty oil level sensor at hand.

    In the future, please don't use CAPS lock as it is difficult to read and is normally interpreted as SHOUTING. Cheers

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO