EM TuningChris Nott
Results 1 to 19 of 19
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Nov 2008
    Posts
    95

    S3 Rev'ing its self between 1.k-3k when not in gear, and very hesitant

    Hey all, im not having very much luck with my car at all

    its is now rev'ing its self between 1.k-3k when not in gear, and very hesitant when driving. also engine managment light is on.

    any ideas what this could be?

    cheers

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Works 60% the time, Everytime.

    Status
    Offline
    Join Date
    Jul 2008
    Location
    Up North
    Posts
    1,577
    If engine management light on get it checked.

    Im sure there must be an idle control unit on the S3. Might be part of the throttle body itself. This may have gone or also the temp sender on the vag engines can cause irratic idling although 1-3k is quite a large variation.

    2003 Audi S3 + Go faster bits

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Nov 2008
    Posts
    95
    ok thanks mate, well its rev's it self all the way up to 3k, then sounds like it cant go any further, then drops rights down again, then straight up to 3k again

  5. #4
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,520

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    Did you solve the electrical issues?

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Nov 2008
    Posts
    95
    yeh brake lights and fog lights are now sorted, and the split pipe changed.

    now got this

    still does this when the car is fully warmed up aswell

    it has done it once before, but then after 5 mins it was fine, now it does it all the time

  7. #6
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,520

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    What caused the sporadic airbag/abs/hazards if i may ask? wondering if its related?

    Have you tried an adaption of the throttle body?

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Nov 2008
    Posts
    95
    I never had a problem with any of them....think you may have the wrong person....

    nope i havent, going to give throttle body a clean over the weekend

  9. #8
    Broken Byzan's Avatar
    Photographic Moderator

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Cardiff, United Kingdom
    Posts
    12,520

    My Social Networking

    Follow Broken Byzan On Twitter Add Broken Byzan on Facebook Add Broken Byzan on Google+ Visit Broken Byzan's Youtube Channel
    My bad !!

    Give it a clean and either use VAGcom to reset, or prvoiding you have your radio code dissconnect your battery for 15 mins and reconnect. Then switch on ign without starting the car for 2mins. Switch off and then re start. That should reset the B after you clean it.
    Sorry i got you confused mate

  10. #9
    V.I.P_UAE's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2009
    Posts
    113
    Quote Originally Posted by Byzan A4 View Post
    What caused the sporadic airbag/abs/hazards if i may ask? wondering if its related?

    Have you tried an adaption of the throttle body?
    That was me, and it turned out to be a dodgy earth somewhere.

    Fingers crossed so far so good!

    Could VTI's problem be a maf sensor?? I have slight Idle issues at the moment but the other way when the revs drop it nearly cuts out before settling at 750RPM

    VTI is this like yours when its not revving its ****** off???

  11. #10
    leshkin's Avatar
    Speeding in reverse gear

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Northwood
    Posts
    678
    What you are describing can be either MAF or Trottle body... Cleaning both with mechanical alcohol or vodka (or petrol - carefull with those matches ) might help. As stated above, you would then need to realign the throttle body.

    I had the idle hunting issue on my old 1.8T and this was cured with this approach. The MAF getting fouled up is probably due to an aftermarket air filter i was running.

  12. #11
    Dani_B19's Avatar
    Audi-sports own special child.

    Status
    Offline
    Join Date
    Nov 2008
    Location
    Barnsley
    Posts
    7,233
    So if the maf appears to be broke then would cleaning help restore it back full working health?
    Driving the most secretive S3 on ASN

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Nov 2008
    Posts
    95
    there is a rubbish on cone filter on my car, could this of mucked up the MAF? was on the car when I got it.

    so you guess suggest cleaning the maf and throttle body?

  14. #13
    Dani_B19's Avatar
    Audi-sports own special child.

    Status
    Offline
    Join Date
    Nov 2008
    Location
    Barnsley
    Posts
    7,233
    Alot of people say the oil thats on the cones kill's the maf but alot of things can kill it though
    Driving the most secretive S3 on ASN

  15. #14
    Neutral

    Status
    Offline
    Join Date
    Nov 2008
    Posts
    95
    ok i just check everything i got with the car, and it had a brand new oem maf 2 months ago, so i guess it cant be that?

  16. #15
    HTC
    HTC's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    Koh Samui, Thailand
    Posts
    3,402
    disconnect the maf and see how it runs to rule it out completely.

    Could be a vacuum leak. Check all the breather pipes.

  17. #16
    Neutral

    Status
    Offline
    Join Date
    Nov 2008
    Posts
    95
    runs like a bag of **** when u unplug lol just tried that, sounds awfull.

    I had a vacuum leak before, and fixed that, car sounded totaly different to it did with that.

    at moment its not rev'ing to 3k anymore, which is strange :S its reving at about 1.5k, and stay that when totaly warmed up aswell

  18. #17
    HTC
    HTC's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    Koh Samui, Thailand
    Posts
    3,402
    Coil pack?

  19. #18
    Dani_B19's Avatar
    Audi-sports own special child.

    Status
    Offline
    Join Date
    Nov 2008
    Location
    Barnsley
    Posts
    7,233
    Just come back from the misses and on my way thought id unplug the maf and try the car, to be far there was hardly any difference, if the maf was knackered would i have been able to tell, i.e. would it have pulled harder etc?
    Driving the most secretive S3 on ASN

  20. #19
    Neutral

    Status
    Offline
    Join Date
    Nov 2008
    Posts
    95
    had all 4 coil packs replaced aswell, when i un pluged mine, kept sounding like it was about to stall, didnt sound healthy at all

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO