Badger5AH Fabrications
Results 1 to 13 of 13
  1. #1
    nick-barnes07's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2007
    Location
    gloucester
    Posts
    550

    CLUNKY CLUNKY, FRONT OF CAR CLUNKS

    Hi all, on my s3 the front seems to clunk, it only clunks when the car is lifting of or juddering, i replaced the 2 top mounts, cv boots, and top mount bearings, we have checked all the bushes and that but cant seem to find anything, as i said the car only really clunk's when you are either pulling of from stand still or when the car accelarates and lifts on the front, anyone had this problem?????????????????????????

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    2nd Gear

    Status
    Offline
    Join Date
    Jun 2007
    Posts
    446
    engine mounts?

    no luck selling it yet nick?

  4. #3
    nick-barnes07's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2007
    Location
    gloucester
    Posts
    550
    yeah its sold matt, just need to get the mounts done

  5. #4
    1st Gear

    Status
    Offline
    Join Date
    Jun 2008
    Location
    Epsom, Surrey
    Posts
    233
    Hi,

    i also have the same sort of problem but only when going over bumps and only since fitting coilovers and if i remember right it's only on the passenger side and that was the side which went down a hugh pot hole so think it may be the top mount bearing.

    Quote Originally Posted by nick-barnes07 View Post
    Hi all, on my s3 the front seems to clunk, it only clunks when the car is lifting of or juddering, i replaced the 2 top mounts, cv boots, and top mount bearings, we have checked all the bushes and that but cant seem to find anything, as i said the car only really clunk's when you are either pulling of from stand still or when the car accelarates and lifts on the front, anyone had this problem?????????????????????????

  6. #5
    Soon be christmas!!!!!!!!!!

    Status
    Offline
    Join Date
    Feb 2008
    Location
    North Wales
    Posts
    163
    arb drop links?? easy fix if it is

  7. #6
    jcs356's Avatar
    Brum brum

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Englandland
    Posts
    2,681
    Another vote for the ARB drop links.
    Jason
    2001 Nogaro S3 (daily driver)

    1958 replica Porsche 356 Speedster (summer posing)
    1997 Seat Cordoba SX 16v (track day toy) replacing (t)rusty 1994 Seat Ibiza GTi RIP

  8. #7
    nick-barnes07's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2007
    Location
    gloucester
    Posts
    550
    ill order some from my local tps tommorow

  9. #8
    Mr.G's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Nov 2008
    Location
    In a Tardis!!
    Posts
    1,302
    Mine needs top mounts im sure, had my drop links and bushes done so cant think what else it could be!

    G

  10. #9
    fran-s3's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Jan 2008
    Posts
    1,090
    Sorry to ressurect an old thread but was this the drop links? This is exactly what my car is doing, clunking lunks when the car is lifting of or juddering... Had the front arb and bushes changed and still the same.

  11. #10
    s3 ryan's Avatar
    ryan s3

    Status
    Offline
    Join Date
    Sep 2009
    Posts
    26
    same here ive changed the antiroll bushes for power flex ones and ive still got a clunking or sometimes a creak from the front drivers side when going over bumps! its annoying as hell is it worth changing the drop links or could it be somthing else?

  12. #11
    Kingston's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Preston
    Posts
    182
    My does the same first time was pads in Calipers so I fitted my nice new front brake kit and rear up grade.
    Still did it but sounded different mmm
    Had all bushes etc changed at front and everything else checked suspension the lot and still none the litter.

    So next on my list is new suspension and top mounts i'm sure this will sort it but as on my report the ones fitted are fine.
    Nogaro Blue 2001 S3 Quattro, Cream leather interior. Miltek Cat back, Induction kit, KO4 Hybrid Turbo, Chipped Remap, Power Boost Valve, Forge RC DV, Compbrake Racing 4 Pot Calipers with 2piece 350x32mm Conversion Front, 2 piece 330x20mm Compbrake Conversion on Back, Discs are Powervane Racing Rotors Gas slotted and internally veined. Hawk Hps Pads, Goodridge Braided lines to Calipers. Bose Symphony sound system. Compbrake Quickshift and side shift. Big thanks to www.Vagperformance.co.uk

  13. #12
    nick-barnes07's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2007
    Location
    gloucester
    Posts
    550
    i never got mine sorted so wasn't sure what it was ???

  14. #13
    s3 ryan's Avatar
    ryan s3

    Status
    Offline
    Join Date
    Sep 2009
    Posts
    26
    after changing wish bone bushes, top mounts etc i found out by taking the wheel off putting the car on an axle stand then jacked under the hub it was the anti roll bushes still making a noise even tho they are new powerflex ones so i took them off put loads of grease on and it went for 2 weeks without a noise but has started again! im contiplating changing the anti roll bar to an uprated one see if that makes a difference
    225 BAM with Stage 2 REVO map / 3" pipewerx downpipe and decat / powerflow system / Forge DV

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO