EM TuningChris Nott
Results 1 to 3 of 3
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2007
    Posts
    26

    forge splitR valve now engine lights on !help!

    hi

    im so peed off its unbeleivable , i always wanted the little woosh noise but knew the s3 engines cant use them so i never botherd getting a blow off valave, then forge come up with the splitr valave that diverts the air but also releases 30 % to atmosphere,

    well i had it on for a couple of days no problems then after trying to boot it at the lights i suddenly lost power and felt like there was no boost ,, car just wasnt picking up speed the way it used to,,, so i was just waiting for the engine light to come on which after 30 mins it did.

    car was running fine before i changed the dv

    im thinkiing to just put the blanking plate of the dv valve and make it just recirculating

    has any one else experienced this problem ??

    thanks

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    S£'s Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2008
    Location
    Suffolk
    Posts
    669
    Might not have been the DV, does sounds like Limp mode... although it probably was the cause of it. When i bought my S3 it had a Atmospheric DV on which i ran for a month like it, it ran fine but it was relocated to the cold side, and also had the N249 valve bypassed.

  4. #3
    4th Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Manchester
    Posts
    724
    Hi
    Did you fit the SplitR as per instructions?
    They need to be fitted cold and then set up
    This is quite important to do

    Sarah

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO