Monster MotorsportVolks Autos
Results 1 to 14 of 14
Like Tree1Likes
  • 1 Post By Mickeybhoy67

Thread: Throttle position sensor

  1. #1
    Neutral

    Status
    Offline
    Join Date
    Feb 2006
    Location
    glasgow
    Posts
    45

    Throttle position sensor

    Don't mean to be stupid but can anyone tell me where it is located on an Audi A3 98?
    Cheers an advance!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    HTC
    HTC's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    Koh Samui, Thailand
    Posts
    3,402
    It is incorporated into the the throttle body under the black plastic cover.

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Feb 2006
    Location
    glasgow
    Posts
    45
    Is it easy to replace????

  5. #4
    HTC
    HTC's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    Koh Samui, Thailand
    Posts
    3,402
    Just to double check, you have a cable operated throttle, correct and you are getting some sort of error code relating to the throttle position sensor?

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Feb 2006
    Location
    glasgow
    Posts
    45
    Yes that is correct

  7. #6
    HTC
    HTC's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    Koh Samui, Thailand
    Posts
    3,402
    Just checking it wasn't DBW.

    You could try disconnecting the battery for about 20mins and then re-aligning the throttle body. Do this by turning on the ignition without starting the engine or touching the throttle body. Wait for the high pitched noise from the throttle body to stop and then see how you go.
    If it's still not right then it's a new throttle body unfortunately as the sensor cannot be removed separately as far as I know.

    Is the car not idling or something?

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Feb 2006
    Location
    glasgow
    Posts
    45
    I took to a couple of garages, one of which was an Audi specialist in Duntocher who done a diagnostic which gave out the following faults:

    00518 - Throttle Position Sensor (G69)
    31-00 - Open or Short to Ground

    01087 - Basic Setting Not Performed
    27-00 - Implausible Signal

    00530 - Throttle Position Sensor (G88)
    31-10 - Open or Short to Ground - Intermittent

    Basically the car starts ok when I turn the key however it dies straight away. I have to keep my foot on accelerator for a few minutes to keep the revs up then car is ok however idle set usually at 1ish
    Mido likes this.

  9. #8
    HTC
    HTC's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    Koh Samui, Thailand
    Posts
    3,402
    Yup, sounds buggered. It will probably be a new throttle body then. The specialist should first check the wiring though, just in case its a wire break rather than a component failure. However, I suspect it's the latter.

    Have a look on Ebay as the dealer will want about 430 for a new one.

  10. #9
    Neutral

    Status
    Offline
    Join Date
    Feb 2006
    Location
    glasgow
    Posts
    45
    Its not the throttle body as I took into my local garage and they tried another throttle body, and took another diagnosis which gave the exact same readings!!!!!

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2013
    Posts
    4
    I have the same problem and I replaced the throttle body and it still the same
    if you fixed it please tell me how

  12. #11
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2013
    Posts
    4
    Quote Originally Posted by Mickeybhoy67 View Post
    I took to a couple of garages, one of which was an Audi specialist in Duntocher who done a diagnostic which gave out the following faults:

    00518 - Throttle Position Sensor (G69)
    31-00 - Open or Short to Ground

    01087 - Basic Setting Not Performed
    27-00 - Implausible Signal

    00530 - Throttle Position Sensor (G88)
    31-10 - Open or Short to Ground - Intermittent

    Basically the car starts ok when I turn the key however it dies straight away. I have to keep my foot on accelerator for a few minutes to keep the revs up then car is ok however idle set usually at 1ish

    same problem need someone to tell us how to fix it

  13. #12
    RGL
    RGL's Avatar
    Free breather

    Status
    Online
    Join Date
    May 2013
    Location
    Way up north
    Posts
    45
    As someone already mentioned, it is possible that the throttle body itself stopped working properly. However it would be wiser (and much cheaper) to first try to check all the wires running to and from it for splits or any other damages, since these "Open or short to ground" and signal codes have often to do with the wiring. Cleaning the throttle body can't hurt either but I'm pretty sure it won't fix those faults. Either it's the wiring or the throttle body itself has lived it's life. Just try all non-cost/cheap measures like checking the wiring, cleaning and re-aligning first.

  14. #13
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2013
    Posts
    4
    I replaced the throttle body and these errors remained
    00518 - Throttle Position Sensor (G69)
    31-00 - Open or Short to Ground

    00530 - Throttle Position Sensor (G88)
    31-10 - Open or Short to Ground - Intermittent

    I checked the wires and it seems ok .. and all fuses ok and cleaned the throttle body
    I don't know what else to do

  15. #14
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2013
    Posts
    4
    does Audi A3 1998 1.6 petrol throttle pedal has a sensor ??
    if it does where its location plz

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO