Sky InsuranceJMB Retrofits
Results 1 to 4 of 4

Thread: Radiator Leak!

  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2007
    Posts
    3

    Radiator Leak!

    Hi there.

    I've recently started learning to do things for my Audi A3 1.9tdi (V-Reg, 1999) so I'm no expert. I had a little problem with my car, and was told by a garage that my radiator was causing it (car hitting 90 degreese VERY quickly & loss of coolant over a period of a few weeks). I topped up the coolant a few times over the last month or two, but it keeps happening - the warning light comes on on the dashboard display, and the expansion tank is EMPTY! I decided to do what the garage said - and jeez, he was right - the radiator in my car was battered, and it had dried pink ooze at the bottom of it - clearly been leaking. Anyway, all new radiator has been fitted. Since I've done this though, I spotted a leak when I was flushing the system with water - the lower radiator hose seemed to be drippping, ever so slowly. I have since replaced this, and it seemed to make the problem go away whilst i ran the engine to test for more leaks, but it appears now that something else is leaking - the ECT sensor which is just above that hose, connected to the radiator. Like I said, I'm no expert, but I don't understand how something like that could leak - if so, is it as simple as replacing the ECT sensor, and spotting any more leaks? Should I go main dealer or GSF? And, I've read somewhere about a new "green" ECT that is supposedly better than the standard black one. Any help is greatly appreciated. Thanks.

    Taj.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    1animal1's Avatar
    The Clar!! it mouves!!!

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Sheffield
    Posts
    9,990
    egg yolk lol.......no dont
    Xbox 360 gamer ID : Timffy

    Grey Triumph Sprint 1050 ST
    Silver BMW 535D Tourer - Fully loaded 340BHP 700NM torque
    2009 8P3 S3 Brilliant Red - Sold
    2001 F/L S3 Dolphin Grey - Sold
    1999 Pre F/L Silver A3 1.8T - Sold

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Dec 2006
    Posts
    190
    I take it you mean the fan switch screwed into the rad? could be that its not screwed in properly, try tightening it up a bit. if you want to replace it, anywhere will do it, not just gsf or main dealer. try any motor factor.

  5. #4
    davidhodgkinson's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    lancashire
    Posts
    198
    I think you mean the temp sender.

    Have a look on VAGPARTS for the sensor and replace the rubber o-ring seal and the locking clip
    Was A3 1.8Ts
    Now S3

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO