Chris NottSky Insurance
Results 1 to 26 of 26

Thread: Haldex problem

  1. #1
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062

    Haldex problem

    Hey guys

    changed my haldex controller the weekend for a standard one, ever since then its only been front wheel drive. A little oil came out but not alot really. So i put the uprated one back on, and still its front wheel drive. Checked fuse number 31 looks fine. What else can it be? Also how do you check the haldex oil level and change it?
    Thanks

    Xbox online id - supaed133

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    1animal1's Avatar
    The Clar!! it mouves!!!

    Status
    Offline
    Join Date
    Dec 2007
    Location
    Sheffield
    Posts
    9,990
    eeerrrrrmmmmmm...... couldnt you ask a simple question
    Xbox 360 gamer ID : Timffy

    Grey Triumph Sprint 1050 ST
    Silver BMW 535D Tourer - Fully loaded 340BHP 700NM torque
    2009 8P3 S3 Brilliant Red - Sold
    2001 F/L S3 Dolphin Grey - Sold
    1999 Pre F/L Silver A3 1.8T - Sold

  4. #3
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    Meaning its only front wheel drive 4wd dosent engage. i just get loads of wheel spin

    Xbox online id - supaed133

  5. #4
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,436
    I recommend you do a vagcom check on your car ed, sounds like a loose connection or something, if it was working before.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  6. #5
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    anyone with VAGCOM in the area?!

    Xbox online id - supaed133

  7. #6
    Slipping at 3.5Krpm

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Berkshire
    Posts
    1,951
    I have it (A4 Twyford/Wargrave) and Nick Evelry has it (Jct 11)
    <Insert meaningless geeky specs here>

  8. #7
    Longman's Avatar
    vassdignostics.co.uk

    Status
    Offline
    Join Date
    Jul 2007
    Location
    Nr Maidstone, Kent
    Posts
    113
    I agree, VAG-COM will show if there are any communication problems between the ECU and the Haldex controller. Thats what I would expect to see.

    Have you got an ABS or Traction Control light on the dash?

    Remind me is fuse 31 one of the ones above the battery. If not I would check them too?

  9. #8
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    no its the one one in the car. could it be one of those fuses then?! Are you about the weekend at all dave could you have a check over for me?! If it was low on oill would that cause it not to work?

    Xbox online id - supaed133

  10. #9
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    oh and no lights on the dash have come up!

    Xbox online id - supaed133

  11. #10
    Slipping at 3.5Krpm

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Berkshire
    Posts
    1,951
    I'm about the weekend Ed, if you make your way over to mine I'll check it for you no problem. Send me a PM.

    Dave
    <Insert meaningless geeky specs here>

  12. #11
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,436

    Talking

    Quote Originally Posted by Dave_Bayern View Post
    I'm about the weekend Ed, if you make your way over to mine I'll check it for you no problem. Send me a PM.

    Dave

    I recommened you take it for a quick spin also and give us some feedback Dave.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  13. #12
    Longman's Avatar
    vassdignostics.co.uk

    Status
    Offline
    Join Date
    Jul 2007
    Location
    Nr Maidstone, Kent
    Posts
    113
    Yeah, let us know how you get on.

    One of the large fuses under the bonnet over the battery is for ABS/TC communication. I looked at Ballcrushers car on here with a communication prob to the Haldex and ABS and it was a connection to that fuse that was shot.

    Well worth a check.

    V/C will show this anyway.

  14. #13
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    Checked the fuses on top of the battery they were all ok! Guess we will have to see what VAG COM says!

    Xbox online id - supaed133

  15. #14
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    well dave check the vag com and after he cleared everything, no other faults came up. Still only front wheels drive tho. So i changed the haldex again for the standard one and changed the oil still not working! If its to low on oil would stop it working? Any other ideas?

    Xbox online id - supaed133

  16. #15
    Slipping at 3.5Krpm

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Berkshire
    Posts
    1,951
    Only thing that came up on yours was brake light switch - intermittent.

    However, it also came up under the AWD control module, is that something that affects the haldex operation?
    <Insert meaningless geeky specs here>

  17. #16
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    what is the AWD module?!

    Xbox online id - supaed133

  18. #17
    Dave B's Avatar
    REALITY?.... WHERE AM I AGAIN?.... WHO AM I AGAIN?

    Status
    Offline
    Join Date
    Apr 2007
    Location
    Oxfordshire and Sofia
    Posts
    176
    Could it be that the AWD/Haldes systems can't see the brake applications to read how to apply 4wd ratio's?

    Dave
    Silver S3 OE03, PH sticker in Rear Window,

  19. #18
    6th Gear

    Status
    Offline
    Join Date
    Feb 2004
    Posts
    2,036
    Well if the hadbrake is aplied, the handbrake has a switch which disables the haldex.

    Maybe its the same with the foot brake.....?

  20. #19
    Longman's Avatar
    vassdignostics.co.uk

    Status
    Offline
    Join Date
    Jul 2007
    Location
    Nr Maidstone, Kent
    Posts
    113
    Edward: AWD moduile is what controls the 4wd system (All wheel drive)

    I would definitely start with the brake light switch if it has come up on both controllers. It would make sense for it to diable the haldex if there was a problem like that.

    Its under the dash behind the pedal.

  21. #20
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    but the brake lights are working fine! They were playing up before, so i adjusted it and works fine now!

    Xbox online id - supaed133

  22. #21
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    Quote Originally Posted by Der Teufel View Post
    You should buy an Alfa mate, much nicer looking that than the fat german barges built by AUDI.
    Then i would always have problems!!

    Xbox online id - supaed133

  23. #22
    alijames's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2008
    Location
    Oxford
    Posts
    1,017
    Are we getting BORED again?

    Cheers,
    Alistair

    "Why don't you listen to something really classical, like Mozart, Mendelssohn or Motorhead?"
    Arnold Rimmer, 1988

    Commuting & Weekend Fun:
    Yamaha YZF-1000R Thunder Ace in Blue/Black

    Practical Alternative (Still fun though!!):
    S3 2002/51 AMK Silver, Symphony II + Bose + xCarLink + AndyMac Stealth Sub, Metallic Mirrors, Heated Black Leather, Cruise control.

  24. #23
    scott_johnson's Avatar
    Audiless

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Bingley
    Posts
    875
    Ed, how did you remove the haldex controller. is it easy???

  25. #24
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    it is if you have a ramp and a ratchet with a pivot on the end other wise it can be tricky getting to the top bolt! I used a small allen key the first time! Why do you need to take yours off?!

    Xbox online id - supaed133

  26. #25
    scott_johnson's Avatar
    Audiless

    Status
    Offline
    Join Date
    Jan 2008
    Location
    Bingley
    Posts
    875
    got a fault thats always there from vagcom. haldex memory controll error. Was goin to wack it off and see if there was anything up with it!!

  27. #26
    edward_harris's Avatar
    s3 gone now a shiney red evo 6

    Status
    Offline
    Join Date
    Jan 2007
    Location
    berkshire, Reading
    Posts
    1,062
    it would prob be a electrical prob with it, and i guess the only way to sort it would be a new controller or get someone to repair yours!

    Xbox online id - supaed133

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO