Chris NottBadger5
Results 1 to 6 of 6
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    May 2003
    Location
    North London, UK
    Posts
    13

    Power Loss / Turbo Problems??

    Ive had power loss problems with my 2001 S3 over the last 3 months, the turbos have been cutting out whilst driving/accelerating, especially at higher speeds, there have been times when they havent even kicked in. The computer didnt register a fault but the Audi technician said that the turbos were over boosting? providing too much pressure? They took it on a road test a couple of times before they experienced the fault. I dont have a clue about these things. But they ordered me a new turbo.

    Has anyone else had these problems?

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Offline
    Join Date
    Dec 2003
    Location
    Stockton-on-tees
    Posts
    151

    Re: Power Loss / Turbo Problems??

    [ QUOTE ]
    S3 Freak said:Has anyone else had these problems?

    [/ QUOTE ]

    A Big YES,
    i've an A3 TDI Quattro which has been modded by previous owner (not sure as wether just a remap or some kind of tuner box also) but when driven hard my turbo can cut out (limp home mode super chips call it) caused by overboosting and a simple pulling over and turning ignition off/on resets it and its fine until next time.
    Whatevers been done to my car must be well hid as the car was thoroughly checked/tested by audi (2 garages) and eventually Audi special tech's and after a new flow meter, gate, hosing and new TURBO the fault is still present.
    Audi techs said that the logged fault was very vague.
    It simply registered "FAULTY TURBO" Which according to the guys at Audi meant that they had to check/replace around 18 minor components before the Mighty turbo.
    So depending if you've only been to see them once/twice and the cars still under warrenty then getting a new turbo is all good!
    Is your car modded? (remap etc)the reason i ask is that another member of this forum R-Quattro had the same problem as myself and both our cars are modded.
    Cheers

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    May 2003
    Location
    North London, UK
    Posts
    13

    Re: Power Loss / Turbo Problems??

    Ive just had the Lambda 2 probe (oxygen sensor?)changed and so far so good, no turbo cut out. I just hope it stays that way

    My car has not been modified as its fast enough for me as standard.

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    May 2003
    Location
    North London, UK
    Posts
    13

    Re: Power Loss / Turbo Problems??

    Well, got the car back, everything was ok for a couple of days then it happened again, I keep losing the turbo.

    And on top of that, the fuel senders are going crazy, even after the instrument cluster change.
    Its going back in on Tuesday. Im getting really annoyed now, I just want it sorted. This will be the 5th time in the garage in the past few months.

    God help me

  6. #5
    1st Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Sydney, Australia
    Posts
    262

    Re: Power Loss / Turbo Problems??

    gutted!

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    May 2003
    Location
    North London, UK
    Posts
    13

    Re: Power Loss / Turbo Problems??

    yes, well and truly

    Well its gone back in today, my fingers and legs are crossed


    I just want my S3

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO