Monster MotorsportEM Tuning
Results 1 to 17 of 17
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    May 2007
    Posts
    2

    Problems with "Door Open" display on dash

    Hi , i was wondering if anyone can help , i own a 2001 Audi A3 tdi sport and have recently been experiencing a problem with my dash display showing up that my drivers door is open when it isnt ...the only way i can get it to go out is by constently opening and closing the door until it goes out....any ideas ? ....if it wasnt for the fact that the interior lights come on when the door open display is showing i could probably live with it ...! HELP!!!!!!!!!!!!!!!!!!!!!!!!!

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    aidank1981's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Shetland Islands
    Posts
    251
    its really commen mate, loads on here! its the micro switch in the lock unit, you can clean it with contact cleaner etc but it'll eventually die! ive just bought a new one from audi for 39.97+vat part no 8L2837016B (DRIVER SIDE S3 MIND) surely a small repair but a bit job stripping to door down....
    Audi S4 Black on Black. 1999(T)facelift, Aluminium Mirrors, KW Varient 3 coilovers, AmD remap, uprated D/V's, 315bhp375Lb/ft torque, milltek down, 100cpsi cats an back, S4 B6 18" Oem runnin toyo T1-R's. Rs4 B5 front brakes still to fit...


  4. #3
    Toxik-Signal's Avatar
    Andy

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Nottingham
    Posts
    357
    Yeah I've got this problem too on my 1.9 TDi (2001).

  5. #4
    buckas's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Sep 2006
    Location
    south west wales
    Posts
    750
    it's occurs most frequent when the car has been sitting a while with the sun on it i've found

  6. #5
    Audi S3 (2000)

    Status
    Offline
    Join Date
    Mar 2007
    Posts
    303
    Quote Originally Posted by buckas
    it's occurs most frequent when the car has been sitting a while with the sun on it i've found
    yeh mine does the same, park in the shade and its fine

  7. #6
    rickparmar's Avatar
    va va voom

    Status
    Offline
    Join Date
    May 2004
    Location
    Leicester
    Posts
    2,269
    Quote Originally Posted by buckas
    it's occurs most frequent when the car has been sitting a while with the sun on it i've found
    so true

    i cant justify spending 40+ just to fix it, i can live with it, just switch interior lights off, and as soon as you sit in press the dis controller so it shows somthing else

    but i heard the alarm isnt fully armed or somthing
    ~ ~ ~2003 Audi S3 BAM ~ Ming Blue ~ 18" BBS Alloys ~ Heated Black Leather ~ Forge DV ~ RNS-E ~ denison ipod link~ parrot mk6100 bluetooth ~ ~ ~

    Still need Remap

    2007 Audi S3 8L
    2005 Audi A3 1.6 sport grey with climate control
    2003 Audi A3 1.6 sport black without climate contol

  8. #7
    hud at ye bam

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Aberdeenshire
    Posts
    2,231
    Same issue here. I find that a little WD40 sprayed into lock works for a few days, otherwise slamming the door several times seems to sort it, especially after a mile or so of driving.

    Riks suggestion is equally as good.
    [/sarcasm]

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Stockport
    Posts
    241
    About the alarm, from what i've heard if you lock the door with the door problem the red lights don't flash on the doors and I think the internal sensors are disabled

    Someone correct me if I'm wrong?
    51 reg A3 1.8 Sport, 17"TT Alloys, Centre Arm, Leon Spliter.

    Stockport

    17 - Pug206, 19 - Punto, 23 - A3



    http://s154.photobucket.com/albums/s...rst_widget.pbw

  10. #9
    nick-barnes07's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2007
    Location
    gloucester
    Posts
    550
    i find opening the door wide open and slamming it once makes it go of , never seems to go of when i just open and slam the door , i have got to fully open it

  11. #10
    vrbob's Avatar
    Thats no Moon, Thats a space station!

    Status
    Offline
    Join Date
    Jun 2007
    Location
    Southampton
    Posts
    2,279
    Glad other people are having this issue as i thought it was just me.
    I have noticed the sun thing too does the micro switch overheat or something??
    I have just got used to shutting the door firmly whenever i get in or out of the car and also making sure the red lights are flashing when i leave the car.
    Audi S3 8L BAM 225 2002 - Ming Blue : Silver Heated Leather, Armrest, RNS-E - Bose, Alloy Mirrors, 18" RSTT`s, Sunroof, Cruise, AutoDim Mirror & Usual S3 Extras.
    Mods : Revo Stg 2 & Select+, FMIC, 3" DP & 200 Cell Cat, 007P, Jetex Filter & 80mm TIP & Heatshield, Complete LED Kit, Gen VW Aero Wipers, Full Powerflex Kit, R32 RARB, AP Shocks & Springs, 15mm Front & 20mm Rear Spacers, BB Uprated Actuator,
    N249 Delete & Catch Can, AP TVR 4Pot Brakes & DS2500`s, Sachs Carbon/Kevlar Clutch

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    Jul 2007
    Location
    Huddersfield
    Posts
    218
    Yep i have this problem as well.
    I re aligned the door a few weeks ago and it does not do it as often now.
    Again i just turn the interior light off and press the dis button go get rid of the door open display.

    Just gonna live with it

  13. #12
    batwad's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Jul 2006
    Location
    Beds
    Posts
    841
    Yes, it's a stunningly common problem. I had mine done by Audi (under warranty fortunately) last month. The dealer confirmed that the alarm does not arm if the car thinks one of the doors is open, so you're compromising the security of your car by not fixing it.

    Mind you, the A3's alarm is pretty feeble...
    03 A3 (8L) TDi quattro Sport, Aluminium Silver with leather, armrest, cruise, xenons and me at the wheel

  14. #13
    Reverse Gear

    Status
    Offline
    Join Date
    May 2007
    Posts
    2
    thanks for all your posts guys ...well helpfull apart from the cure !!!! ...does anyone know what causes this problem ? where is the micro switch located? what does it look like? is it a big deal to replace? if it isnt too hard a job ,has anyone come across the possibility of a 2nd hand one being fitted?

  15. #14
    Gti Jazz Blue's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Feb 2007
    Location
    Hampshire
    Posts
    1,654
    If it is the same as efflicted the Mark IV Golf it is one of two things :

    1. The micrososwitch that confirms that the door is close / open is gunked up with spray lube from when the locks are lubed. (part of the lock mecahnism)

    2. A dry joint on the circuitboard in the lock mechanism.

    On the Golf if it was the drivers door, it has been know for people to lock their keys in the car as they would unlock the car chuck the keys on the seat, and shut the drivers door to get something else, and as the alarm didn't realise that the door had been opened the autolock reactivated, locking the keys in the car.

    You have been warned.

    Paul
    2011 (MY12) Skoda Octavia II FL VRS Manual Hatch 2.0Tsi in Race Blue.
    Gone not forgotten -
    2005 Black A3 (8P1) S-Line 2.0TDi DSG. Eibach Pro Springs, Koni FSD shocks and a few bling bits inside.
    Revo 99 GTi Turbo, too much to list mod wise.
    92 Golf Gti Mark 2 16V.

    VCDS HEX-USB+CAN

  16. #15
    QUATTRO_REP's Avatar
    Diesel Power!

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Manchester
    Posts
    228
    yep i had this prob now..i squirted loads of WD40 init and i havent had it since...it did seem to occour during hot days tho,,, and as we hanvent really had many of those this year i dont know if its because of that!
    Audi A3 52 | 1.9TDI Quattro | Chipped 175 BHP | Hids |

  17. #16
    buckas's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Sep 2006
    Location
    south west wales
    Posts
    750
    Quote Originally Posted by garratt83
    About the alarm, from what i've heard if you lock the door with the door problem the red lights don't flash on the doors and I think the internal sensors are disabled

    Someone correct me if I'm wrong?
    yeh, because it thinks the door is ajar, then it doesn't arm the alarm properly, as when you lock it, the red lights or indicators dont flash

    drew

  18. #17
    1st Gear

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Stockport
    Posts
    241
    Well thought I would see if I could get the microswitch and clean it today.

    Took the side of the the door off but then was stuck couldn't find anything to clean.

    Anyone point me in the right direction?

    Cheers
    51 reg A3 1.8 Sport, 17"TT Alloys, Centre Arm, Leon Spliter.

    Stockport

    17 - Pug206, 19 - Punto, 23 - A3



    http://s154.photobucket.com/albums/s...rst_widget.pbw

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO