Monster MotorsportJMB Retrofits
Results 1 to 11 of 11
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Oct 2006
    Posts
    41

    Oil light warning resulting in toe home, anyone recognise this problem?

    Hi,

    Well i bought a 98 A3 1.8T sport with 100k on the clock with FASH around a month ago, and i must say up untill now its been great. Then last night was on my way back to Huddersfield when the Oil pressure warning light came on the dash in the middle, so obviously i pulled over straight away. I also noticed that it was sounding rather like a diesel, which it didnt before.

    Now i know the oil was bang height on when i left, and i couldnt see any leaks. I phoned RAC to come and get me and when they arrived, we started her up so he could see what the problem was (as relucktant as i was!) but to my suprise the 'OK' light was showing and the car sounded sweet as a nut again......????

    So we decided that i should drive back with him following and if it occured again he would toe me. I got all of 100m down the road when it happeded again, so i pulled over once more and turned the engine straight off. Apparantly a big cloud of blue smoke came out of my exhaust at the same time as the light came on......? Neither of us could put our finger on this (im no expert and he didnt really know audi's as theyre pretty reliable)

    So my car got toed home and is being taking it to the garage today, but id just thought id see if anyone else has had a similar experiance. Im praying that its not going to cost a fortune but tbh it doesnt look hopefull.....

    Any help appreciated.

    Cheers

    Sam

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    markyp2002's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Burntwood
    Posts
    301
    erm, blue smoke, sounding like a diesel?

    did you notice a drop in power aswell?

    i would beg to differ on head gasket mate, hope its not tho!
    A4 B7 2.0 TDi S-Line Special Edition Gloss Red, BOSE, 18" Black RS4s, Black / Grey Leather, Sat Nav

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Oct 2006
    Posts
    41
    what sort of money would we be talking to get that sorted? comon sence is telling me its not going to be cheap.....

  5. #4
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Posts
    2,488
    sounds like the oil pump has died.


  6. #5
    Neutral

    Status
    Offline
    Join Date
    Oct 2006
    Posts
    41
    how would the oil pump cause it to smoke? this is what i initially thought. any idea's on costing to put right?

    Cheers
    Sam

  7. #6
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Posts
    2,488
    if the oil pump has died, then it could have possibly caused other components to fail too, especially if you drove on.

    The advice to restart the engine and carry on driving was BAD advice.

    Could potentially be either head gasket or turbo with those symptoms.


  8. #7
    Neutral

    Status
    Offline
    Join Date
    Oct 2006
    Posts
    41
    Quote Originally Posted by madvw
    if the oil pump has died, then it could have possibly caused other components to fail too, especially if you drove on.

    The advice to restart the engine and carry on driving was BAD advice.

    Could potentially be either head gasket or turbo with those symptoms.
    Cheers RAC, i'll be going to AA then come renewal....

  9. #8
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Posts
    2,488
    this thread looks like essential reading for you:

    Oil Pump Failure

    follow the pistonheads links too.


  10. #9
    Neutral

    Status
    Offline
    Join Date
    Oct 2006
    Posts
    41
    Quote Originally Posted by madvw
    this thread looks like essential reading for you:

    Oil Pump Failure

    follow the pistonheads links too.
    Cheers mate, thats a great help. reading it it sounds exactly the same as what happened to me. just hope i havent damaged the engine further!!!

    Sam

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2006
    Posts
    3
    sam 20Vturbo,

    It will be your oil pump. Same thing happend to me on the start of a 60mile journey home in the middle of the night - (cover your ears) I kept on driving the rest of journey with no oil running through the system.

    100 later a new oil pump and oil change she was fine. Sounded like a diesal combined with a old tappy engine, I thought I'd f**ked it up big time but was ok.

  12. #11
    Pete69zx
    Guest
    Bloody hell Sam, that doesnt sound so good. Hope you managed to get it fixed cheaply!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO