Chris NottMonster Motorsport
Page 1 of 2 12 LastLast
Results 1 to 40 of 60
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Newcastle
    Posts
    24

    Lcd display faulty

    Just picked up my 1998 A3 t sport and ive noticed the main lcd diplay seems to have some lines which do not illuminate correctly or at all, but the display itself shows all of the various things it should.

    Any one got any ideas what it costs to repair this at audi?

    (I have a 28 day warranty from the garage (not an audi garage) i purchased this from but not sure if they would cover this).

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,586
    The LCD requires the whole dashpod/clocks to be replaced, something like £350+vat and labour, exchange! And it can only be done at Audi, as they need to get the right codes for it to work with your car!!
    I just leave mine off, it's a PITA, but not worth the 500 notes or so just to see useless information imo.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  4. #3
    monkeytrousers's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    East Sussex
    Posts
    372
    It's a common fault. Fortunately mine is fine but it seems to come with the car's age so fingers crossed it holds.

    Or did the later models have the fault fixed?
    Audi A4 3.0 TDI Quattro 2008 - Ice Silver

    JUST GONE: BMW 330i M Sport Saloon 2006 - Le Mans Blue

    GONE BUT NOT FORGOTTEN: Audi S3 Quattro 2002 - AMD stage 1 - 261BHP - MTM clutch - Brilliant Black

  5. #4
    ANDYTQ's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Oct 2003
    Location
    Caerdydd, Cardiff, United Kingdom, United Kingdom
    Posts
    951
    Mine is just starting to go like this,gutted.
    06 A4 AVANT QUATTRO 2.0T S-LINE SE,GARNET RED, RS4 REAR ARB,SPACERS ALLROUND,H & R SPRINGS,B5 PERCHES,A6 V8 RIMS.PORSCHE CAYENNE TURBO S SIX POTS .REVO ST2 MAP ,MILLTEK CATBACK EXHAUST,PANEL FILTER,034 INTAKE PIPE.

  6. #5
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Posts
    2,488
    AndyUK it's not inbetween the top and bottom parts of the DIS is it? if so there's not meant to be any there...

    otherwise, yes, its on its way out and hammer the warranty for it.


  7. #6
    Markb's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Midlands, Staffs
    Posts
    2,136
    Mine is starting to go also.

    I just keep it turned off to save the screen and view it when required.
    Pirates black Honda Accord Type-R VTEC

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Newcastle
    Posts
    24
    how do i turn it off?? (and then back on again if i want to)?

    Its only certain areas of the screen, like the 'g' in 'mpg' doesnt display properly, top right doesnt seem too clever either.

  9. #8
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,586
    Quote Originally Posted by AndyUK
    how do i turn it off?? (and then back on again if i want to)?

    Its only certain areas of the screen, like the 'g' in 'mpg' doesnt display properly, top right doesnt seem too clever either.
    The reset button on the underside of the wiper stalk, press it to go off, and press again to come back on, only a quick press though, a long press resets the trip meters.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  10. #9
    paul_brad's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Leicester
    Posts
    365
    ive had my car for 2.5 years (now 6 years old) and its always had lines coming in and out, depending on its mood. Normally 1 or 2 lines are out at any given time. Its never got any worse during this period to be honest.

  11. #10
    4th Gear

    Status
    Offline
    Join Date
    Jun 2006
    Posts
    831
    The thick vertical orange lines on mine fade depending on how hot the cabin is!

    Can you not code a new dashpod using VAG-COM?

  12. #11
    dultanur's Avatar
    all promises, no action :)

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Istanbul,Turkey
    Posts
    407
    mine too

    antone know which specific part is failing? maybe we can change just that part?
    2000 Black S3 (Sold, then totalled) - 2008 A3 1.4T Sport

  13. #12
    monkeytrousers's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Jul 2004
    Location
    East Sussex
    Posts
    372
    Quote Originally Posted by dultanur
    mine too

    antone know which specific part is failing? maybe we can change just that part?
    Not possible. The whole instrument cluster needs changing.
    Audi A4 3.0 TDI Quattro 2008 - Ice Silver

    JUST GONE: BMW 330i M Sport Saloon 2006 - Le Mans Blue

    GONE BUT NOT FORGOTTEN: Audi S3 Quattro 2002 - AMD stage 1 - 261BHP - MTM clutch - Brilliant Black

  14. #13
    1st Gear

    Status
    Offline
    Join Date
    Aug 2005
    Location
    Leeds
    Posts
    144
    I didnt even know the 1998 A3s displayed mpg etc.

    Ive got a 1999 & didnt know about it i guess mines knackered too then? i get all the usual digital mileage reading etc, bur no mpg etc.

    Has anyone got any pics of what it should look like working?!
    Last edited by turbodan; 26th October 2006 at 16:21.

  15. #14
    KEF A3 20V T's Avatar
    Turbo's Rule

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Whitby
    Posts
    198
    this is in my 98 a3 it does read mpg but its not there cos i wasnt doing ne miles (parked up) the end of the washers stalk is a button to scroll through the menu! can record trip info too!

  16. #15
    JohnS3's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2004
    Posts
    3,021
    Quote Originally Posted by Tallpaul
    Can you not code a new dashpod using VAG-COM?
    Don't think so. It's got something to do with the vehicle mileage. May be wrong on that though....


  17. #16
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    London during week & Aberdeen at weekends
    Posts
    22
    Yeah, I've got a couple of horizontal lines of sometimes "dead" sometimes "live" pixels. Just depends on how the car is feeling, it doesn't seem to be linked to any one thing in particular i.e. cold mornings, wet conditions etc. Fortunately they are in places where there is not normally anything displayed. I do what others have recommended and normally just switch it off for a wee rest!

    As it came out the box!

  18. #17
    1st Gear

    Status
    Offline
    Join Date
    Aug 2005
    Location
    Leeds
    Posts
    144
    I dont have a button on the end of my washers stalk

    Its a 1999 A3 TDI

    Strange huh?!

  19. #18
    4th Gear

    Status
    Offline
    Join Date
    Jun 2006
    Posts
    831
    Quote Originally Posted by turbodan
    I dont have a button on the end of my washers stalk

    Its a 1999 A3 TDI

    Strange huh?!
    Do you have DIS?

    How do you reset things like average mpg?

  20. #19
    1st Gear

    Status
    Offline
    Join Date
    Aug 2005
    Location
    Leeds
    Posts
    144
    My car hasnt displayed mpg since i bought it last year and thought only the facelift models had this feature.

    If i wanted display info such as temperature etc, id have to display it on the air con/climate display with a combination of keypresses!

  21. #20
    4th Gear

    Status
    Offline
    Join Date
    Jun 2006
    Posts
    831
    Guess it wasn't standard on your spec. My '98 1.8T Sport has it.

  22. #21
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2006
    Location
    Newcastle
    Posts
    24
    Ah excellent.

    Getting 23mpg driving like a nutter and 30mpg normally.

    Handy or useless? im not sure

  23. #22
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Johannesburg, South Africa
    Posts
    5
    Dont let the Audi garages fool you, the whole cluster does not need changing. Mine did exactly the same thing, worse on hot days, better on cooler days. Audi also said change the cluster, I thought forget it! I took it out, there's 3 plugs on the back. Turn it over, there's a few torx screws, take those out, and loosen the black clips which hold the clear face to the rest of the cluster.
    What happens is the lcd display glass has a thin ribbon cable on its right hand side that powers the display, the bonding/glueing on this ribbon cable comes loose, doesn't make proper contact thats why the lines come and go.
    Over the top of the display is a metal cover plate held on by 4 legs bent on the back of the pc board. Straighten these, and it comes off. WORK GENTLY!!!
    Then you can remove the lcd glass. Be careful, don't loose the 2 pieces of plastic behind the lcd glass. IT WILL NOT WORK WITHOUT BOTH OF THESE.
    Then, either take the lcd panel to a good electronic company to re-bond the ribbon cable for you, or find a place that makes and sells lcd displays.
    Don't worry about the codes either, so long as you disconnect the cluster with the ignition off, once you plug it back, everything will work fine.

    I did mine myself, just added 2 extra strips of thin rubber strip behind the lcd on either side, and made the metal cover press down slightly harder on the ribbon cable so it makes better contact, and it works perfectly. All in all, an hour or so's work.

  24. #23
    4th Gear

    Status
    Offline
    Join Date
    Jun 2006
    Posts
    831
    outstanding. how do you actually remove the clocks?

  25. #24
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Johannesburg, South Africa
    Posts
    5
    Actually not difficult either to remove the clocks. Loosen the steering column adjusting lever on the left, pull it towards you and down, (you are going to need all the space you can get) tighten it again.

    On top of the column right underneath the clocks is a small plastic cover, grab it and pull at it, it comes out relatively easy, there's no screws holding it in.
    On the top of the cluster, is 2 x Philips screws, take these out (It helps if you have a very short screwdriver, it just a very difficult and tricky place to work). Then, pull at the top of the cluster, you should be able to get a finger in right at the top, and its not too difficult once you've got it loose.

    Pull it down and towards you, then try look in the back, one of the cables is attached with a cable tie, cut it, (but obviously not the wiring it holds in place)
    The plugs are difficult to get out, they are held in place by clips which fold over then clipping into place, almost like a stirrup. Do the closest one to you first so you can see how it works. Unclip it on the sides, then push it up and over the plug, this will actually lift the plug out of the fiiting, then its just a simple case of moving the cluster around till you can get it out.

  26. #25
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,586
    Cool!, the been waiting for an answer to this question for a long time, this one should be sticky mods.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  27. #26
    dultanur's Avatar
    all promises, no action :)

    Status
    Offline
    Join Date
    Sep 2006
    Location
    Istanbul,Turkey
    Posts
    407
    yep, i'll try to get this done! thanks for the great info!
    2000 Black S3 (Sold, then totalled) - 2008 A3 1.4T Sport

  28. #27
    Numptie of the highest order

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Crowthorne, England
    Posts
    2,512
    Yep I think this needs to be added to the FAQ, mines just started doing it with a line or two occasionally, I find it's mainly on lines that arn't used and only when the display hasn't changed very often, had the low coolant warning light come on the other day for about 20secs when it was freezing and that flashing away seemed to sort the problem for a while. I might have to give this a go when I get some free time.

  29. #28
    Reverse Gear

    Status
    Offline
    Join Date
    Nov 2006
    Location
    Johannesburg, South Africa
    Posts
    5
    No prob guy's. I think the degree of work you going to have to do will depend on how much of your ribbon cable has come loose from the side of the lcd display. I wasn't going to take chances, so took mine off completely, cleaned everything and put it back.
    Something you could also try if you don't have thin rubber strip is the right sized cable tie. Just trim it to fit in neatly under the lcd so that the metal case squeezes the glass down onto the ribbon cable and the cable down onto the cable tie.
    Mine worked first time (and for that I am SO thankful), but, you know how it goes. Just get that damn cable onto the glass as tight as you can, and your problems will be over.
    Good Luck!

  30. #29
    Reverse Gear

    Status
    Offline
    Join Date
    Dec 2006
    Location
    Melbourne, Australia
    Posts
    13
    Quote Originally Posted by turbodan
    I dont have a button on the end of my washers stalk

    Its a 1999 A3 TDI

    Strange huh?!
    Sorry to dig up a skeleton all but what can be done for people (such as turbodan and myself) that dont have the button at the end of the wiper stalk and the display is always off? I have the trip meter and total mileage on the right hand side inside the speedo but nothing in the middle dis.
    Audi A3 '98 1.8 Turbo Black

  31. #30
    M44 DUB's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Dec 2006
    Location
    Rosyth, Fife, SCOTLAND
    Posts
    152
    I wondered why mines was doing this too, only happens when the car is hot, works perfect on freezing cold days.
    NEW PLATE............WRONG CAR.............

  32. #31
    rodenal's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Oct 2006
    Posts
    1,982
    Quote Originally Posted by Tequie
    Sorry to dig up a skeleton all but what can be done for people (such as turbodan and myself) that dont have the button at the end of the wiper stalk and the display is always off? I have the trip meter and total mileage on the right hand side inside the speedo but nothing in the middle dis.
    Bugger all i believe as its probably linked to the ecu
    *Gone* 1997 A3 1.6 facelift headlights, 16"1.8t Alloys, full rear tints. 110k

    You built a time machine.........out of a delorean!?!?!

  33. #32
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2007
    Posts
    4
    Quote Originally Posted by FlyingBy
    Dont let the Audi garages fool you, the whole cluster does not need changing. Mine did exactly the same thing, worse on hot days, better on cooler days. Audi also said change the cluster, I thought forget it! I took it out, there's 3 plugs on the back. Turn it over, there's a few torx screws, take those out, and loosen the black clips which hold the clear face to the rest of the cluster.
    What happens is the lcd display glass has a thin ribbon cable on its right hand side that powers the display, the bonding/glueing on this ribbon cable comes loose, doesn't make proper contact thats why the lines come and go.
    Over the top of the display is a metal cover plate held on by 4 legs bent on the back of the pc board. Straighten these, and it comes off. WORK GENTLY!!!
    Then you can remove the lcd glass. Be careful, don't loose the 2 pieces of plastic behind the lcd glass. IT WILL NOT WORK WITHOUT BOTH OF THESE.
    Then, either take the lcd panel to a good electronic company to re-bond the ribbon cable for you, or find a place that makes and sells lcd displays.
    Don't worry about the codes either, so long as you disconnect the cluster with the ignition off, once you plug it back, everything will work fine.

    I did mine myself, just added 2 extra strips of thin rubber strip behind the lcd on either side, and made the metal cover press down slightly harder on the ribbon cable so it makes better contact, and it works perfectly. All in all, an hour or so's work.
    This thread got quiet. Did anyone try this and have success? I am thinking about opening up my instrument panel and giving it a shot if it at least worked for someone??

  34. #33
    Prawn's Avatar
    My other car is a MINI!!!!

    Status
    Online
    Join Date
    Dec 2006
    Location
    Basingstoke
    Posts
    9,380
    ive been thinking about it too, but apart from FlyingBy, nobody seems to have had any luck doing it at all!

    still, i may well whip my clocks out and see if it looks do-able.

    mines always been bad sinse i bought the car, but its recently gotten worse to the point where i can only just read it!
    -------------------------------------------------------------------------------------------------

    Prawns TFSI Turbo'd 1.8T Track Car

    But I know nothing so ignore me.

  35. #34
    Randomjim's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Aug 2006
    Location
    Sussex, Uk
    Posts
    2,747
    Im gonna do the same get it out an see if its worth the hassle
    Built in Germany, Perfected in England

  36. #35
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,586
    I just have mine switched OFF! I suppose it's pretty much buggered anyway, there's no harm in having a go at fixing it, something to do at the weekend methinks.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  37. #36
    Reverse Gear

    Status
    Offline
    Join Date
    Sep 2007
    Posts
    1

    lcd display repaired

    Got mine repaired by a company called dmcs pixel repairs, type that in google for there web address.

    they specialise in pixel/lcd repairs for Audi and other makes, Bmw and Mercedes

    i tried repairing it my self but seemed to damage the ribbon, they are so easy to come off. dan from dmcs replaced the lcd. they do repairs as well and carry spare lcds too.


    very good service over all.

  38. #37
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,586
    Well this is handy, a free plug for the company in question.

    LCD repair Linky

    Not too sure about the 'other' services they have available though...
    Last edited by jojo; 19th September 2007 at 19:34.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  39. #38
    Prawn's Avatar
    My other car is a MINI!!!!

    Status
    Online
    Join Date
    Dec 2006
    Location
    Basingstoke
    Posts
    9,380
    you got me all excited there jojo! then i clicked the link and found it was £200

    sodd that, id rather turn it off than pay £200 just to have a clear screen again
    -------------------------------------------------------------------------------------------------

    Prawns TFSI Turbo'd 1.8T Track Car

    But I know nothing so ignore me.

  40. #39
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,586
    Quote Originally Posted by Prawn
    you got me all excited there jojo! then i clicked the link and found it was 200

    sodd that, id rather turn it off than pay 200 just to have a clear screen again
    It's 200 from these guys, or around 550 from Audi to get it fixed! But I fancy the third option, which is DIY.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  41. #40
    1st Gear

    Status
    Offline
    Join Date
    Apr 2007
    Posts
    297
    ANyone does this mod take lots of pics!

 

 
Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO