Volks AutosChris Nott
Results 1 to 18 of 18
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    SE Ldn/Kent
    Posts
    26

    Unhappy Just been told i need new ECU

    My car has been off road for past 3 weeks after cutting out intermittently and towed it into garage on Sat morning. When i towed it in it would not start at all - turnover but not fire and no go from injectors

    They have called me just now and told me i need a new ECU as the trim wasn't put back on properley and water has got into it and damaged the board.

    How could this have happened ? Would anyone have need to access the ECU when i had my car remapped ?
    I had my car remapped maybe 2 years ago

    They have told me it will cost around 450quid.....but now I will lose the remap i had done on it.

    I feel crap.

    Any Advice ?

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    6th Gear

    Status
    Offline
    Join Date
    Jul 2005
    Posts
    2,488
    eh? I thought ECU's were pretty waterproof?


  4. #3
    Neutral

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Northern Ireland
    Posts
    38
    i thought the ecu would have been a sealed unit? is that 450 for an audi ecu? how much is an aftermarket one?

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    SE Ldn/Kent
    Posts
    26
    Quote Originally Posted by curran33
    i thought the ecu would have been a sealed unit? is that 450 for an audi ecu? how much is an aftermarket one?

    yeah they ahve told me its a replacement unit from Audi - they swap it like they do headunits etc.

    312 for replacement ECU and 120quid to calibrate it etc.

    i have been told to make sure they have checked the crank angle sensor before anything else

    this has ruined my day to be honest

  6. #5
    DPM
    DPM's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jun 2006
    Location
    Newcastle/Durham
    Posts
    4,210
    That's strange, it would have been taken out when they did the remap i would of though but as everyone says it's still a tight sealed unit. Have you looked at the ECU yourself?
    DPM Performance
    The premier online suspension and performance specialists
    W: www.dpmperformance.co.uk
    T: 01207 561606
    E: sales@dpmperformance.co.uk

  7. #6
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    SE Ldn/Kent
    Posts
    26
    right just been talking to the parts guy at my local audi who I know (and he is very helpful)

    he seems to think that if the pollen filter was not put in correctly then the plenum chamber can fill with water and flood the ECU which is directly under neath
    its not a sealed chamber and will flood - just my luck.

    I had my car serviced for 60k AVS service back in April and will have to check this myself to see if I can point the finger at the place that did it ...........what are the chances of getting them to admit any liability ????


    slim to zero i think.....

  8. #7
    hud at ye bam

    Status
    Offline
    Join Date
    Jan 2006
    Location
    Aberdeenshire
    Posts
    2,231
    If the chip was taken out and replaced with they mapped it then it's possible that either they didn't put the seal back in, or they didn't put it back in properly and it's perished.

    Audi's price is about right for a new one, expensive day for you
    [/sarcasm]

  9. #8
    neil.c's Avatar
    Senior

    Status
    Offline
    Join Date
    Apr 2004
    Location
    leicestershire
    Posts
    563
    I have had the ecu in the wifes golf apart a few times and while there is a good seal on it it would not stand being immersed in water
    99 S3 Absolute red

  10. #9
    Neutral

    Status
    Offline
    Join Date
    Feb 2006
    Location
    Northern Ireland
    Posts
    38
    try pricing an aftermarket ecu that can be adjusted anytime you want

  11. #10
    Reverse Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    SE Ldn/Kent
    Posts
    26
    Subject: Re: Just been told i need new ECU

    well total damage is gonne be 600 quid

    new ECU on exchange from Audi and then they have to take car to Audi so they can reprogramme the ECU to the immobiliser.

    I had a look inside the ECU and the circuit board looks fine but there were a few small watermarks on the inside of the lid - ever so tiny tho

    I saw the chip that AMD put in there also and its just soldered onto the circuit board - Sanspeed have told me they can remove this and put it on the new one so that I can keep the map (an extra 100quid plus VAT of course)


    I have to say the ECU is in a stupid place on my car - right under the windscreen where rain should run down - once this is fixed I will be sealing it up in waterprrof plastic to stop this happening again - very poor design from Audi

    oh and it wont be done til next tuesday.....

  12. #11
    dummi's Avatar
    smoking a6

    Status
    Offline
    Join Date
    Mar 2004
    Location
    brumingham
    Posts
    1,188
    not sure if im too late for you but theres a ecu specialist in nottingham that repair ecu's in all sorts of states or can source you another and recode, lynx automotive

    HTH
    just a little a6

  13. #12
    1st Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Middlesex
    Posts
    141
    I thought the area where the ECU was had drain holes, im sure there were some at either end last time I looked going into the wheel wells, for that reason the ECU was housed in a water resistant case. If the drain holes are blocked then its going to flood and immerse the ECU in water.

    If your car is a facelift model wouldnt it support serial remapping? wouldnt need to touch the ecu then. Im sure if you spoke to AMD and explained the situation theyd remap your car for you via serial port, if its a non drive by wire and therefor a solder only job then there is obviously more work involved and they may not be so willing. Would be worth a try anyways

  14. #13
    mazzy's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    West Midlands, UK
    Posts
    299
    I think my ECU has gone...

    Washed the car yesterday and i know i got water down the scuttle panel, afterwards i went for a drive, it was fine until today it started behaving weird, wouldnt start and now it dont start at all. VAGCOM dont communicate with the ENGINE block but does with all the other blocks.

    What should i do??

    Any clues guys? I'd appreciate it.

  15. #14
    Blunteh's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Mar 2006
    Location
    South East UK
    Posts
    198
    My ECU died a few months ago (lost all power on a dual carriageway in heavy rain).

    Audi claimed there was no sign of water damage on the ECU.
    Nogaro Blue 2001 S3 - Revo Remap (Stage1) - Hyperboost DV - Neuspeed 22mm + 19mm ARBs

  16. #15
    mazzy's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    West Midlands, UK
    Posts
    299
    Does anyone have any ideas what it may be? i'm opening the ECU up later to take a look inside for any moisture.

    Can i just take the ECU to the dealers or have i got to recover my car into the dealers to get the whole immobiliser issue etc. sorted. ???

  17. #16
    mazzy's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    West Midlands, UK
    Posts
    299
    I've managed to sort it, i opened up the ECU and found water particles, i cleaned and wiped it and sprayed electrical cleaner on it and wiped it carefully, each circuit etc.

    Cured the BEAST!!

  18. #17
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    24,840
    Good work Maz, when you gonna show me this Chrome pipe you got in your engine bay mate?


    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh!



  19. #18
    spuddie007's Avatar
    Thomas the Tank Engine - Choo, Choo!

    Status
    Offline
    Join Date
    Feb 2005
    Location
    Barnet, Hertfordshire
    Posts
    210
    Quote Originally Posted by griffin1
    My car has been off road for past 3 weeks after cutting out intermittently and towed it into garage on Sat morning. When i towed it in it would not start at all - turnover but not fire and no go from injectors

    They have called me just now and told me i need a new ECU as the trim wasn't put back on properley and water has got into it and damaged the board.

    How could this have happened ? Would anyone have need to access the ECU when i had my car remapped ?
    I had my car remapped maybe 2 years ago

    They have told me it will cost around 450quid.....but now I will lose the remap i had done on it.

    I feel crap.

    Any Advice ?
    Similar thing happened to my car, although the ECU was dried out by the stealer and it's been fine since!!!

    See my thread below:

    S3 Christmas Tree...... :o(
    Was an Audi S3, Pre-Facelift 210 bhp, Security Tints, Standard spec, simple sweet and to the point.

    Currently a Golf GT TDi 170 DSG in Pearlescent Black with every conceivable extra available - company car


    From June 2011 - Audi A3 Sportback Black Edition 140 tdi (company car) with DSG gearbox, Technology Pack + AMI, Storage Pack, Open Sky Roof System, Comfort Pack, Luggage Pack and Interior Light pack. Oh and it's Monza Silver. Can't wait

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO