Chris NottEM Tuning
Results 1 to 4 of 4
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Bergen Norway
    Posts
    9

    Problem with "short-to-ground" VAG-COM

    Hello, I have an Audi A3 1996 with the 1.8L non-turbo engine. I have a problem that the engine just dies sinstantly during driving. it is most of the times possible to start it again after a short while, but it can die again at any time.

    The following fault codes are registered:
    01249 - Fuel injector for cylinder 1(N30)
    29-10 -Short to ground - intermittent

    Similar fault codes exist for the other cylinders (I have a common error for all injectors).

    The car is equipeed with Motronic M3.8 if I understand correctly.

    I cannot find any electrical wiring diagram for the engine or Motronic 3.8! Haynes has nothing about any engine, and i have not been able to find schematics online. My understanding of short to ground is that the ECU does not get sufficent current through the injectrors when it grounds the injector, this could maybe be from high resistance on the supply, or high reistance down to ground after the ECU

    Questions:
    1. Has someone had these fault codes before? how did you solve the problem?
    2. does anyone have a circuit diagram for this engine, or maybe to a 1.8T that should be similar?
    3. Where is the ground point to the ECU located?
    4. I have googled that the fuel relay might have something to do with such codes, does anyone know anything more about that?


    Best regards Eric

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Bergen Norway
    Posts
    9
    I have now checked all ground points that I could find under the hood and made sure they have proper contact to ground. I have also taken the fuel pump relay apart and sand-papered the contacts for improved connections. The failures are unfortunately still there with frequent stalls of the engine.

    Several more "short-to-ground" codes are also generated, for the camshaft position sensor and the MAF-sensor. These must have some common points that should be checked.

    Are you guys sure that no one has some electric drawings for an A3 (or A4 for that matter) engine with motronic?

  4. #3
    2nd Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    385
    Some of the earth points are well hidden on the a3 have look under the battery if you haven't already, short to ground doesn't always mean its an earth problem have you cleaned the fuses on top of the battery if you have them depending on model

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Aug 2010
    Location
    Bergen Norway
    Posts
    9
    Quote Originally Posted by Ian2012 View Post
    Some of the earth points are well hidden on the a3 have look under the battery if you haven't already, short to ground doesn't always mean its an earth problem have you cleaned the fuses on top of the battery if you have them depending on model
    Thanks for your reply Ian. I have checked the connection for the fuses on top of the battery and they look fine, I have also measured the resistance over them and no remarks there. Do you know where the earth points for the injectors are placed? Is it one of the points just next to the battery (left hand side of car, close to the left headlight?) I am thinking about shortening them 10cm and replacing the ends with new wires since the cores in the cables look corroded in the end.

    I have yesterday inspected the ECU connections and they alos look fine. I also removed pittings on the fuel pump relay contacts but the problem is still there. I have now ordered a new fuel pump relay and will try with that.

 

 

Similar Threads

  1. Problem with vag-com.
    By vw754 in forum VCDS (formerly VAG-COM) forum
    Replies: 8
    Last Post: 30th September 2008, 23:15
  2. Vag-Com problem on a new laptop with vista
    By Badgeronimous in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 14th December 2007, 18:45
  3. Having problem getting USB cable to work with VAG.com
    By Rev-head in forum VCDS (formerly VAG-COM) forum
    Replies: 34
    Last Post: 14th August 2007, 17:53
  4. Aftermarket radio problem with VAG-COM?
    By Dean_T in forum In-Car Entertainment
    Replies: 2
    Last Post: 5th September 2004, 18:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO