Monster MotorsportEM Tuning
Results 1 to 6 of 6
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    90

    Failing heater flap and it's infuriating clicking

    Right, the car is driving me mental, and any help would be massively appreciated!

    I've got a constant clicking sound from the heater, regardless of whether the heater is switched on or off.

    I've taken the heater motor out and the fan itself is absolutely fine, it seems it's the flap behind that moves when you switch the heater on/off. When it's on, it makes a constant clicking sound as it seems to get stuck, whilst the flap motor keeps trying to move. When I switch it off, the motor moves to the top position but again can't make it all the way and makes an even louder sound as it keeps trying to move.

    I can push the flap to either the open or closed position, the motor stops and I have peace and quite, as the flap is in the rest position, but as soon as I switch it on/off again, it gets stuck and the noise continues.

    Below is a where it seems to generally get stuck (sorry, the photo is coming up sideways for some reason).

    photo.JPG

    Any thoughts on a fix? I've doused the sides with WD40 over night, but is there anything else anyone has done to fix a similar problem? Is the motor failing, and if so, how do you go about replacing it? Everything seems pretty hard to get to and I can't see anything blocking it.

    Any help would be massively appreciated, before I kick the thing in.

    Cheers
    Currently running a MTM stage 1 map, ECS brakes, Forge DV, Bager 5 TIP, 18" RS4s, Bilsteins, H&R springs, Tie bars, Milltek catback... but not for long...

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Oct 2009
    Posts
    90
    Bump...

    Anyone, anyone, Bueller??
    Currently running a MTM stage 1 map, ECS brakes, Forge DV, Bager 5 TIP, 18" RS4s, Bilsteins, H&R springs, Tie bars, Milltek catback... but not for long...

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Nov 2010
    Location
    scotland east lothian
    Posts
    46

    My Social Networking

    Visit westcoast a3's Youtube Channel
    Had this prob mate and just suffered it for about two weeks with it on and stopped lol

  5. #4
    J44KWED's Avatar
    Neutral

    Status
    Offline
    Join Date
    Sep 2013
    Location
    West London
    Posts
    46
    I had this very same problem, I pushed the flap down from the engine bay side of the car (to the open position) until it clicked and stayed firmly open. Maybe i broke something i don't know! I've kept it stuck open for a good 4 months now and it hasn't bothered me so i just left it like that!

    Not sure if this is linked to the flap, but when i have the fans blowing say on the lowest setting, by the time I've driven a few miles the blowers are blowing at nearly full tilt! The black blocks on the lcd gradually creep up and up as i drive the car and the blowers get stronger. Weird hey!

  6. #5
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    744
    Quote Originally Posted by J44KWED View Post
    I had this very same problem, I pushed the flap down from the engine bay side of the car (to the open position) until it clicked and stayed firmly open. Maybe i broke something i don't know! I've kept it stuck open for a good 4 months now and it hasn't bothered me so i just left it like that!

    Not sure if this is linked to the flap, but when i have the fans blowing say on the lowest setting, by the time I've driven a few miles the blowers are blowing at nearly full tilt! The black blocks on the lcd gradually creep up and up as i drive the car and the blowers get stronger. Weird hey!
    Do you have climate control? Is it on Auto? Do you mean the fans kick in harder once the car comes up to temperature?

    If not, it sounds like your radiator/stat is buggered?
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel
    To Fit - Decat then Mapping WANTED: Audi A4 B7 or MK5 Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  7. #6
    J44KWED's Avatar
    Neutral

    Status
    Offline
    Join Date
    Sep 2013
    Location
    West London
    Posts
    46
    yeah i have climate control, but i dont mean the fans, the aircon in the car. whenever i have it on manual whatever setting i put it on, the air con blowers will slowly get stronger and stronger until they are at their strongest, you can watch the bars on the lcd screen ticking up, and feel the air blowing on your face! lol. I've tried changing the aircon unit itself and this makes no difference. It probably takes 15 minutes of driving for the blowers to get to max from their lowest setting. Quite annoying, as i constantly have to reduce the blower power as i drive.

 

 

Similar Threads

  1. Heater flap motors - where to buy
    By jbcalvin in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 14
    Last Post: 12th February 2014, 19:29
  2. Fuel flap and camshaft
    By TOON FLYER in forum Audi S4/A4/A4 Cab (B8 Chassis)
    Replies: 2
    Last Post: 8th July 2011, 18:05
  3. Heater motor / and or resistor - little advice please.
    By neal-a3 in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 20th January 2011, 09:19
  4. has anyone got a heater flap?
    By rasA4 in forum A4/S4 forum(B5 Chassis)
    Replies: 0
    Last Post: 23rd September 2010, 17:44
  5. RECIRCULATE FLAP AND SMELLY AIRCON ,HVAC UNIT
    By cheech in forum Air Conditioning
    Replies: 1
    Last Post: 13th July 2010, 20:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO