Monster MotorsportChris Nott
Results 1 to 3 of 3
  1. #1
    5th Gear

    Status
    Offline
    Join Date
    Nov 2004
    Location
    Tonbridge, Kent
    Posts
    912

    Hyperboost DV problem

    Hi, I had one fitted to my car when my old stock one was dead. I have been told by someone that my cars surging of boost on accelerating is due to this failing to hold the boost on acceleration.
    Can someone please run through how to service this part as I did not fit it. I am no fool and should be able to sort it with a little info.
    Finally, are they tellling the truth or am I going to get wet and cold playing under my bonnet for nothing?

    I had the valve fitted about a year ago, maybe less and have covered around 12k so is probably due a service I guess???

    Thanks for the flood of responses....

    Rob [img]/ubbthreads/images/graemlins/ok.gif[/img]

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    HTC
    HTC's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2004
    Location
    Koh Samui, Thailand
    Posts
    3,402

    Re: Hyperboost DV problem

    Your valve might be sticking a bit.

    Unscrew the top and you'll be able to remove the piston.

    Clean it all up and then lubricate the sides with a bit of synthetic grease.

    I tend to clean my valve up each time I do an oil change as its a quick job.

    If its still bad, you might need a service kit to replace the seals etc.

  4. #3
    5th Gear

    Status
    Offline
    Join Date
    Nov 2004
    Location
    Tonbridge, Kent
    Posts
    912

    Re: Hyperboost DV problem

    Thanks HTC. Will have a look at the weekend.

    Rob

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO