Monster MotorsportVolks Autos
Results 1 to 8 of 8
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2014
    Posts
    4

    Audi S3 p0340 fault code keeps on comming up

    Hi guys I just recently brought a s3 8l amk engine code 2001 the problem is on idle it doesnt run nice but once your going it drives lovely so I was told it was the ignition coils so I changed all 4 with now bosh platinum sparks then still I have the same problem so I took it to the garge and diagnosed it they told me it was cam sensor so I got a new one and still the same code is comming up again then after some research I found out it could of been the timming which it was off a tooth after getting that done its STILL comming up with the same code p0340 and also mis fire on cylinder 1,2,4 need some help
    Thank you for taking for time for reading

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    andy68's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Jul 2013
    Location
    Tameside
    Posts
    18
    Was your new Cam sensor genuine Audi or pattern part? Pattern parts quality is a bit hit and miss so you may have bought a duff one.

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    Jul 2013
    Posts
    157
    Did you change the coil packs or spark plugs? Cammage

  5. #4
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2014
    Posts
    4
    Hi yep genuine audi cam sensor. And also I chaned genuine beru ignition coils and sparks

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2014
    Posts
    4
    update i changed the valve timming unit now i cleared that code now another code is keep on coming up even if i clear the codes
    p0302 misfire on cyl 2
    p0171 system too lean on bank 1
    is this possible air leak because i listen to any air leaks and nothing also its boosting well and when im on idle the car shakes

  7. #6
    Lewis583's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    870
    The diagnosis needs to start again now you replaced the cam chain tensioner.

    Swap coil pack 2 & 3 and see if the misfire code follows. If it does, then the coil pack is dead. ( They can come dead out of the box so one dieing very soon isn't impossible)
    If it doesn't, I'd swap the 2 & 3 spark plugs and re-check.
    Next I'd check the coil pack wiring for signs of damage to the insulation.

    In regard to the Lean code, checked all vac/boost pipes for leaks/splits? If not, start with this.
    2008 E92 BMW 335i M-sport
    1990 Golf GTi w/ a 20v heart BUILD THREAD
    Full VCDS

    2006 A3 2.0T quattro S-line R.I.P. You will be missed.

    ** Breaking - 8L 1997 Audi A3 1.8T. **

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Jan 2014
    Posts
    4
    i brought 4 new coil packs inc 4 new sparks

  9. #8
    Lewis583's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Mar 2010
    Posts
    870
    Check the coil pack wiring then seeing as this will have been messed with when you changed the chain tensioner.

    Just because they're new doesn't mean they're not faulty by the way.
    2008 E92 BMW 335i M-sport
    1990 Golf GTi w/ a 20v heart BUILD THREAD
    Full VCDS

    2006 A3 2.0T quattro S-line R.I.P. You will be missed.

    ** Breaking - 8L 1997 Audi A3 1.8T. **

 

 

Similar Threads

  1. audi a3 01221 fault code help
    By adrianmrf in forum A3/S3/Sportback (8P Chassis)
    Replies: 1
    Last Post: 14th August 2013, 19:31
  2. Brake system fault - Audi say no fault codes.
    By DeanTTaylor in forum A3/S3/Sportback (8P Chassis)
    Replies: 2
    Last Post: 14th January 2013, 23:31
  3. arghhh please help, fault codes keep increasing
    By brys3 in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 2nd March 2010, 21:37
  4. vag com fault codes..... any help out there please?????
    By shufti in forum VCDS (formerly VAG-COM) forum
    Replies: 4
    Last Post: 12th March 2007, 03:43
  5. VAG-COM Fault Codes
    By imported_VaulterTim in forum A4/S4 forum(B5 Chassis)
    Replies: 0
    Last Post: 9th January 2006, 08:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO