Monster MotorsportBadger5
Results 1 to 16 of 16
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    N yorkshire
    Posts
    65

    Turbo issue maybe????

    This morning car started with a funny noise like a whining noise and a loss of power not sure if it's a leak in the system or f**k turbo. Cars not smoking. Any advice.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    1st Gear

    Status
    Online
    Join Date
    Jul 2013
    Posts
    157
    I'm pretty sure your best option is to get it scanned asap... Any fault codes will help loads..

  4. #3
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    N yorkshire
    Posts
    65
    Had it plugged into vag but no codes

  5. #4
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    34
    This was mine two weeks ago, does it sound like this? Mine had two fins on the turbo chipped off and loads of play.
    VID 20131118 073149 - YouTube

  6. #5
    JoeeS3's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Cardiff
    Posts
    355

    My Social Networking

    Follow JoeeS3 On Twitter Visit JoeeS3's Instagram Channel
    https://www.youtube.com/watch?v=IN8o...e_gdata_player does it sound anything like this?
    i'm not a genius...i'm a learner

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    N yorkshire
    Posts
    65

    Turbo issue maybe????

    Yes it does sound abit like that!!! What is it??? Plz!!!
    Last edited by temp; 6th December 2013 at 15:20.

  8. #7
    JoeeS3's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Cardiff
    Posts
    355

    My Social Networking

    Follow JoeeS3 On Twitter Visit JoeeS3's Instagram Channel
    not sure if you have seen any of my posts but unfortunately it sounds as if its your turbo gone bud. i'm having my k04 changed today. do you have an s3 or a3?
    i'm not a genius...i'm a learner

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    N yorkshire
    Posts
    65

    Turbo issue maybe????

    S3 that what I did not want to hear how much is it costing.

  10. #9
    JoeeS3's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Cardiff
    Posts
    355

    My Social Networking

    Follow JoeeS3 On Twitter Visit JoeeS3's Instagram Channel
    but i'm no mechanic. that video is of my car though and it seemed on the older turbo(chinese knock off) that there was a lot of play in the shaft, so the blades were touching the housing which was causing the whine.
    i'm not a genius...i'm a learner

  11. #10
    JoeeS3's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Cardiff
    Posts
    355

    My Social Networking

    Follow JoeeS3 On Twitter Visit JoeeS3's Instagram Channel
    well i bought a second hand turbo for the time being for 190 delivered (Genuine) but i'm getting a hyrbrid sometime in the new year. if your not planning on doing that speak to dan at beach buggy turbos and he should be able to sort something out for you. hope this helps
    i'm not a genius...i'm a learner

  12. #11
    JoeeS3's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Cardiff
    Posts
    355

    My Social Networking

    Follow JoeeS3 On Twitter Visit JoeeS3's Instagram Channel
    and then the fitting for me is 200 as i know the person doing it.
    i'm not a genius...i'm a learner

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    N yorkshire
    Posts
    65
    What sort of turbo is on a standard s3 k03 or k04 which is best and what do you need to upgrade if put the better one on. My car is standard and want to upgrade stuff and if it needs a new turned might as well start now.

  14. #13
    sean_s3's Avatar
    1st Gear

    Status
    Online
    Join Date
    May 2009
    Location
    West Yorkshire
    Posts
    264
    K04 standard on an S3 , if you wanted to upgrade you would be looking at a K04 hybrid turbo.
    S3 Big Turbo

  15. #14
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    N yorkshire
    Posts
    65

    Turbo issue maybe????

    .

  16. #15
    JoeeS3's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2013
    Location
    Cardiff
    Posts
    355

    My Social Networking

    Follow JoeeS3 On Twitter Visit JoeeS3's Instagram Channel
    there isnt anything to click on mate
    i'm not a genius...i'm a learner

  17. #16
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    N yorkshire
    Posts
    65
    Not sure how to put vids on through my phone it was a vid of the noise drove car 2 day about 15miles no power, or smoke?? Stripped it down to the turbo the other night and all still there and no play in fin's somebody said my cat might of broken up and blocking the exhaust???? Not sure????

 

 

Similar Threads

  1. Turbo issues???
    By Scottynic in forum A3/S3 Forum (8L Chassis)
    Replies: 9
    Last Post: 24th May 2009, 19:36
  2. DIS Fault or Issue (maybe)
    By wilko in forum A3/S3/Sportback (8P Chassis)
    Replies: 7
    Last Post: 11th August 2006, 11:55
  3. Cold start issues? Maybe it;s your O2 sensor.
    By eddyg in forum A3/S3 Forum (8L Chassis)
    Replies: 0
    Last Post: 21st March 2006, 02:03
  4. 1 Turbo Enough ? Maybe 2 ? How about 8 !!!!
    By hop2407 in forum General Chat
    Replies: 12
    Last Post: 29th January 2005, 18:52
  5. Turbo Issue Questions
    By dann959 in forum A4/S4 forum(B5 Chassis)
    Replies: 11
    Last Post: 30th September 2004, 08:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO