JMB RetrofitsChris Nott
Results 1 to 4 of 4
  1. #1
    Freeman_1986's Avatar
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Forest Of Dean
    Posts
    112

    Maf issues.......

    A couple months ago my maf started doing the usual symptoms of failing. I unplugged it and the car improved massively. Left it until yesterday to get another, but went to eurocarparts splashed out the 80 quid and gave them my old one for a new bosch.

    I instaled led it and straight away it was idling high, then the weak acceleration and hesitation came back etc.
    is it possible I have a dodgy one? It is brand new and bosch, from a reputable dealer not and eBay jobby.

    Is there anything else that could cause it? Just don't understand how with it unplugged it runs absolutely spot on, but with the new one it runs ****e.
    S3 AMK (AKA FUTURE CLASSIC )

    Mods So Far: PCV Delete, N249 Bypass, S2K Filter, Black Side Indicators, FMIC, B5 TIP, Rear Anti Roll Bar, Polybush Upgrade.

    Mods Wanted/Planned: Wheel Spacers, Moar Silicone, 3" Downpipe, Decat, Debadge Rear Rings, Spray Front Rings, 8P/V Gear Knob, REVO!!!!!!!

    MISC: Sort Out Paintwork...

    Because It Makes No Attempt To Be Great, It Is Therefore Extremely Great.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    epox's Avatar
    3rd Gear

    Status
    Online
    Join Date
    Oct 2012
    Location
    Glasgow
    Posts
    561
    i got one fron ecp and its crap aswell.

    mark
    S3 2003........REVO..........Stage 1...........218G/S.......÷..........°8..........=..........272bhp ......368Nm.....271 ft lbs

  4. #3
    Freeman_1986's Avatar
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Forest Of Dean
    Posts
    112
    is this common then? would they accept it back for a replacement?
    S3 AMK (AKA FUTURE CLASSIC )

    Mods So Far: PCV Delete, N249 Bypass, S2K Filter, Black Side Indicators, FMIC, B5 TIP, Rear Anti Roll Bar, Polybush Upgrade.

    Mods Wanted/Planned: Wheel Spacers, Moar Silicone, 3" Downpipe, Decat, Debadge Rear Rings, Spray Front Rings, 8P/V Gear Knob, REVO!!!!!!!

    MISC: Sort Out Paintwork...

    Because It Makes No Attempt To Be Great, It Is Therefore Extremely Great.

  5. #4
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,632
    Yes.. But try GSF instead.. Ecp seem to do dodgey ones. Mine ATM is from GSF and feels fine. OEM would be better!
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

 

 

Similar Threads

  1. Accelerate jerky, idle rev up and down but not MAF issue
    By flippy in forum A3/S3 Forum (8L Chassis)
    Replies: 11
    Last Post: 26th November 2013, 21:51
  2. weird MAF issues
    By JaseS3 in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 11th November 2013, 12:57
  3. Posible Boost/Maf Issue Around 3700 rpm - Logs Inside
    By Aviry in forum A3/S3/Sportback (8P Chassis)
    Replies: 0
    Last Post: 11th May 2013, 22:24
  4. MAF Sensor Issues 'BU'L engine
    By Custardsucker in forum Audi S4/A4/A4 Cab (B7 Chassis)
    Replies: 0
    Last Post: 21st October 2012, 19:59
  5. question to those who have had MAF issues....
    By tboy in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 1
    Last Post: 18th July 2005, 08:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO