Volks AutosBadger5
Results 1 to 11 of 11
  1. #1
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,494

    Haldex controller question

    Not your usual question, but would it be ok to just plug my Haldex performance controller under the car without bolting it up? No oil running through it, just want to eliminate the no comms DTC from VCDS. Shouldn't't be a problem right? The part is kind of expensive to break, so want to make sure!



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    hoffmanvp3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Sep 2013
    Location
    Oldmeldrum
    Posts
    286
    Did u check the earth strap for the controller that's still bolted on?
    I don't see why the pre charge pump won't come on if your not requesting it to operate via VCDS but sure one will correct me if I'm wrong

  4. #3
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,494
    Quote Originally Posted by hoffmanvp3 View Post
    Did u check the earth strap for the controller that's still bolted on?
    I don't see why the pre charge pump won't come on if your not requesting it to operate via VCDS but sure one will correct me if I'm wrong
    My car doesn't have an earth strap as far as I know? VCDS is just showing no comms to controller, so I wanted to plug my unfitted performance one on to test the comms. Will the lack of oil effect it's operation, it's just a stepper motor that opens and close a valve right?



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  5. #4
    hoffmanvp3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Sep 2013
    Location
    Oldmeldrum
    Posts
    286
    Not really sure tbh but there should be an earth strap iirc as that'll prob be causing ur no coms

  6. #5
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,634
    It should work.. But be warned not to turn over the car.. It'll piss out oil! I'm not sure if the pre charge pump activates on ignition and oil may come out! It's not a hard job popping it back out anyhow. You using MY blue haldex? 8-)
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

  7. #6
    jojo's Avatar
    S3 Drift King!

    Status
    Offline
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,494
    Quote Originally Posted by Gops View Post
    It should work.. But be warned not to turn over the car.. It'll piss out oil! I'm not sure if the pre charge pump activates on ignition and oil may come out! It's not a hard job popping it back out anyhow. You using MY blue haldex? 8-)
    I'm keeping my original Haldex in situ, just want to plug the performance one into the lead to confirm it's the lead that's faulty.

    It did come off your car, but it Miiiiine!



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  8. #7
    Big Al's Avatar
    Engine knackered!!

    Status
    Offline
    Join Date
    May 2011
    Location
    West Midlands
    Posts
    295
    Hi Joe

    The Haldex controller may work if just plugged in, but without an earth it may malfunction and damage the circuitry. Apparently many of the controllers fail in this way, as earth straps often break. Your diff unit should have an earth strap and they are easy enough to make. There should be screw posts on both the shell and trans. See this picture of my Haldex unit which I'm selling.

    Al


    Audi A4 B7 2004 red 2.0 TFSI Quattro Sport saloon, Servotronic steering, MFSW, CDIS, DRL with Coming Home, auto dual xenon lights/wipers/mirrors, split folding rear seats, 3rd headrest, centre armrest, Isofix mounts, RS4 rear ARB, pedals & carbon dash trims; Audi TTS 9Jx18alloys (2 sets), Yokohama AD08 summer, Conti TS830P winter 245/40/18 tyres, TPI 15/20 spacers/lockers, Pipercross filter, GFB DV+ turbo valve, NGK BKR7EIX plugs, Osram Silverstar Xenarc D1S bulbs. Build thread

  9. #8
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,634
    Pre facelifts didn't have an earth strap
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

  10. #9
    Big Al's Avatar
    Engine knackered!!

    Status
    Offline
    Join Date
    May 2011
    Location
    West Midlands
    Posts
    295
    Quote Originally Posted by Gops View Post
    Pre facelifts didn't have an earth strap
    Really? That's weird. Maybe the loom wiring on pre-facelifts is different too, including an earth in the wiring? I can't see how the controller would operate reliably without the earth/-ve ground strap.
    Audi A4 B7 2004 red 2.0 TFSI Quattro Sport saloon, Servotronic steering, MFSW, CDIS, DRL with Coming Home, auto dual xenon lights/wipers/mirrors, split folding rear seats, 3rd headrest, centre armrest, Isofix mounts, RS4 rear ARB, pedals & carbon dash trims; Audi TTS 9Jx18alloys (2 sets), Yokohama AD08 summer, Conti TS830P winter 245/40/18 tyres, TPI 15/20 spacers/lockers, Pipercross filter, GFB DV+ turbo valve, NGK BKR7EIX plugs, Osram Silverstar Xenarc D1S bulbs. Build thread

  11. #10
    A3 TQS

    Status
    Online
    Join Date
    Jul 2013
    Location
    Devon
    Posts
    162
    my facelift doesn't have a ground strap either and theirs no evidence of their ever having been one, I can see the stud on the floor pan where it would go, but it's covered in the factory underbody stuff.

  12. #11
    Matt78's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    Chard, Somerset
    Posts
    48

    My Social Networking

    Follow Matt78 On Twitter
    I'm having my Y plate S3 looked at tomorrow because of this same no comms code....

 

 

Similar Threads

  1. Techincal question for any Haldex controller "experts"
    By Scullies in forum A3/S3 Forum (8L Chassis)
    Replies: 37
    Last Post: 10th October 2013, 15:36
  2. S3 Haldex Controller Questions
    By Colly in forum A3/S3 Forum (8L Chassis)
    Replies: 11
    Last Post: 22nd June 2012, 10:03
  3. Haldex Controller question
    By RobW in forum A3/S3 Forum (8L Chassis)
    Replies: 21
    Last Post: 22nd September 2011, 13:30
  4. Launch Controll Question
    By imported_kkline in forum A3/S3/Sportback (8P Chassis)
    Replies: 15
    Last Post: 25th September 2005, 13:43
  5. EIP Haldex Controller
    By DuncS3 in forum A3/S3 Forum (8L Chassis)
    Replies: 9
    Last Post: 31st May 2005, 21:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO