Monster MotorsportAH Fabrications
Results 1 to 14 of 14
Like Tree1Likes
  • 1 Post By Matt78

Thread: Haldex Control Unit probably needed, advice....

  1. #1
    Matt78's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    Chard, Somerset
    Posts
    41

    My Social Networking

    Follow Matt78 On Twitter

    Haldex Control Unit probably needed, advice....

    Hi all, the ESP/traction control light has been lit up for a couple weeks now on my 2001 S3 that I bought 3 weeks ago (strangely it wasn't on when I bought the car and the 100 mile journey back). My mechanic thinks he's tracked down the fault to the Haldex Control Unit, in other words I need a new one. What are my options? Is there anywhere I can send this off to, to test? Maybe a company that sells reconditioned replacements? I know there are some on Ebay but they'd not be guaranteed, so am I stuck with buying a new one? Obviously it's annoying but I like the car and if it needs doing it needs doing!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,045
    Are you sure its the haldex? what fault codes come up?

    I assume you have tested if you have AWD?

    The ESP light comes on for other reasons such as a faulty MAF sensor...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  4. #3
    Matt78's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    Chard, Somerset
    Posts
    41

    My Social Networking

    Follow Matt78 On Twitter
    I myself haven't tested anything, left that to the garage. This is the second time they've had the car as the first time they just spent a couple hours on it, checking wiring, sensors etc, as they weren't sure how in depth I wanted to go with it, and I do trust in their ability. And by testing if I have AWD, do you mean getting the wheels to spin up on a wet road?!

  5. #4
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,045
    If the Haldex is disabled through a faulty controller then the front wheels will spin as you climb on boost especially in the wet weather

    The ESP light normally stays on if it detects a fault with sensors relating to the ESP system... the MAF is the normal one as these regularly fail as the ESP system uses this to determine load and control throttle under conditions requiring ESP...

    As much as you may trust these people it may be worth asking them for what fault codes came up...

    Haldex fault codes are not normally picked up by generic code readers as they have no idea on what modules are on the car... a scan with VCDS is more reliable in this case as its VAG specific...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  6. #5
    Matt78's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    Chard, Somerset
    Posts
    41

    My Social Networking

    Follow Matt78 On Twitter
    Maybe I need to take it somewhere with VCDS then... The car doesn't feel unstable to be honest, and we have had wet weather a lot, and the front wheels haven't span up at all. I might go out in a bit and test the theory though...without crashing it of course! Thanks for the help. I guess the obvious choice is a VW dealer, although there is VAG specialist quite close to where I live.

  7. #6
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,045
    Use the VCDS map in the VCDS section of ASN to see if anyone is close to you or failing that for less than a tenner you can do it yourself by having a read of this enormously helpful yet under read thread

    IMPORTANT! - When posting asking for help... - PLEASE READ BEFORE POSTING (UPDATED)



    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  8. #7
    Matt78's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    Chard, Somerset
    Posts
    41

    My Social Networking

    Follow Matt78 On Twitter
    Ok I've had a read of that so may buy a lead and download the software. I'll also go out and see if I have AWD to start with.

  9. #8
    A3 TQS

    Status
    Online
    Join Date
    Jul 2013
    Location
    Devon
    Posts
    129
    I'm not too far from you in exmouth if you get really stuck and have full vcds so can run output tests on the controller etc, which I don't think you can do with the cheapy cable.


  10. #9
    Matt78's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    Chard, Somerset
    Posts
    41

    My Social Networking

    Follow Matt78 On Twitter
    Oh that would be a great help, thanks for the offer, Exmouth is about 40 minutes from me. I'll see what happens in a sec when I go and test my AWD....

  11. #10
    Matt78's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    Chard, Somerset
    Posts
    41

    My Social Networking

    Follow Matt78 On Twitter
    Update on the issue, I think tuffty may have been correct, as earlier I tried to launch the car with a lot of revs and dumped the clutch, and it seemed to just grip and go with no wheel spin. Seems my garage has mis-diagnosed the problem. Luckily a friend of mine's business has expanded since I last spoke to him and his garage now offers full VAG code reading at dealer standard, so he's gonna take a look at it for me.
    <tuffty/> likes this.

  12. #11
    G60DAN's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2010
    Location
    Cornwall
    Posts
    318
    Try TSR in bridgewater

  13. #12
    Matt78's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    Chard, Somerset
    Posts
    41

    My Social Networking

    Follow Matt78 On Twitter
    Oh yeah, the last S3 I had was remapped there before I owned it.

  14. #13
    2nd Gear

    Status
    Offline
    Join Date
    Feb 2004
    Location
    Borders, Scotland
    Posts
    371
    I had to replace the controller on my 8p, VCDS was very clear; faulty controller. I tried getting it reconditioned, didn't work, just threw up another fault code. Took it to a specialist, new code said I had a pump problem so I got a new pump, guess what, new code Haldex contoller faulty, should have replaced it in the first place.
    Moral of the story if VAG com is clear on what the problem is (Isn't always) it usually knows better than you or anyone. If I had listened in the first palce I could have got a controller at trade price and changed it myself, cost about £850 vs bill from Specialist (Pump, Controller fitting etc) £1200, still kicking myself!

  15. #14
    Matt78's Avatar
    Neutral

    Status
    Offline
    Join Date
    Oct 2013
    Location
    Chard, Somerset
    Posts
    41

    My Social Networking

    Follow Matt78 On Twitter
    Oooh that must have hurt the wallet! I should have answers by tomorrow evening so I'm intrigued now. But as far as I know the garage I first used only had a generic code read machine for all makes of car.

 

 

Similar Threads

  1. A6 Climate control unit -- help needed please !
    By Markraw1 in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 2
    Last Post: 7th March 2012, 14:25
  2. Replies: 1
    Last Post: 30th September 2010, 17:54
  3. Faulty Haldex control Unit
    By Richbod in forum A3/S3 Forum (8L Chassis)
    Replies: 20
    Last Post: 29th July 2010, 19:09
  4. where can i get a second hand haldex controll unit from? Any one selling one?
    By scott_johnson in forum A3/S3 Forum (8L Chassis)
    Replies: 11
    Last Post: 11th August 2009, 17:29
  5. Wheres the Haldex controll unit kept???
    By scott_johnson in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 4th March 2008, 01:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO