Volks AutosAH Fabrications
Results 1 to 32 of 32
Like Tree2Likes
  • 1 Post By tiki2402
  • 1 Post By tiki2402

Thread: Audi s3 oil light flashing red, replaced sensor, pickup, breather and pump 3 times!

  1. #1
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28

    Audi s3 oil light flashing red, replaced sensor, pickup, breather and pump 3 times!

    So monday I purchased a mark 1 s3 with 95000 on the clock, after driving it home with the oil light flashing intermittently I began asking the previous owner for any advice, he then proceeded to tell me that he had the oil pump changed 3 times, the breather once, sensor once and pickup once and yet it still persisted. He then told me that a friend of his had said that the sump plug thread was knackered and that it needs to be helicoiled, could this really be the reason for the red oil light to keep coming on?
    Any help much appreciated, thinking about replacing the sump and plug to see if it solves it!

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    voorhees's Avatar
    Moderator

    Status
    Offline
    Join Date
    Dec 2005
    Location
    Leafy Warwickshire
    Posts
    14,911

  4. #3
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    So if the sump plug is bad, the light could be no oil??
    Stop driving it until you source the problem, or the red light will be the least of your worries...

  5. #4
    voorhees's Avatar
    Moderator

    Status
    Offline
    Join Date
    Dec 2005
    Location
    Leafy Warwickshire
    Posts
    14,911
    Sad to see an S treated this way

  6. #5
    kwistof's Avatar
    South East Events Moderator

    Status
    Online
    Join Date
    Jun 2010
    Location
    SE Kent
    Posts
    2,281

    My Social Networking

    Follow kwistof On Twitter Visit kwistof's Youtube Channel Visit kwistof's Instagram Channel
    Quote Originally Posted by tiki2402 View Post
    after driving it home with the oil light flashing intermittently
    Did you pull over and even check the oil level once the light was flashing?
    2000 S3 APY

    18" BBS RSII with Michelin PS3s, 20mm H&R adapters, Relentless 3" DP and Sports cat, B5 V1 induction kit, cone filter+heat shield, Forge 007P, Awesome GTI SMF, AP coilovers, Facelift rear lights, Full Powerflex poly bush kit, R32 Rear ARB, SAI delete, N249 by-pass, Upgraded Engine mounts with Polytek, Stage 1 CC at Badger 5.

  7. #6
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    The oil level is near on perfect, any ideas? Thanks

  8. #7
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    I would get the sump off, what people say they have done and what as been done maybe different?

  9. #8
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Good point, I thought that too, but there are receipts to prove it, it had a bottom end rebuild a couple thousand miles ago, could the sump plug have been put back shabbily? Should also say that 2000 miles ago was 2 years ago.

  10. #9
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Also its just been in for a recent service, maybe that could've damaged the plug. Can anyone recommend a place to get a sump and plug kit from? Thanks for the help

  11. #10
    kwistof's Avatar
    South East Events Moderator

    Status
    Online
    Join Date
    Jun 2010
    Location
    SE Kent
    Posts
    2,281

    My Social Networking

    Follow kwistof On Twitter Visit kwistof's Youtube Channel Visit kwistof's Instagram Channel
    Quote Originally Posted by tiki2402 View Post
    Should also say that 2000 miles ago was 2 years ago.
    Bloody hell....

    I did 2000 miles just in August of this year! lol

    In terms of a sump, plug and kit from- 3 options I've found.

    1. TPS - OEM genuine parts cheaper than dealer.
    2. GFS/ Euro Car Parts/ Car parts 4 less - doubt they will be OEM genuine but will be the cheapest option - check between the 3 sites for the cheapest option.
    3. Forge baffled sump - if you want to upgrade the sump from OEM - it's about twice the price of an OEM one....you will also need to buy a sump plug and ring. I've got an ECS tuning one...these both can be purchased from Awesome GTI or DPM who are a site sponsors
    2000 S3 APY

    18" BBS RSII with Michelin PS3s, 20mm H&R adapters, Relentless 3" DP and Sports cat, B5 V1 induction kit, cone filter+heat shield, Forge 007P, Awesome GTI SMF, AP coilovers, Facelift rear lights, Full Powerflex poly bush kit, R32 Rear ARB, SAI delete, N249 by-pass, Upgraded Engine mounts with Polytek, Stage 1 CC at Badger 5.

  12. #11
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Quote Originally Posted by kwistof View Post
    Bloody hell....

    I did 2000 miles just in August of this year! lol

    In terms of a sump, plug and kit from- 3 options I've found.

    1. TPS - OEM genuine parts cheaper than dealer.
    2. GFS/ Euro Car Parts/ Car parts 4 less - doubt they will be OEM genuine but will be the cheapest option - check between the 3 sites for the cheapest option.
    3. Forge baffled sump - if you want to upgrade the sump from OEM - it's about twice the price of an OEM one....you will also need to buy a sump plug and ring. I've got an ECS tuning one...these both can be purchased from Awesome GTI or DPM who are a site sponsors


    Well the last owner before me had done 2000 miles in 2 years as he had a van for work, awesome dude thats some great info, will have a look at all of those options, baffled sump sounds very tempting though!

  13. #12
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    I'd get a third party oil pressure sensor and plumb it in so you can see what the oil pressure really is.

    Maybe it's a dodgy earth somewhere - just an electrical gremlin?

    Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  14. #13
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Quote Originally Posted by vfr800 View Post
    I'd get a third party oil pressure sensor and plumb it in so you can see what the oil pressure really is.

    Maybe it's a dodgy earth somewhere - just an electrical gremlin?

    Liam
    Thanks liam

    Would a local garage be able to do that? Cheers

  15. #14
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    I'd hope so, but it's the sort of thing I'd do myself.

    I had a look on eBay earlier and there were quite a few sensors and display bundles for not too much £. You need to make sure you know where to plumb it in and stuff etc.

    Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  16. #15
    kwistof's Avatar
    South East Events Moderator

    Status
    Online
    Join Date
    Jun 2010
    Location
    SE Kent
    Posts
    2,281

    My Social Networking

    Follow kwistof On Twitter Visit kwistof's Youtube Channel Visit kwistof's Instagram Channel
    Quote Originally Posted by tiki2402 View Post
    Would a local garage be able to do that? Cheers
    If you're not carrying out the work yourself, then what's your location?

    You could be round the corner from a reputable VAG tuner for all you know
    2000 S3 APY

    18" BBS RSII with Michelin PS3s, 20mm H&R adapters, Relentless 3" DP and Sports cat, B5 V1 induction kit, cone filter+heat shield, Forge 007P, Awesome GTI SMF, AP coilovers, Facelift rear lights, Full Powerflex poly bush kit, R32 Rear ARB, SAI delete, N249 by-pass, Upgraded Engine mounts with Polytek, Stage 1 CC at Badger 5.

  17. #16
    Andrew@A.L.D's Avatar
    Cylinder Head Master

    Status
    Offline
    Join Date
    Jun 2009
    Location
    Leeds
    Posts
    3,470
    What grade of oil are you running ?
    RIP S3dave/David Marshall stickers now available

    FOR SALE
    None resonated Milltek exhaust,
    Adjustable FPR from 1-5 bar, 2 sets of Unused ARP 3/8 2000 rod bolts, relentless 200 cell cat pipe, Std AGU Crankshaft. Ported & Reconditioned Cylinder head service.

  18. #17
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Im running 5w30 and im located in norwich, norfolk. I wouldn't know where to plumb in the new sensor so would leave that to a professional.
    Thanks for the help.

  19. #18
    kwistof's Avatar
    South East Events Moderator

    Status
    Online
    Join Date
    Jun 2010
    Location
    SE Kent
    Posts
    2,281

    My Social Networking

    Follow kwistof On Twitter Visit kwistof's Youtube Channel Visit kwistof's Instagram Channel
    I'm from the SE - so can't be of much help concerning garages in your area- but maybe someone else could recommend one in your area mate.

    Get off the 5w30 and chuck some Quantum Platinum 5w40 in her (available from TPS)
    2000 S3 APY

    18" BBS RSII with Michelin PS3s, 20mm H&R adapters, Relentless 3" DP and Sports cat, B5 V1 induction kit, cone filter+heat shield, Forge 007P, Awesome GTI SMF, AP coilovers, Facelift rear lights, Full Powerflex poly bush kit, R32 Rear ARB, SAI delete, N249 by-pass, Upgraded Engine mounts with Polytek, Stage 1 CC at Badger 5.

  20. #19
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Quote Originally Posted by kwistof View Post
    I'm from the SE - so can't be of much help concerning garages in your area- but maybe someone else could recommend one in your area mate.

    Get off the 5w30 and chuck some Quantum Platinum 5w40 in her (available from TPS)
    much obliged kwistof!

  21. #20
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Replacing the oil sump and oil pressure switch on Tuesday along with some decent 5w40 oil and filter, will let you know the outcome! Thanks

  22. #21
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,639
    How about testing the oil level sensor plug to see if it's seeing any voltage? Might have a dodgy wire?
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

  23. #22
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    The sump plug recieves a voltage? Thats new to me, tell me more....

  24. #23
    Gops's Avatar
    6th gear @7000rpm

    Status
    Offline
    Join Date
    Nov 2009
    Location
    Coventry
    Posts
    2,639
    Edited!^
    Quote Originally Posted by <tuffty/> View Post
    its either mapped or broken...

  25. #24
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Ah I see, will do, thanks for the advice, although it's not the oil level sensor light coming on ita the oil pressure light.

  26. #25
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Update: Replaced the sump, oil and filter today, found the cause of the problem, looks like the last person to have the sump off put a bit too much sealant around the pickup pipe gasket, causing it to partially block of some oil flow, all sorted now, no more annoying oil light! Yipee!
    Attached Images Attached Images
    s3dave likes this.

  27. #26
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    Great news but sealant should not be on the pickup, it should have an O ring to seal..

  28. #27
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    I think thats what it was, it may be the oil return pipe for the turbo actually.

  29. #28
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Ok update again:

    So last monday I replaced the sump, oil and filter and the light stayed a way for a day or so and came back on, gutted!

    So today I replaced the gasket for the oil feed pipe for the turbo at the sump end and replaced the oil pressure sensor with an aftermarket one, now the light seems to come on more regularly than before!

    Any help people?

    So ive devided to replace the oil pressure switch with a genuine audi part tomorrow to see if it cures the problem.

    Also ive heard using a genuine audi oil filter may make a difference, can anyone shed anu light on this?

    Much Love

  30. #29
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Update!

    Replaced the oil pressure sensor with a genuine article and all is good! Bout time!
    s3dave likes this.

  31. #30
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Update again:

    Oil light back on but not as much, only happens when the car is warm and below 2k revs, really running out of ideas now, any advice peeps?

    Thanks

  32. #31
    ManuGD's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2012
    Location
    Barcelona, Spain
    Posts
    24
    Could it be low oil pressure?
    IMHO it would be great to install a gauge to check the oil pressure under different use conditions. Maybe then you can make some conclusions.
    A friend with a BMW had similar issues and it was all about oil pressure.

  33. #32
    tiki2402's Avatar
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2013
    Posts
    28
    Yeah I think thats the next step tbh, other than getting an oil pressure test done, thanks.

 

 

Similar Threads

  1. oil light flashing
    By daz616 in forum A4/S4 forum(B5 Chassis)
    Replies: 4
    Last Post: 22nd July 2010, 11:28
  2. oil light flashed up?
    By Bellic in forum A4/S4 forum(B5 Chassis)
    Replies: 2
    Last Post: 24th August 2007, 18:03
  3. oil light flashed up?
    By Bellic in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 24th August 2007, 01:02
  4. Audi 100 Oil Light at 3000rpm
    By blued in forum Classic Audi Forum
    Replies: 4
    Last Post: 27th March 2006, 14:08
  5. Audi A4 Oil Light - HELP HELP :(
    By slips in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 0
    Last Post: 26th January 2005, 18:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO