Badger5AH Fabrications
Results 1 to 16 of 16
Like Tree3Likes
  • 1 Post By <tuffty/>
  • 1 Post By <tuffty/>
  • 1 Post By <tuffty/>

Thread: 02 sensor question help please

  1. #1
    Neutral

    Status
    Offline
    Join Date
    Aug 2013
    Posts
    37

    02 sensor question help please

    hi all i have just had my fault codes read and it said after cat 02 sensor fault is there more that one 02 sensor on this car then?

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,449
    Quote Originally Posted by xxxxSMITHYxxxx View Post
    hi all i have just had my fault codes read and it said after cat 02 sensor fault is there more that one 02 sensor on this car then?
    Yes... post cat and pre cat... post cat is for cat efficiency, pre cat is for fuelling..

    What are the actual codes? not all codes mean a component is faulty... do you have a de-cat?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  4. #3
    Jonesy's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Kent
    Posts
    570
    I take it the pre cat is the one you can see from under the car, closest to the exhaust? Mines just failed MOT pretty badly on CO emissions and lambda, not sure whether to get new sensors or buy a second hand cat.

    Been getting P0171 'system too lean (bank1)' and P0420 'cat system efficiency below threshold (bank1)' for a while, if I clear them they come back within weeks.

    Allan
    2001 Audi S3 - Facelift - Revo remap - Forge 007p DV - BMC Panel Filter- Type R Ariel - Aero wipers - n75j valve.

  5. #4
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,449
    Quote Originally Posted by Jonesy View Post
    I take it the pre cat is the one you can see from under the car, closest to the exhaust? Mines just failed MOT pretty badly on CO emissions and lambda, not sure whether to get new sensors or buy a second hand cat.

    Been getting P0171 'system too lean (bank1)' and P0420 'cat system efficiency below threshold (bank1)' for a while, if I clear them they come back within weeks.

    Allan
    On your S3 the precat wideband lambda is up top and can bee seen from the engine bay (bank 1 S1), the post cat sensor (bank 1 S2) is just after the cats and can be seen from underneath...

    Your PO171 code is
    16555/P0171/000369 - Ross-Tech Wiki

    16555/P0171/000369 - Fuel Trim; Bank 1: System Too Lean
    Possible Causes

    Mass Air Flow Sensor (G70) defective
    Intake System Leak(s)

    Possible Solutions

    Check Mass Air Flow Sensor (G70)
    Check Fuel Pressure Regulation
    Check Fuel Pump
    Check Injectors
    Check Intake System for Leaks
    Check Exhaust System for Leaks
    Check Secondary Air System for Leaks
    Check Vacuum Pipes for Leaks

    This code should NOT be ignored as it appears when fuel additive adaption has reached the max 25% and you are now running potentially lean fuelling which can result in severe engine damage...

    The PO420 code is...
    16804/P0420/001056 - Ross-Tech Wiki
    16804/P0420/001056 - Catalyst System; Bank 1: Efficiency Below Threshold
    Possible Causes

    Leakage in Intake and/or Exhaust System
    Catalyst faulty
    Oxygen Sensor(s) faulty
    Oxygen Sensor(s) Control faulty

    Possible Solutions

    Check Intake and Exhaust System for Leaks
    Check Catalyst
    Check Oxygen Sensor(s)
    Check Oxygen Sensor(s) Control
    Perform Oxygen Sensor(s) Aging Check
    This typically means your CATS are no longer working and need replacing...

    <tuffty/>
    Jonesy likes this.
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  6. #5
    Jonesy's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Kent
    Posts
    570
    Thanks tuffty, so you'd recommend a new catalytic converter? I'm on a budget so gonna try source a second hand jobby. Does this one look ok, comes with post cat sensor as well. AUDI S3 A3 8L Exhaust Twin Cat Catalytic Convertor K04 1.8T BAM 225bhp 1997-2003 | eBay

    Allan
    2001 Audi S3 - Facelift - Revo remap - Forge 007p DV - BMC Panel Filter- Type R Ariel - Aero wipers - n75j valve.

  7. #6
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,449
    Quote Originally Posted by Jonesy View Post
    Thanks tuffty, so you'd recommend a new catalytic converter? I'm on a budget so gonna try source a second hand jobby. Does this one look ok, comes with post cat sensor as well. AUDI S3 A3 8L Exhaust Twin Cat Catalytic Convertor K04 1.8T BAM 225bhp 1997-2003 | eBay

    Allan
    I did say it 'typically' means the cats are on their way out... you should be able to get this verified at an MOT station as the emissions test will fail...

    Assuming you have std downpipe then yeah, they look ok but be aware that they will come off a car of similar age and therefore subject to failing sooner rather than later... buying from a dealer will be silly prices but I believe there are after market versions (even the miltek sports cats may work out cheaper than new OE)... there is also the option to go 3" dp and sports cat...

    While you are on a budget at least you have some options...

    Get it tested first but it is also possible that the code is related to your other fault code... personally I would look to fix the 'lean' issue first then worry about the CATs... lean problem is almost certainly a massive split pipe under the inlet mani..

    <tuffty/>
    Jonesy likes this.
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  8. #7
    Jonesy's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Kent
    Posts
    570
    The MOT station were useless, told me to hook it up to a diagnostic machine, which I've already done. Yeah everything is standard. Im gonna order that part and find a decent exhaust garage to fit and check for any other probs, leaks etc. Ill also have a look for split pipes near manifold, from what I can remember, I did have a split pipe years ago and replaced the whole bunch under there, was such a pain to do! Thanks again for the help. Sorry to OP for hijacking the thread.

    Allan
    Last edited by Jonesy; 9th September 2013 at 19:32.
    2001 Audi S3 - Facelift - Revo remap - Forge 007p DV - BMC Panel Filter- Type R Ariel - Aero wipers - n75j valve.

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Aug 2013
    Posts
    37
    hi tuffty,,

    i cant remember what code it was but i remember it saying it was a post cat sensor fault,
    because when i took the car to the garage on used a new snap on code reader it said it was the post cat sensor.
    but the car is smelling like it is over fueling slightly so does the post cat sensor not help with the fuel trim at all becuase i dont wana buy the wrong part as they are not cheap, only one on the sensor was giving a reading 0.25 and the second one was not giving any reading at all.
    I could realy use some help with this one please

  10. #9
    Neutral

    Status
    Offline
    Join Date
    Aug 2013
    Posts
    37
    Anyone

  11. #10
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,449
    A disconnected post cat sensor can affect adaptions... if you have a smell of fuel its something else... you need to scan with VCDS realistically and find out what the codes are... all the post cat sensor does is monitor CAT efficiency, most of the time they get coded out in a remap due to customers fitting decat's or sports cats...

    Fuel smell is typically a leak as its rare that these ECU's run that rich you can smell the fuel... you need to check fuel trims in VCDS too (requires a registered version)... also worth checking the FPR to see if its blocked... the rubber hoses deteriorate and bits clog up the FPR causing higher fuel pressure and this could be forcing a leak or over fuelling...

    Sorry to say but diagnosis almost always starts with VCDS on these cars... the snapon/generic fault code readers can more difficult to diagnose from although they are a start... really need the fault codes to be able to work back from there

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Aug 2013
    Posts
    37
    i have the lite version of vcds but my obd connecter is a bit tempermental lol
    i have a visual check of both sensors in the exhaust system ,

    also if anyone has vcds in my area this would be a great help
    thanks for the info

  13. #12
    Jonesy's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Kent
    Posts
    570
    Hey Tuffty, I could have possibly found something under the inlet manifold with the PCV breather pipes. I have noticed the one part of plastic that looks like a Y shape has a pipe to the right of it touching and just sitting inside but not properly sealed. Thought that maybe you can push and they would click together but no luck. Doesn't look like there is meant to be a clip either.

    Here's a picture, part is labelled 058-133-753-B and to the right is the pipe that just sits inside loosely.



    Thanks again,

    and Smithy ill PM you in a bit regarding the vcds program.
    2001 Audi S3 - Facelift - Revo remap - Forge 007p DV - BMC Panel Filter- Type R Ariel - Aero wipers - n75j valve.

  14. #13
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,449
    Quote Originally Posted by Jonesy View Post
    Hey Tuffty, I could have possibly found something under the inlet manifold with the PCV breather pipes. I have noticed the one part of plastic that looks like a Y shape has a pipe to the right of it touching and just sitting inside but not properly sealed. Thought that maybe you can push and they would click together but no luck. Doesn't look like there is meant to be a clip either.

    Here's a picture, part is labelled 058-133-753-B and to the right is the pipe that just sits inside loosely.



    Thanks again,

    and Smithy ill PM you in a bit regarding the vcds program.
    Its an 'air pump' if thats in pieces then its where your leak is... tbh that whole setup is 100 quid or more from a dealer... most peeps bin it all off to simplify... usually using a catch tank for the PCV

    <tuffty/>
    Jonesy likes this.
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  15. #14
    Jonesy's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Kent
    Posts
    570
    its not in pieces and doesn't look broken just doesn't look secure. TBH I think it was a sealed unit and is not meant to come apart. That whole left side and middle I replaced a few years back when the W bend rubber part split.

    So you think this could be the cause of the emissions failing? Would be cheaper to replace this than cat and o2 sensors...

    Thanks again,

    Allan

    edit - I've ordered the part from Audi, bout to go pick it up. Part no. 058 133 753 D. £21.00 plus VAT
    Last edited by Jonesy; 10th September 2013 at 15:16.
    2001 Audi S3 - Facelift - Revo remap - Forge 007p DV - BMC Panel Filter- Type R Ariel - Aero wipers - n75j valve.

  16. #15
    Jonesy's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Kent
    Posts
    570

    Red face

    Thought id update the post, I fitted the new pipe under the inlet manifold and what a pain those old Audi clips are!!! Car felt better straight away smoother through the revs and idles much better. Also fitted a new panel filter as my old one looked knackered and changed plugs, cleaned MAF and the throttle body.

    Ordered a new cat few days ago, second-hand one from a breakers for £120. Went to get it fitted today and was told the part was too short by a few inches and the diameter was smaller, brilliant! Anyway they hooked up the emissions machine as they were curious to see how bad it was and surprisingly it had got better, but was still not passing.

    They told me to put the Cataclean in that I had bought earlier in Halfrauds and to go for a blast up the motorway for half hour or so. Did this and went back and it passed straight away.

    CO went down from 1.487 to 0.197
    HC went down from 57 to 19
    Lambda went up from 0.960 to 1.000

    Idle test CO was originally 1.493 and now is 000.5

    Anyway Im happy, gonna try get a refund on cat. The garage seem to think it is the precat lambda sensor playing up but hopefully it just needed cleaning, time will tell....

    Allan
    2001 Audi S3 - Facelift - Revo remap - Forge 007p DV - BMC Panel Filter- Type R Ariel - Aero wipers - n75j valve.

  17. #16
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,449
    Quote Originally Posted by Jonesy View Post
    Thought id update the post, I fitted the new pipe under the inlet manifold and what a pain those old Audi clips are!!! Car felt better straight away smoother through the revs and idles much better. Also fitted a new panel filter as my old one looked knackered and changed plugs, cleaned MAF and the throttle body.

    Ordered a new cat few days ago, second-hand one from a breakers for £120. Went to get it fitted today and was told the part was too short by a few inches and the diameter was smaller, brilliant! Anyway they hooked up the emissions machine as they were curious to see how bad it was and surprisingly it had got better, but was still not passing.

    They told me to put the Cataclean in that I had bought earlier in Halfrauds and to go for a blast up the motorway for half hour or so. Did this and went back and it passed straight away.

    CO went down from 1.487 to 0.197
    HC went down from 57 to 19
    Lambda went up from 0.960 to 1.000

    Idle test CO was originally 1.493 and now is 000.5

    Anyway Im happy, gonna try get a refund on cat. The garage seem to think it is the precat lambda sensor playing up but hopefully it just needed cleaning, time will tell....

    Allan
    If it was a smaller diameter its from an A3 TQS...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

 

 

Similar Threads

  1. Traction Control/Quattro question HELP please
    By crazychris in forum A3/S3 Forum (8L Chassis)
    Replies: 5
    Last Post: 26th November 2010, 16:46
  2. bose questions ...help please
    By 10blazin in forum In-Car Entertainment
    Replies: 9
    Last Post: 11th May 2009, 18:39
  3. S3 Newbie, questions, HELP PLEASE
    By mac6967 in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 6th November 2008, 13:17
  4. S3 Newbie, questions, HELP PLEASE
    By mac6967 in forum A3/S3/Sportback (8P Chassis)
    Replies: 6
    Last Post: 5th November 2008, 23:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO