Monster MotorsportEM Tuning
Results 1 to 8 of 8
  1. #1
    S3 TAM's Avatar
    Pocket now empty

    Status
    Offline
    Join Date
    Oct 2009
    Location
    London & Hertfordshire
    Posts
    621

    knock sensor 2 issue's

    Hello All,

    I'm back after not posting for some time. Just been enjoying the S3 until now.

    For the past few months i've been getting VCDS error

    16717/P0333/000819 - Knock Sensor 2 (G66): Signal too High

    Possible Symptoms


    • Engine Damage
    Possible Causes

    • Knock Sensor 2 (G66) improperly torqued
    Possible Solutions

    • Torque Knock Sensor 2 (G66) to specifications
    • Check Knock Sensor 2 (G66) and Knock Control

    I tried every thing the vcds wiki page has said from checking the torque to replacing the sensor this leaves one thing left

    ENGINE DAMAGE

    What could this be? something in the bottom end about to give up?

    Is it time for me the put the large port head on the motor that i've had sitting in my garage for 1 1/2 years?

    this brings me to my next question which i think i already know the answer too. "don't shoot me down for this"

    Would you buy this off ebay

    for Audi S3 A4 TT 1.8T VW Golf Gti Con Rod Conrod H-beam Connecting Rod Rods ARP | eBay

    Money's tight at the min saving for a house and a wedding... silly me i know, but if im gonna change the head i might as well do the bottom end or vice versa.

    cheers in advance.



    Revo Stage 2 with all the Gear
    BHP = 274 / Torque = 293




  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    S3 TAM's Avatar
    Pocket now empty

    Status
    Offline
    Join Date
    Oct 2009
    Location
    London & Hertfordshire
    Posts
    621
    ohh forgot to ask would running a large port head on standard rods be ok?

    if money wasn't an object hey.
    Revo Stage 2 with all the Gear
    BHP = 274 / Torque = 293




  4. #3
    S3 TAM's Avatar
    Pocket now empty

    Status
    Offline
    Join Date
    Oct 2009
    Location
    London & Hertfordshire
    Posts
    621
    Just found a post from tuffty

    which i haven't tried. i hate wiring.....

    VAGCOM - Knock Sensor problem
    Revo Stage 2 with all the Gear
    BHP = 274 / Torque = 293




  5. #4
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,559
    Quote Originally Posted by S3 TAM View Post
    Just found a post from tuffty

    which i haven't tried. i hate wiring.....

    VAGCOM - Knock Sensor problem
    Haha... yeah, one of my first posts as a n00b 4 years ago lol... all have to start somewhere

    Re-wire worked for me... its not as bad as it looks as you can just run the new cable along side and patch in...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  6. #5
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,559
    Those rods aren't rifle drilled so tbh I wouldn't touch them personally... I would also not bother with a large port head unless going north of 350hp...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  7. #6
    Vex182's Avatar
    Guess what I drive...

    Status
    Offline
    Join Date
    Apr 2012
    Location
    Hinckley
    Posts
    879

    My Social Networking

    Add Vex182 on Facebook
    I've got the same code but in knock sensor 1 at the minute, I'm hoping its just a loose sensor and not the cable. For the first 30 seconds of driving, the car feels rough and underpowered but then disappears and the car drives great! If the car is up to temp then the car drives complete fine when restarted, I guess it is related to this one code.
    Silver 2002 Audi S3 225 (BAM) since March 2011.

    Mods: Badger5 2.2 TIP, Jetex filter, PCV delete, 710 DV, Standard N249 in use, R-Tech Stage 1 TiV Remap, Audi TT Pedals, Red Dogbone, Polybushed tie arms. All silicone boost pipes, Michelin PS3s, Red V6 coil packs, MK4 flat blade conversion, retrofited cruise control.
    Currently: 254bhp - 276lb/ft (174bhp/ton) as of 11/02/2013 On V-Power

  8. #7
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,559
    Quote Originally Posted by Vex182 View Post
    I've got the same code but in knock sensor 1 at the minute, I'm hoping its just a loose sensor and not the cable. For the first 30 seconds of driving, the car feels rough and underpowered but then disappears and the car drives great! If the car is up to temp then the car drives complete fine when restarted, I guess it is related to this one code.
    Yeah, if the ECU thinks it can't see knock as the sensor is playing up or if the signal is not as expected then it will pull timing out and you will lose torque...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  9. #8
    Westy's Avatar
    Double Dark Side! Diesel & 8P

    Status
    Online
    Join Date
    Dec 2008
    Location
    Cambridgeshire sometimes Hertfordshire
    Posts
    17,273
    Quote Originally Posted by S3 TAM View Post
    Saving for a house and a wedding.
    she'll murder you!
    8P A3 TDI - 220bhp - 335lbft
    A3 Maintenance Thread
    Bye bye S3 you will be missed.
    S3 Build Thread







 

 

Similar Threads

  1. Knock Sensor 2.8q 30v
    By dsmclark40v in forum A4/S4 forum(B5 Chassis)
    Replies: 0
    Last Post: 18th May 2007, 10:03
  2. KNOCK SENSOR
    By vw754 in forum General Technical / How To
    Replies: 3
    Last Post: 30th March 2007, 15:54
  3. KNOCK SENSOR
    By vw754 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 0
    Last Post: 26th March 2007, 10:24
  4. Parking sensor issues
    By dan1 in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 0
    Last Post: 4th April 2006, 09:32
  5. What can knock a knock sensor?
    By MisterD in forum General Technical / How To
    Replies: 15
    Last Post: 20th May 2003, 13:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO