AH FabricationsVolks Autos
Results 1 to 2 of 2
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Nov 2012
    Posts
    44

    S3 wiper and indicator problems need help ASAP!!!

    My S3 has started giving me a headache this week! First the rear wiper wouldn't turn off so I had to pull the fuse to avoid looking like an idiot and marking the glass, I've scavenged the forum and noticed some comments about the wiper motor and water getting into it which could also cause the boot open light to come up on the dash which did happen last week had to open and close it three time before it went out and now the wiper won't turn off!

    Also my indicators have gone on the blink, or more so don't blink lol, when u move the stalk the first click makes a single blink but doesn't stay on though the stalk is locked into turn position, I have noticed if you hold the stalk before the click they do sometimes work? Hazards are fine though I have seen comments about the relays being in the hazard switch and this being the issue.

    i thought it was the stalks so I had ordered and just received a pair from the bay in good condition, but whole I was looking for some fitting/repair guides or diagrams I came across the new info and I'm possibly about to waste my time fitting stalks that won't fix the issue. Could any of you shed any light or your own experiences on these problems and the correct fixes, any diagrams etc would be a great help in me fixing the problems too.

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,024
    The indicator issues is the hazard light switch... this is where the indicator relay is... this is a 35 or so quid part from a dealer

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

 

 

Similar Threads

  1. Random wiper and indicator problems
    By S3 chj in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 6th August 2013, 23:28
  2. Need help ASAP on water problem :(
    By audi-tk in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 14th March 2011, 16:32
  3. A4 Tdi, engine problem AND steering problem! PLEASE help!!
    By mattsavage in forum A4/S4 forum(B5 Chassis)
    Replies: 5
    Last Post: 27th February 2007, 16:02
  4. Problem - Need Help please
    By Herby1 in forum A3/S3 Forum (8L Chassis)
    Replies: 20
    Last Post: 12th January 2007, 11:48
  5. BIG PROBLEM,NEED HELP FELLAS
    By imported_RELOADED99 in forum A4/S4 forum(B5 Chassis)
    Replies: 2
    Last Post: 15th January 2005, 19:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO