Volks AutosSky Insurance
Results 1 to 13 of 13
  1. #1
    Neutral

    Status
    Offline
    Join Date
    Sep 2005
    Location
    wales
    Posts
    58

    Indicator problems

    Hi guys, ive done a search can't find anything about it so am hoping someone may be able to help.

    I noticed the other day the indicactors seemed to be not flashing at a regular time the, they would seem to miss a beat every now and again. Anyway yesterday they would turn on for a couple of flashes then turn off, if you flicked the switch off and back on again they would do the same again although maybe flashing slightly longer. The right is worse than the left but they both do it.

    Sometimes they work normally but most of the time they don't. The hazzards by the way function perfectly all the time.

    Any help would be appreciated as you can imagine its quite dangerous !

    Thanks

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    Post Whore

    Status
    Offline
    Join Date
    Jul 2004
    Location
    Southampton
    Posts
    1,747

    Re: Indicator problems

    I have that problem all the time [img]/ubbthreads/images/graemlins/laugh_roll.gif[/img]

  4. #3
    Numptie of the highest order

    Status
    Offline
    Join Date
    Jun 2004
    Location
    Crowthorne, England
    Posts
    2,512

    Re: Indicator problems

    get back in your box BMW boy! [img]/ubbthreads/images/graemlins/laugh_2.gif[/img]

    It could be the relay that controls the flashing is buggered - shouldn't be too expensive to get the part and it's only a few screws to remove the panel under the steering wheel to get to I believe.

  5. #4
    Khufu's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    West coast of Scotland
    Posts
    5,693

    Re: Indicator problems

    It happened on my A3 and as said it was the indicator flasher unit which on my model (1998) is the hazzard warning switch too. Its not to dear but you do have to take the centre console apart to get it out.

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Jul 2005
    Location
    Colchester
    Posts
    46

    Re: Indicator problems

    If the indicator flasher has gone and you need to remove you centre consule or take it apart. I create a post on how to do this recently.

    I have an S3 - X reg. (Hopefully this link works - if not do search on my login name.)

    http://www.audi-sport.net/ubbthreads/sho...true#Post347004

  7. #6
    S3Steve's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    Peterborough
    Posts
    1,588

    Re: Indicator problems

    Definately sounds like the relay in the hazard switch as i had exactly the same problem. Got a new switch from audi for 28. Changing it wasnt hard either, half hour tops, had to take the radio out to get access to the back of the switch as its held in with two spring clips

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Sep 2005
    Location
    wales
    Posts
    58

    Re: Indicator problems

    Thanks guys for all the help, but how come the hazard switch is causing the problem as the hazards work fine. Does the relay control the left and right as well ?

  9. #8
    S3Steve's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    Peterborough
    Posts
    1,588

    Re: Indicator problems

    Their is two seperate relays inside the switch, one controls the indicators and the other controls the hazards. Like yours when mine went the hazards worked fine.

  10. #9
    Neutral

    Status
    Offline
    Join Date
    Sep 2005
    Location
    wales
    Posts
    58

    Re: Indicator problems

    [ QUOTE ]
    Their is two seperate relays inside the switch, one controls the indicators and the other controls the hazards. Like yours when mine went the hazards worked fine.

    [/ QUOTE ]

    Thanks I shall get down the stealers and order one. [img]/ubbthreads/images/graemlins/wink.gif[/img]

  11. #10
    S3Steve's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Sep 2005
    Location
    Peterborough
    Posts
    1,588

    Re: Indicator problems

    Have you got the keys to get the radio out? If not ask the dealer to remove it for you when you get switch, as you will need it out to replace the switch.

  12. #11
    Neutral

    Status
    Offline
    Join Date
    Sep 2005
    Location
    wales
    Posts
    58

    Re: Indicator problems

    [ QUOTE ]
    Have you got the keys to get the radio out? If not ask the dealer to remove it for you when you get switch, as you will need it out to replace the switch.

    [/ QUOTE ]

    No I don't, I will ask them, thanks for the advice !

  13. #12
    Neutral

    Status
    Offline
    Join Date
    Sep 2005
    Location
    wales
    Posts
    58

    Re: Indicator problems

    Just an update, part collected from dealers today - 32 inc vat. They kindly removed the radio for me - Thanks Sinclair Audi Swansea -
    and with a bit of fiddling in went the new switch ! They now work perfectly thanks for the help !

  14. #13
    The Slug's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Nov 2004
    Location
    UK
    Posts
    1,853

    Re: Indicator problems

    [ QUOTE ]
    Definately sounds like the relay in the hazard switch as i had exactly the same problem. Got a new switch from audi for 28. Changing it wasnt hard either, half hour tops, had to take the radio out to get access to the back of the switch as its held in with two spring clips

    [/ QUOTE ]

    Had this exact same problem, Audi roadside assist came out, took off fascia plate around the Hazard button, slide out old relay (part of the hazard button) and slipped new one in, click fascia plate back on, took the guy less than 60seconds, lol. (2003 model) Just for the record, hehe.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO