JMB RetrofitsBadger5
Results 1 to 16 of 16
Like Tree1Likes
  • 1 Post By vrbob

Thread: Emissions control light?

  1. #1
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Birmingham
    Posts
    212

    Emissions control light?

    Last night this started flashing car seemed ok until put under load which caused it to hesitate and struggle. Now the lights constantly illuminated and the car is struggling feeling a bit lumpy and the idle has got worse dropping off then picking up.
    Am I on the right track suspecting a leaking pipe or pipes? I have had the car a week today and this engine is totally new to me a little bit annoying happening so soon!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Online
    Join Date
    Jul 2008
    Posts
    8,534
    what engine is it ?

  4. #3
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Birmingham
    Posts
    212
    Sorry about that completely forgot it's a 2001 S3 Amk engine.

  5. #4
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Online
    Join Date
    Jul 2008
    Posts
    8,534
    a coil pack gone down ?
    they make the light flash and misfire ?
    get it on vcds for codes.

  6. #5
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,607
    As above, scan for fault codes, look up what they mean (links in the FAQ sticky) then post up the findings... we can help out with anything you are not sure of from there

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  7. #6
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Birmingham
    Posts
    212
    I think I'll order vcds as I had intended to just not quite so quickly! I was trying to find somewhere to get it scanned but not had much luck being a Saturday local vag specialist was shut. Not keen on racking up too many miles whilst it's running the way it is.

  8. #7
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,607
    the light is not just for emissions btw... the CEL (check engine light) comes on for a number of reasons... if it flickers on and off then it could be from a misfire... if its stays on then it normally means an important sensor is showing a fault (typically the MAF)

    Scan for codes first and have a look for split pipes etc under the inlet manifold...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  9. #8
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Birmingham
    Posts
    212
    It is the only light I've had so far it was flickering then going off now stays lit then flickers under load. I did have a feeling it wasn't an emissions issue my Vw bora threw up a glow plug light if a brake light was out.
    I've messaged about buying vcds so with any luck I can get it sorted early in the week bit of a pain but I suppose these things happen!

  10. #9
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Online
    Join Date
    Jul 2008
    Posts
    8,534
    where do you live ?

  11. #10
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Birmingham
    Posts
    212
    I'm in Stourbridge near Birmingham from looking at the map the nearest people with VCDS are in Walsall. Could be about 40
    mins or so drive and no where to grab parts from tonight so I'll hopefully be able to scan the car Tuesday.

    thanks for the advice so far I am pretty clueless with this car at the minute but can see myself learning plenty and many dark evenings grazing my knuckles on it!

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Birmingham
    Posts
    212
    Bit of an update I've got my engine covers of and hoping I have found the issue... Under the manifold near the right hand side as you face it there is like a 90 degree bend coming up from the bottom appears to be plastic or metal? To the right of this there is a rubber pipe I assume should be attached as they line up both quite oily though I can't seem the get them back together. The rubber pipe looks as though it has a smaller pipe running off it. I'm going to strip it down a bit more tomorrow as access is fairly tight and I was just having a quick mess. I know my description is vague but does that sound likely to anyone?
    I can see a few more pipes that look like they need replacing but nothing oily or that stood out like the one mentioned. Next month I'll hopefully get as much as I can replaced with silicon.

  13. #12
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,607
    Pics?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  14. #13
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Birmingham
    Posts
    212
    IMG_2032.jpgIMG_2031.jpg Ok heres best I could do with the photos first one shows the actual pipe that has come apart. The second photo shows where it terminates in the top right is the hockey puck shape thing the pipe that's came apart is the one below it with the silver clip at the top.

    Thanks for taking the time to help also had an offer of someone scanning my car if I don't get anywhere so thanks again!

  15. #14
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Birmingham
    Posts
    212
    Ok got a better picture it appears to be a hard pipe that's broken cant see it had a join where it's split? It's on that elbow where it has a lip looks like a clean break. Managed to break out the dipstick holder too!

  16. #15
    vrbob's Avatar
    Thats no Moon, Thats a space station!

    Status
    Offline
    Join Date
    Jun 2007
    Location
    Southampton
    Posts
    2,363
    That part is prone to breaking, I broke mine trying to remove it when fitting my catch can. New part is about £30 from TPS or Audi and whilst your there you can pick up a new dipstick holder as they are about £4.

    Basically at the mo you have a boost leak hence the hesitation under load. Might be worth doing the N249 removal and also a catch can setup (check the stickies for guides) as this will help remove other old pipework and simplify the setup.
    Wallm0nkey likes this.
    Audi S3 8L BAM 225 2002 - Ming Blue : Silver Heated Leather, Armrest, RNS-E - Bose, Alloy Mirrors, 18" RSTT`s, Sunroof, Cruise, AutoDim Mirror & Usual S3 Extras.
    Mods : Badger 5 Stg 2 Custom Map, FMIC, 3" DP & 200 Cell Cat, 007P, Jetex Filter & 80mm TIP & Heatshield, Complete LED Kit, Gen VW Aero Wipers, Full Powerflex Kit, R32 RARB, AP Shocks & Springs, 15mm Front & 20mm Rear Spacers, BB Uprated Actuator,
    N249 Delete & Catch Can, AP TVR 4Pot Brakes & DS2500`s, Sachs Carbon/Kevlar Clutch

  17. #16
    1st Gear

    Status
    Offline
    Join Date
    May 2013
    Location
    Birmingham
    Posts
    212
    Just an update and thanks to all that helped me! Due to time constraints and needing to be at work plus needing the car back ASAP. I just didn't have the time to go about it the way I wanted Vcds would of been here on Tuesday and I was going to struggle collecting up the parts I needed after that. So took the easy route and I popped to the garage I use this morning and explained, they were fully booked but had a phonecall at 17:30 that I can collect tomorrow. Crankcase breather pipe broke again on the removal giving them some fun but that and another pipe that was split have been replaced as is dipstick and holder. Car was scanned and I had two knackered coil packs which have been replaced along with a new set of plugs.
    So car will be back and my idle issue cleared for tomorrow

    I'm still planning on getting myself VCDS and want to give my sump and pickup a clean next I seem to have grown a massive list of things I want to do and change now but thats my starters and it's just my second week of ownership I feel like I'm at the top of a very slippery slope!

 

 

Similar Threads

  1. Emission control light on - expensive quote from Audi to diagnose
    By Monsoon in forum A3/S3/Sportback (8P Chassis)
    Replies: 36
    Last Post: 2 Weeks Ago, 11:48
  2. Audi A3 8p emission control light, Surrey - VAG-com help?
    By Greenmunkey in forum A3/S3/Sportback (8P Chassis)
    Replies: 18
    Last Post: 24th July 2010, 03:01
  3. help.. Emission control light has come on..
    By andyb_88 in forum A3/S3/Sportback (8P Chassis)
    Replies: 9
    Last Post: 22nd May 2009, 11:23
  4. Emission control light on
    By khalil in forum A3/S3/Sportback (8P Chassis)
    Replies: 7
    Last Post: 30th October 2008, 18:16
  5. emissions control light on
    By GARTHY in forum A3/S3/Sportback (8P Chassis)
    Replies: 4
    Last Post: 20th December 2007, 12:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO