AH FabricationsMonster Motorsport
Results 1 to 16 of 16
  1. #1
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740

    VCDS Errors on ABS and Knock Sensor?

    Hi

    I was driving the car the other day and whilst braking on some bumpy tarmac the ABS kicked in for a split second. No problems, arrived at work, when I got in the car and started it to leave work the ESP and ABS warning lights came on and have stayed illuminated on the dash ever since.

    I scanned the car these two errors came up, I know they're unrelated, probably:

    VCDS-Lite Version: Release 1.2
    Friday, 03 May 2013, 15:39:45:5805
    Control Module Part Number: 8N0 907 379 E
    Component and/or Version: ESP 20 CAN V005
    Software Coding: 18448
    Work Shop Code: WSC 01236
    VCID: 3E0FAB56296F
    1 Fault Found:
    00285 - ABS Wheel Speed Sensor; Front Right (G45)
    35-00 - -

    I can't clear this error - I've checked the plug on the sensor and it all seems fine. New sensor needed?
    GSF have pattern sensors for about £17 or should I get a OE one?


    Any ideas on the second, unrelated, error would be appreciated ...

    VCDS-Lite Version: Release 1.2

    Friday, 03 May 2013, 15:39:02:5805
    Control Module Part Number: 8N0 906 018 J
    Component and/or Version: 1.8L R4/5VT G 0004
    Software Coding: 10710
    Work Shop Code: WSC 01236
    VCID: 3803BD4E0B4B
    Additional Info: ****
    1 Fault Found:
    16712 - Knock Sensor 1 (G61): Signal too High
    P0328 - 35-10 - - - Intermittent

    What does this mean? My googling hasn't really enlightened me. As far as I know the knock sensor hasn't been touched ... I don't even know where it is.


    Thanks, Liam






    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    [Dave B]'s Avatar
    Rrrrrrrr-tech

    Status
    Offline
    Join Date
    Jan 2003
    Location
    Manchester
    Posts
    1,987
    I had the first code (same corner) and replaced the sensor with an OE one, problem solved. Didn't consider a GSF one at the time.

    Can't help with the second one.
    > S3 225 (03) - OEM+
    > 205 GTI (90) - Limited Edition Miami Blue with full leather - 1 of only 300 made
    > Clio v6 255 (05) - Lethal Weapon

    View: My S3 diary

  4. #3
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Thanks Dave B.

    I just found Tuffty's previous thread on the knock sensor topic.

    VAGCOM - Knock Sensor problem

    Where do I find the knock sensor(s) so I can 'waggle' ? ...

    Cheers, Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  5. #4
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,753
    Check for a break in the loom somewhere?
    the knock sensor could have triggered when the esp kicked in , does that code clear and stay cleared?

    location... google says under the front manifold, will be a heavily shielded wire and bolted into the block.
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  6. #5
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    @udi A3 - thanks - good point. I did clear the code I'll check it out.

    I might go to GSF and get a cheapo ABS sensor and see how that goes.

    Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  7. #6
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,753
    Google Image Result for http://i8.photobucket.com/albums/a44/godsphantasma/3acdc8ab.jpg

    I think this will be a similar engine block. there are possibly 2 sensers, you could try swapping them over as tufty did to confirm the sensor itself is faulty assuming it doesnt go away.

    Of course, keep an eye on it, knock senser detects detonation and we wouldnt want any of that going on un detected!
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  8. #7
    6th Gear

    Status
    Offline
    Join Date
    May 2012
    Location
    RETFORD, NOTTS
    Posts
    1,753
    if you go to the thread that pic is from theres a lot more photos, including shiney engine porn lol
    '02 TDi 130 Sport: Mods to date: BXP 160 conversion, EGR delete, Decat, Helix SMF fast road clutch, 312mm front rotors, full DIS , CC, Xenons.
    VCDS fully registered and happy to help.
    *Need a Spare Key or Remote? SKC retrieval? Clock/ECU swap or milage correction? I am fully insured to work on your vehicle! Offering a good deal and quality service to ASN members Nationwide!*

  9. #8
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Thanks. mmmm engine pr0n.

    Looks simple - I'll check the codes again ... hopefully it will not have come back.

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  10. #9
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,594
    knock sensor 1 is located under the inlet manifold just to the right of the thermostat housing... I did indeed have this same issue and I re-wired the sensor back to the ECU... 2 core screened cable is required to do this...

    Sensor G61, pins on ECU below...



    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  11. #10
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Thanks for the info Tuffty.

    I have scanned again and the error has not re-occurred. Maybe it was a one off or as it says, an intermittent fault which will come back.

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  12. #11
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,594
    Quote Originally Posted by vfr800 View Post
    Thanks for the info Tuffty.

    I have scanned again and the error has not re-occurred. Maybe it was a one off or as it says, an intermittent fault which will come back.
    Mine was intermittent... it would happen randomly and the rewire made it go away and is still fine today...

    These kind of faults are like that...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  13. #12
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Thanks.

    I have one coil pack that keeps working its way out. Would a coil pack making a bid for freedom cause this?

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  14. #13
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Offline
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,594
    Quote Originally Posted by vfr800 View Post
    Thanks.

    I have one coil pack that keeps working its way out. Would a coil pack making a bid for freedom cause this?
    Very much doubt it (although stranger things have happened...)

    cut a small section of rubber out from the retaining ribs of the coil pack... reason they list is the air trapped as you push the pack in heats up and any oil etc on the rocker means the rubber bit of the pack can't grip and subsequently the pack rises up from the the expanding air... small slot in the rubber will let the air out (might be worth degreasing the coil pack holes too)

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  15. #14
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    Quote Originally Posted by <tuffty/> View Post
    Very much doubt it (although stranger things have happened...)

    cut a small section of rubber out from the retaining ribs of the coil pack... reason they list is the air trapped as you push the pack in heats up and any oil etc on the rocker means the rubber bit of the pack can't grip and subsequently the pack rises up from the the expanding air... small slot in the rubber will let the air out (might be worth degreasing the coil pack holes too)

    <tuffty/>
    That's a good idea to cut a vent in, I have degreased the holes and the coil pack several times, which slowed it down.

    Cheers, Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  16. #15
    vfr800's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Feb 2012
    Location
    Melting Beans
    Posts
    740
    So I picked up a cheapo £17 ABS sensor from GSF. I thought it would be simple to replace.

    I drove the car up on some ramps so I could get underneath and put plenty of penetrating spray on the old sensor.

    Undid the 5mm allen bolt holding it on, it took about 1 min of gentle coaxing with the screw driver and pliers in an attempt to free the old sensor to do this instead.





    Oooops! Doh! It snapped off. Now I had to lift the car up put it on axle stands and remove the wheel to get to the remains.

    Used a small chisel to slice off the remains of the old sensor poking out the other side.

    Once the copper coil was remove from the insides there was a cylinder of plastic left in the hub which took a while to hammer and pry out.

    Once it was out and the hole was cleaned it was simple to reassemble and put the new sensor in.

    Cleared all the fault codes and my dash no longer looks like a christmas tree. Happy days!

    I know it's a cheap sensor but it has a 1yr warranty so I'll see how it goes. Thank god it was a cheap fix.

    Liam

    S3 AMK 2002. Only 203 BHP left in my poor little engine, currently searching for the 7 missing horses.
    Mods: Powerflex bushes at the front and rear, 710P DV, ambient light module, Badger5 V3 TIP, S2000 Filter.

  17. #16
    Sandra's Avatar
    MODERATOR

    Status
    Offline
    Join Date
    Sep 2010
    Location
    Scotland
    Posts
    15,487
    Liam, sounds like a bad day. Why do these things always happen at the weekend or when there is nowhere open for you to get help? Its fixed now and your dashboard is back to normal, now you can just drive it again. x
    Audi-sport.net Lanyards & Stickers
    To find Audi-Sport-Net members with VCDS check out the MAP


 

 

Similar Threads

  1. Knock Sensors and Timing Pull
    By Alex C in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 14th November 2012, 19:19
  2. G61 and G66 Knock Sensors
    By Barks in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 10th July 2012, 20:40
  3. Replies: 24
    Last Post: 10th October 2010, 17:40
  4. ABS and ESP lights - Brake pressure sensor fault - Help!
    By wilkoa6 in forum A6/S6/Allroad forum (C5 Chassis)
    Replies: 3
    Last Post: 25th March 2010, 15:45
  5. MAF and knock sensor problems??
    By <tuffty/> in forum A3/S3 Forum (8L Chassis)
    Replies: 36
    Last Post: 6th December 2009, 12:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO