Sky InsuranceEM Tuning
Results 1 to 22 of 22
Like Tree5Likes
  • 1 Post By epox
  • 1 Post By Lemon S3
  • 1 Post By lloydie1
  • 1 Post By AudiS3-Turbo
  • 1 Post By AudiS3-Turbo

Thread: brake light issues

  1. #1
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    34

    brake light issues

    Hi all, simple problem, both brake lights are not working (except for the eye level brake light) I changed the bulbs in the clusters to no avail. Could it be the brake light switch if the eye level brake light is still working?

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    Neutral

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Killarney, Ireland
    Posts
    75
    It wont be the brake light switch, if the switch was gone you wouldn't have any brake lights at all. Are you getting voltage at the lights?

  4. #3
    epox's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Glasgow
    Posts
    561
    check the fuse just incase
    Tripp likes this.

  5. #4
    Lemon S3's Avatar
    Alex

    Status
    Offline
    Join Date
    Sep 2009
    Location
    Bicknacre, Essex
    Posts
    1,314
    Quote Originally Posted by epox View Post
    check the fuse just incase
    I hope that was the first thing he did.
    Tripp likes this.
    1999 APY S3 Imola Yellow

    PS3: Broady_11

  6. #5
    Neutral

    Status
    Offline
    Join Date
    Feb 2012
    Posts
    68
    Brake light switch. The switch has seperate outputs for the clusters and the eye level light so its quite possible the clusters dont work and the eye level one does, had this just a few months back. Get the latest revision (green bodied) switch from GSF but make sure you know how to fit it or you can break it upon installation !
    Tripp likes this.

  7. #6
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    34
    @LemonS3 - HA yeah I checked the fuse. all seemed in order. guess I will be ordering a new brake switch. thanks all

  8. #7
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    34
    ok slight dilemma on this - ive replaced the brake light switch, switched out the bulbs and checked the fuse (fuse 13 correct?) and still only the top brake light works....whats going on cos I don't know what it could be.

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    34
    bump for a little help

  10. #9
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Durham NE
    Posts
    578
    the brake light switch is working,the high level brake light and the lower cluster lights work together,the brake light switch has two functions,one for lights one for ecu.

    Have you any tow bars fitted? check your wiring to the lights,make sure the bulbs are correct two filament bulbs,its the same bulb the side lights are on.
    Tripp likes this.
    James
    Silver Audi 8L S3
    97 Fireblade fully restored ...just for summer!
    My old Corrado VR6 Turbo... Click me for the build DIY style!
    and many many cars and bikes in the past!!

  11. #10
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    34
    no tow bar and yeah the two filament bulbs are fitted. I suppose I will have to check the wires at this point. the bulbs work (one of the filaments anyway) so power is getting to the cluster and to the bulb, just seems to be no signal to turn on the braking light...odd

  12. #11
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Durham NE
    Posts
    578
    does the warning come on the dis? that brake light bulb is out?
    James
    Silver Audi 8L S3
    97 Fireblade fully restored ...just for summer!
    My old Corrado VR6 Turbo... Click me for the build DIY style!
    and many many cars and bikes in the past!!

  13. #12
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Durham NE
    Posts
    578
    by the way has your car esp?
    James
    Silver Audi 8L S3
    97 Fireblade fully restored ...just for summer!
    My old Corrado VR6 Turbo... Click me for the build DIY style!
    and many many cars and bikes in the past!!

  14. #13
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    34
    yes it has esp and no warning lights on the dash either for bulbs (or anything for that matter)

  15. #14
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Durham NE
    Posts
    578
    the brake switch is an two way as i said for esp cars,you should have had a warning on the dis display with no brake lights which suggests wiring issue to me.

    The red and black wire is the feed wire for high level,and both brake lights,have you checked if these have feeds when brake lights are applied?

    do all the othe cluster light work? even with the foot brake applied do they all work together?

    on,y thing i can think of is a bad or no earth to the rear light clusters..?
    James
    Silver Audi 8L S3
    97 Fireblade fully restored ...just for summer!
    My old Corrado VR6 Turbo... Click me for the build DIY style!
    and many many cars and bikes in the past!!

  16. #15
    epox's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Glasgow
    Posts
    561
    if you pull fuse 13 does the top bl still work?

  17. #16
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Durham NE
    Posts
    578
    fuse 13 (10amp) is the same feed for all rear brake lights.
    James
    Silver Audi 8L S3
    97 Fireblade fully restored ...just for summer!
    My old Corrado VR6 Turbo... Click me for the build DIY style!
    and many many cars and bikes in the past!!

  18. #17
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    34
    yes, I had both clusters out when changing the bulbs, everything on the clusters work except the brake brake lights. I will check the black and red wires when my OH gets back with the car. I cant imagine tho that its a wire fault at the clusters, seems odd to have a fault on both of them, should I be checking the wiring from the brake switch?

  19. #18
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Durham NE
    Posts
    578
    James
    Silver Audi 8L S3
    97 Fireblade fully restored ...just for summer!
    My old Corrado VR6 Turbo... Click me for the build DIY style!
    and many many cars and bikes in the past!!

  20. #19
    3rd Gear

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Durham NE
    Posts
    578
    one more possibility.... are the high level brakes lights led? as they dont need allot of current to work,have you had a multimeter on the brake light wires,can you check amps with it ?
    Wussell likes this.
    James
    Silver Audi 8L S3
    97 Fireblade fully restored ...just for summer!
    My old Corrado VR6 Turbo... Click me for the build DIY style!
    and many many cars and bikes in the past!!

  21. #20
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    34
    I assume the high level brake light has standard bulbs as ive not fitted any LEDs. when I check the wiring later I will get a multimeter to them to see if there is something amiss. thanks for the diagrams - much appreciated

  22. #21
    Neutral

    Status
    Offline
    Join Date
    Mar 2010
    Location
    Killarney, Ireland
    Posts
    75
    I know I've asked this already, but what's your voltage at the lights?

  23. #22
    Neutral

    Status
    Offline
    Join Date
    Aug 2012
    Posts
    34
    Quote Originally Posted by TwinCamMan View Post
    I know I've asked this already, but what's your voltage at the lights?
    I don't know. I will have to wait and get my hands on a multimeter over the next few days. will likely update then

 

 

Similar Threads

  1. Intermittent Brake Light issues - please help?
    By jaishaw in forum A4/S4 forum(B5 Chassis)
    Replies: 5
    Last Post: 16th May 2012, 09:41
  2. Brake light issue
    By kev1000 in forum General Technical / How To
    Replies: 3
    Last Post: 19th February 2012, 05:31
  3. ...Help, electrical / brake lights issue nightmare!
    By Maz in forum A3/S3 Forum (8L Chassis)
    Replies: 3
    Last Post: 18th October 2011, 21:20
  4. brake lights issue
    By dares_uk in forum A3/S3 Forum (8L Chassis)
    Replies: 4
    Last Post: 14th April 2009, 15:23
  5. No brake lights (Switch issue)
    By A3_Turbo in forum A3/S3 Forum (8L Chassis)
    Replies: 6
    Last Post: 18th February 2008, 13:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO