Volks AutosSky Insurance
Results 1 to 13 of 13
  1. #1
    paul_brad's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Leicester
    Posts
    365

    speedo stopped working!

    Hi guys,
    my dads been playing with my reverse light switch under the bonnet, as it hasnt worked for sometime... Hes taken the switch off altogether to get a new one from the scrapyard - now my speedo doesnt work. Is this a fluke? we dont know much about this - is the reverse switch related to the speedo in anyway? help on this, this afternoon would be much appreciated, as he has it at his house at the minute, but I'll be driving back to Leicester tonight (from Doncaster)

    cheers!

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    necroeire's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2004
    Location
    Ireland
    Posts
    1,003

    Re: speedo stopped working!

    My speedo failed last year and I had to change out the dials. Seemed there was a fault somewhere on the back of the dials.

  4. #3
    paul_brad's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Leicester
    Posts
    365

    Re: speedo stopped working!

    Thanks necro, sounds expensive! do you know how much this cost roughly?
    Another ailment of the same fixing reverse light session was my Oil Sensor light keeps beeping at me on the dashboard - both were working fine previous to the bonnet being lifted!

    (my dad has the car all week anyway, and im driving his A4)

  5. #4
    imported_Jamesh
    Guest

    Re: speedo stopped working!

    I known this sound alittle too simple, but the reverse switch and the speedo are both located on the gearbox and both look very similar from the top, have you taken the right piece out. The speedeo transducer will have a set of gears on the bottom. If you have taken the the reverse light switch out correctly have you disturbed the speedo plug in the process.

  6. #5
    paul_brad's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Leicester
    Posts
    365

    Re: speedo stopped working!

    Ill pass that on to my dad!
    I think he's in the process of picking up a Haynes manual too. I dont suppose this Oil Sensor thing can handily be tied in with all this?

  7. #6
    necroeire's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2004
    Location
    Ireland
    Posts
    1,003

    Re: speedo stopped working!

    If it's the dials then the speedo, rev counter and temperature go to zero. Mine was replaced under warranty and it has happened to a few others on here too.

    Hope it's within warranty mate as I'm sure very expensive. I have seen some on ebay though.

  8. #7
    paul_brad's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Leicester
    Posts
    365

    Re: speedo stopped working!

    Its only the speedo - the revs are def. still working (i think im breathing a sigh of relief there then, it sounds like!)

    Its a W reg 1.8T by the way, should that matter to anyone (and no, not under warranty!)

  9. #8
    Khufu's Avatar
    6th Gear

    Status
    Offline
    Join Date
    Jan 2003
    Location
    West coast of Scotland
    Posts
    5,693

    Re: speedo stopped working!

    does it have aircon? You can read the speed off of the display in Kmh. That would eliminate the speed sensor if it still gives a reading.

  10. #9
    paul_brad's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Leicester
    Posts
    365

    Re: speedo stopped working!

    aah yes, it does have aircon - do you know what the key presses are to bring it up?

  11. #10
    imported_Nigma
    Guest

    Re: speedo stopped working!

    Definatly the speed tranducer by the sounds of it.

  12. #11
    paul_brad's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Leicester
    Posts
    365

    Re: speedo stopped working!

    Whats the speed tranducer Anand?

  13. #12
    paul_brad's Avatar
    2nd Gear

    Status
    Offline
    Join Date
    Apr 2004
    Location
    Leicester
    Posts
    365

    Re: speedo stopped working!

    Gentlemen, thanks for your help - i really appreciate it trying to help me.
    Just received an email from my dad:

    Seem to have got everything working Ok now
    Reverse lights working ok with new switch
    Oil pressure sensor ok but not sure why
    Speedo ok same fuse as reverse lights had blown


    PHEW!

  14. #13
    necroeire's Avatar
    5th Gear

    Status
    Offline
    Join Date
    Feb 2004
    Location
    Ireland
    Posts
    1,003

    Re: speedo stopped working!

    Well thats good to know mate. Cool.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO