AH FabricationsSky Insurance
Results 1 to 23 of 23
Like Tree1Likes
  • 1 Post By bez101

Thread: Oil Warning 3 Beeps but oil level high

  1. #1
    Spatula's Avatar
    !.8T AGU

    Status
    Offline
    Join Date
    Jan 2013
    Location
    North West
    Posts
    191

    Oil Warning 3 Beeps but oil level high

    Hi again,

    So last night I changed t/stat. Engine reaches temp perfectly now. I took it for a drive after and whilst climbing a fairly laborious hill, the oil warning flashed in centre with 3 bleeps.

    It did it about every 4 or 5 minutes from then until I got home (approx 20 mins after). This morning I checked the dip stick and the oil level seems to be above max. I had driven a 10 minute drive to work and since then it's been left 2 hours before I checked. Maybe the oil is still warm and expanded. I will check again at dinner, but I have a feeling the warning wasn't low oil..

    Any ideas?

    Spat

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    jojo's Avatar
    S3 Drift King!

    Status
    Online
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,531
    1.8T I presume? The beeps is an oil pressure warning, I'd stop driving it until it's sorted. What's the mileage on the car? May I suggest you replace the oil pick up, it's a common problem.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  4. #3
    Spatula's Avatar
    !.8T AGU

    Status
    Offline
    Join Date
    Jan 2013
    Location
    North West
    Posts
    191
    Yep it's a 1.8t, agu (1998). Erm, the miles are rather high... 188k.
    How does one go about replacing the oil pick up? Parts / instructions etc?

    Thanks

  5. #4
    jojo's Avatar
    S3 Drift King!

    Status
    Online
    Join Date
    Sep 2003
    Location
    Solihull, Midlands
    Posts
    25,531
    The search is your friend.

    http://www.audi-sport.net/vb/search....archid=2679272

    I'm sure there more than one thread with a 'how to' in the link above.



    99' Audi S3(APY) - Brilliant Black Click>>>Going Sideways vid!
    You've got to have a laugh! For Sale:LCR Brakes - £400



  6. #5
    Spatula's Avatar
    !.8T AGU

    Status
    Offline
    Join Date
    Jan 2013
    Location
    North West
    Posts
    191
    Ok so I found a lot of scary things that this issue can cause. I have taken immediate action and called my local Audi. They have ordered me some parts that will arrive tomorrow. (Oil Pickup pipe, Dip stick housing and oil filter) altogether comes to about £24.00 inc vat., which I don't think is too bad.

    I will start tomorrow, removing the sump, cleaning it etc then replacing the Oil pickup. Is there anything I should look out for? I've seen some nice instructions however that was for a 2000 S3. Will mine virtually be the same in this respect?

    Also, what kind of damage will it have done me driving it if the engine is being starved of oil? I hope I havent f'd it

  7. #6
    Prawn's Avatar
    My other car is a MINI!!!!

    Status
    Online
    Join Date
    Dec 2006
    Location
    Basingstoke
    Posts
    9,370
    s3 will be identical to yours on the sump mate.

    I'd start by dropping the sump and checking the pickup, but it's entirely possible it could be the oil pump that's not pumping enough.

    Hopefully just the pick up, start with that and see what happens.

    how long have you driven it with the oil light on?

    The AGU doesn't have an oil level low sensor, so the warning you see is definitely pressure, which is very serious. If you carried on driving for 20 mins with the low pressure light on there's every chance it could be knackered, so be prepared for the worst, but conversely, I've done the same before on a car I didn't care less about, and after an oil change it ran fine and didn't knock at all.
    -------------------------------------------------------------------------------------------------

    Prawns TFSI Turbo'd 1.8T Track Car

    But I know nothing so ignore me.

  8. #7
    1st Gear

    Status
    Offline
    Join Date
    May 2010
    Posts
    139
    Following the guide, it's pretty obvious mate I'm sure your be fine.

    Hopefully very little to no damage has been done, did It sound okay yesterday after your drive?

  9. #8
    danger S3's Avatar
    2nd Gear

    Status
    Online
    Join Date
    Jun 2010
    Location
    Edinburgh, Scotland
    Posts
    355
    there's a couple of links in my signature that might help

  10. #9
    Spatula's Avatar
    !.8T AGU

    Status
    Offline
    Join Date
    Jan 2013
    Location
    North West
    Posts
    191
    The only strange sound was a high pitch clicking coming from the heads? I'm not sure if this is anything to do with it, as I noticed this before the warning light even started beeping, i.e, when I had the bonnet up after I'd finished changing the t/stat. I didn't really think anything of it as I assumed it was normal. However looking at this it sounds this could have been caused by low oil pressure.

    This is my first A3, so please bare with me as I'll probably be asking many stupid questions etc for awhile. :-)

    With regards to the clicking, will this be sorted when the flow is clean and oil is circulating correctly, or is this damage that will need serious money throwing at it to repair?

    Spat

  11. #10
    Spatula's Avatar
    !.8T AGU

    Status
    Offline
    Join Date
    Jan 2013
    Location
    North West
    Posts
    191
    Quote Originally Posted by danger S3 View Post
    there's a couple of links in my signature that might help
    Brilliant, this sump removal was the one I found great guide!

    @Prawn - I drove maybe 5 miles? it came on then went off about 4 times. About 4 or 5 minute intervals. I nursed it home.
    There doesn't seem to feel like there has been any change. All feels normal. Just the ticking..

  12. #11
    1st Gear

    Status
    Offline
    Join Date
    May 2010
    Posts
    139
    The 1.8t is a 'clicky/tappy' engine compared to some, so it's hard to rely on that alone for diagnosis.

    A friends oil light flashed up at 80 on the motorway and he's drove like it for an hour, pulled up and it sounded awful. Pick up change and it's back to normal although of course there will be some internal damage.

  13. #12
    Spatula's Avatar
    !.8T AGU

    Status
    Offline
    Join Date
    Jan 2013
    Location
    North West
    Posts
    191
    It's not that it sounds awful. The ticking can only be heard when bonnet is lifted.
    The car has done a fair few miles though and I have no idea when it was last serviced with oil change etc. So that's this weekends job, obviously, if removing the sump

    I have read a HUGE thread regarding oil to put in and whether or not to flush the oil, as far as I can make out, the best stuff to go for is named brand 10w/40? and not to flush incase of moving clumps and them just blocking up little hoses etc.?

    I trust this stands true with my situation?

    Spat

  14. #13
    Prawn's Avatar
    My other car is a MINI!!!!

    Status
    Online
    Join Date
    Dec 2006
    Location
    Basingstoke
    Posts
    9,370
    ticking from the head is most likely dry tappets due to not getting enough oil.

    Drop sump, change pickup, run it up to temp and see what happens mate.

    Also worth noting this issue will only show up when driving, as the ecu stupidly doesn't show the oil pressure light until over 2k rpm or something like that!
    -------------------------------------------------------------------------------------------------

    Prawns TFSI Turbo'd 1.8T Track Car

    But I know nothing so ignore me.

  15. #14
    Spatula's Avatar
    !.8T AGU

    Status
    Offline
    Join Date
    Jan 2013
    Location
    North West
    Posts
    191
    Ok cool. Well I'll start removing the sump and things tonight, Audi say the parts will be in tomorrow morning so I'll go down there and get the parts. Oh, what's the stuff I use to seal the sump up with? Does it have to be a particular one?

  16. #15
    danger S3's Avatar
    2nd Gear

    Status
    Online
    Join Date
    Jun 2010
    Location
    Edinburgh, Scotland
    Posts
    355
    yeah just use the genuine VAG sump sealant, can't remember the part number but the dealer will have it

  17. #16
    1st Gear

    Status
    Offline
    Join Date
    May 2010
    Posts
    139
    Use Dirko sealant, elring number 030.790

    I use fuchs 10/40w as its around £20 for 5 liters and is perfect for this engine.

  18. #17
    Spatula's Avatar
    !.8T AGU

    Status
    Offline
    Join Date
    Jan 2013
    Location
    North West
    Posts
    191
    Ok brilliant I'll order that stuff up from my L/D. Is there any particular good stuff to clean the oil etc. from the sump? I have a feeling it's going to be preeeeeeeetty messy.

  19. #18
    danger S3's Avatar
    2nd Gear

    Status
    Online
    Join Date
    Jun 2010
    Location
    Edinburgh, Scotland
    Posts
    355
    i use Auto Express Best Buy | Surfex HD Best Pressure Washer Shampoo for cleaning the oil, water based and works really well, i found it better than gunk

  20. #19
    Spatula's Avatar
    !.8T AGU

    Status
    Offline
    Join Date
    Jan 2013
    Location
    North West
    Posts
    191
    Quote Originally Posted by danger S3 View Post
    i use Auto Express Best Buy | Surfex HD Best Pressure Washer Shampoo for cleaning the oil, water based and works really well, i found it better than gunk
    thanks! I'm looking forwards to cleaning that bad boy out... New oil and things should make it run a lot better too, I hope.

    I'll keep you updated as to how I get on.

  21. #20
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    10
    BUMP!!

    So how did ya get on with it, clogged or not?

    I've got the beeps of doom on mine and i've just swapped the engine out and had it all to bits and cleaned and it starts beepin intermittant around 2k, the pump seemed ok when sump was off and i could see the lift pipe wasnt clogged, any ideas? also i just replaced the oil pressure switch for genuine

  22. #21
    bez101's Avatar
    Yorkshire & Humber Rep.

    Status
    Offline
    Join Date
    Jul 2008
    Posts
    8,492
    pump
    it may look ok but you cant tell by looking.
    Tim_Attard likes this.

  23. #22
    2nd Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Kent
    Posts
    459

    My Social Networking

    Add Tim_Attard on Facebook
    id vote pump, mine has gone too especially if its intermittant

    http://www.audi-sport.net/vb/a3-s3-forum-8l-chassis/187166-tims-max-power-a3.html


    Quote Originally Posted by 16Klappe View Post
    Don't listen to him Tim, You're my hero, I'm proud of you.

  24. #23
    Reverse Gear

    Status
    Offline
    Join Date
    Mar 2013
    Posts
    10
    pumpis now my last option or elec issue, just cleaned the **** out of the lift pipe and still same prob

 

 

Similar Threads

  1. Red Oil Warning Light Beeping ?
    By AudiJohn in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 7
    Last Post: 15th January 2012, 14:36
  2. warning beep but no picture on lcd
    By zeeeebo in forum A3/S3 Forum (8L Chassis)
    Replies: 16
    Last Post: 31st July 2010, 00:44
  3. Oil level low warning light - what oil to buy, on xmas day?
    By drewbee in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 2
    Last Post: 25th December 2009, 11:32
  4. OIL WARNING LIGHT BUT PLENTY IN????
    By veccyj in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 6
    Last Post: 8th December 2007, 12:07
  5. Oil warning light Min
    By imported_ashs3 in forum A3/S3 Forum (8L Chassis)
    Replies: 7
    Last Post: 11th February 2005, 20:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO