Sky InsuranceChris Nott
Results 1 to 26 of 26
  1. #1
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751

    Not idling properly/fluctuating idle

    I'm putting it down to the cold and not running the car for 3 days, and it's been minus temperatures and snowing here. I started it up tonight and it wouldn't fast idle so I had to keep my foot on the throttle for a minute or so. Then, once it 'caught' idle it fluctuated a little bit, just a few rpms +/-10 or so. With my old Honda we used to call it hunting or an air bubble in the coolant system.

    I've noticed it's thrown some more coolant (not much but enough to notice) out so I'll top that up a little in the morning. No overheating though and it runs fine after 3-5 minutes (even before it hits 90C). I did give it a little boot coming onto an A road from 30mph to 70mph and it didn't seem as pokey as the last time I drove it.

    Took it for a 10 mile drive and it was fine but the lumpy-ish idle is a concern. Is it just the coolant and a slight air lock? I'll run it with the coolant cap off for a few minutes to see if that releases any air.

    Need to drive to Scotland tomorrow so I'm just checking with you guys first.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  2. # ADS
    ADS
    Join Date
    Always
    Location
    Global
    Posts
    Many
     
  3. #2
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    Coolant wont have anything to do with it running lumpy, check the usual culprits... Vac pipes

  4. #3
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Cheers buddy. I checked this morning (scanned no codes found) for vac leaks but the previous owner replaced them all just a few months ago (£300's worth!). It started perfectly this morning even though it's even colder than it was last night. I ran it with the coolant cap off for a few minutes and topped it up (only about 50-100mls) and there was no lumpiness at idle anymore.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  5. #4
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,611
    Hummm... reminds me of my Mk2 Golf... used to have a misfire/lumpy idle on cold start that went after a short while as the engine warmed up... turned out to be the head gasket and coolant was getting into cyl 1

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  6. #5
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Quote Originally Posted by <tuffty/> View Post
    Hummm... reminds me of my Mk2 Golf... used to have a misfire/lumpy idle on cold start that went after a short while as the engine warmed up... turned out to be the head gasket and coolant was getting into cyl 1

    <tuffty/>
    Ah man, don't say scary stuff like that. It's not a huge fluctuation at idle it just made me wonder about it, and maybe I didn't need to fill up the coolant but it looked a little low but only by a gnat's bollock. Like I said it started up perfectly this morning and I hadn't driven it for a few days - and it's been hella cold. I live near on the coast so we get a icy wind from the sea.

    I'll keep a close eye on it though. Can anything be done if it is the starting's of the HG going? I'll do a compression test soon. I look after it pretty well just had a full service by me and my VAG nut, S3 owning mechanic friend. Never drive it above 2.5k rpm until it's at 90C and don't commute in it, it's usually 10 mins of town driving and the rest A-roads each trip - or today a 150 mile blat to Scotland. I've done 250 miles in the last 15 days to give you an idea so it's been laid up for days at a time.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  7. #6
    s3dave's Avatar
    TFSI Hybrid

    Status
    Offline
    Join Date
    Nov 2009
    Location
    west yorks
    Posts
    10,121
    Head Gaskets dont seem to be an issue on these, more cracked heads (AMK) Like you said just keep your eye on it...

  8. #7
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,611
    Maybe see about getting a hydrocarbons test on the coolant....

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  9. #8
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Will do Tufty. I'm putting it in for it's MOT early as the pre-check only flagged up ARB bushes and an axle bush, but I'll get him to do that check too. Thanks for pointing it out, appreciated
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  10. #9
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Managed to catch the 'intermittent' code after a 20 minute run out today. Mix of roads, not booting it at all but then came to some lights and it started 'hunting' and revs fluctuating a little bit more than before so much so that I had to give it some throttle.

    Got these codes:
    17608 BOOST PRESSURE CONTROL VALVE N249 MECHANICAL MALFUNCTION (P1200 - 35- 10- INTERMITTENT


    17705 N249

    N249 Bypass How To (2000 S3 - but same for many)

    And after reading up it seems that a bypass would be best. I'll do this (I was gonna do it anyway) and see if it cures it. It's weird how after a blat up to Scotland and back it was totally fine but at slow speeds it's been cack. I assume I've done something to cause it when fitting the TIP - the woes of doing stuff in poor light and in the freezing cold I suppose. I'll spanner check everything on the TIP as well. I did have to block one of the openings as mine is a AUM so I used a bolt with a spacer and cranked a jubilee round it...might have popped out although it fit perfectly tight, will try and make time for it tomorrow.

    S3Dave, you were right
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  11. #10
    RIP S3dave

    Status
    Online
    Join Date
    May 2004
    Location
    nr Glos
    Posts
    7,196
    got a leak under the inlet mani?
    or sticking DV?
    **http://www.facebook.com/Badger5Ltd**

    NEW NEW NEW eShop now LIVE>
    www.badger5.biz

    Badger 5 Ltd, Queen Annes Gate, Oldends Lane, Stonehouse, Glos, GL10 2DG


    http://www.badger5.co.uk, Tel:01453822880
    bill@badger5.co.uk
    **NEW** Badger5 Section CLICK here>> http://www.audi-sport.net/vb/213-badger-5/

  12. #11
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Quote Originally Posted by badger5 View Post
    got a leak under the inlet mani?
    or sticking DV?
    Hi Bill, I'll have to check in the morning it's just about to get dark now and it's raining. I need to get some vac hose and a tee piece. I'm hoping it's not the DV it's brand new - although I still haven't lapped the piston in as you and others recommended...I know you're going to say get an OEM DV
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  13. #12
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Did the N249 bypass today and the idle is rock steady and feels smoother.

    Happy. Thanks ASN again
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  14. #13
    RIP S3dave

    Status
    Online
    Join Date
    May 2004
    Location
    nr Glos
    Posts
    7,196
    Quote Originally Posted by JudderMan View Post
    Hi Bill, I'll have to check in the morning it's just about to get dark now and it's raining. I need to get some vac hose and a tee piece. I'm hoping it's not the DV it's brand new - although I still haven't lapped the piston in as you and others recommended...I know you're going to say get an OEM DV
    I checked 3 DVs today... 2 after market, one OEM......... Guess which one did'nt leak and blow bubbles...
    **http://www.facebook.com/Badger5Ltd**

    NEW NEW NEW eShop now LIVE>
    www.badger5.biz

    Badger 5 Ltd, Queen Annes Gate, Oldends Lane, Stonehouse, Glos, GL10 2DG


    http://www.badger5.co.uk, Tel:01453822880
    bill@badger5.co.uk
    **NEW** Badger5 Section CLICK here>> http://www.audi-sport.net/vb/213-badger-5/

  15. #14
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Quote Originally Posted by badger5 View Post
    I checked 3 DVs today... 2 after market, one OEM......... Guess which one did'nt leak and blow bubbles...
    I know, I know, I know. I should have read that thread before I bought my 007 Too late. I might change it in the future as people always want bargain 007p's.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  16. #15
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Guess what, fluctuating idle again and flutter. ****ing DV - excuse my French. Complained to Forge and asked for a servicing kit for free. The guy that replied wasn't aware of the problem, sent a bigger email explaining leak tests etc and will see what they come back with tomorrow.

    I don't want to stick it on eBay out of principle and I'll lose money on it, only bought the bugger at the end of December. At £111, almost three-times as much as the OEM, you're right Bill it should be **** hot and never leak and be three-times better than OEM.

    Gonna order an OEM after I hear back from Frauge and sell it on eBay with the kit installed. Not a happy customer.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  17. #16
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Got my Forge service kit through today, free of charge as I explained that a £111 product should actually work from the off. Will fit it tonight and see what it's like or sell it and get an OEM.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  18. #17
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    I think I've got a leaking radiator as the steam is getting worse. It's not overheating and the pipes look in decent nick, and the steam is coming out the nearside part of the grill at the top near the bonnet. If I squeeze the top hose more steam comes out. It's really light steam but even still the coolant remains almost at the same level. I added about 20-30ml today, just a tiny splash. It's getting MOT'd on Tuesday so I'll get a leak test or whatever can be done. It only happens when I'm driving slow <20mph and then stop ie. at traffic lights.

    Got a frigging vacuum leak as well from the N249 bypass I did. The hose I bought isn't strong enough and has collapsed and others have warped so they aren't tight on the nipples (oi oi ) any more. Bought some fuel hose and that seems to be much better but need to buy more as I could only get 1m. I'm guessing that there was a a problem with the N249 but now I've added crap hoses that it's continued the problem and had misfires on cylinder 1,2 and 3. New hoses have stopped that and the idle is much better now.

    After whinging to Forge earlier in the week I got my new piston through and fitted it today, and what a difference it makes!! I guess the new pipe going to the DV helps as well but now there's no flutter. The piston is quite a bit different to the old one, with an extra rubber seal and different end of the piston.

    Wish these niggles would stop cropping up though as I'm itching to make it go faster but not until I've sorted the problems - one of the rear calipers has started sticking now!!! I'm assuming if it's not a radiator pipe that it's new radiator core time? Grrrr if so as I don't want to shell out for an FMIC yet as that would be easier to fit the two at the same time I assume.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  19. #18
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Update: Been in for an MOT this morning and my mate that runs the garage said that he reckons the head gasket is on it's way. Said it's burning water....What do you guys reckon? He's a family friend and isn't out to rip me off and I'll be doing the HG not him so he's not making a bunch of cash from me. I still reckon once I sort the vacuum leak out and replace the radiator that's lets a little steam out (not much, doesn't overheat, doesn't need much more than 20ml coolant every few weeks) that it would be OK.

    What's the deal with replacing the HG? Skim the head or see what condition it's in when I take it off. Anything else I should replace while I do it? What are the prices of the HG and any other parts that you'd normally change. Or do you reckon it would be easier/cheaper for him to do it as I'm not a mechanic but like to do stuff myself where I can. As you can see by my sig I'm used to old cars and having my head under them.

    Edit: Just had a look in the Haynes and it looks fairly straightforward - doesn't it always...but ends up being hours and hours more work - so I might give it a whirl. Might as well add my DP and decat at the same time and do a cambelt/waterpump change. I can kinda see why my car was fairly cheap, after all of this I would have spent more than I paid for it. If it didn't have such sexy Recaros I'd not love it as much
    Last edited by JudderMan; 12th February 2013 at 13:51.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  20. #19
    S3quatt's Avatar
    Flat Oot like a ducks Foot

    Status
    Offline
    Join Date
    Jan 2007
    Location
    Sunny Scotland
    Posts
    595
    Head gasket not a big deal if you do a bit of spannering.
    Just make sure you get the timing set up properly afterwards when you put it back together. (Or a locking kit)

    Obviously you will likely get a bit of water oil mix, so give it a quick run afterwards & an oil change after that.

    If it all sounds too expensive & complicated, chuck in some rad weld & carry on...

    Would you believe a mate of mine has run his 2.0tdi like that for over a year?

    I think he's in for a shock at some point...
    ...... Now this one's MUCH better!...

  21. #20
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Cool cheers. I've got a feeling it's not the HG. Just drove it back and it's fine. I didn't realise but his place doesn't do MOTs he passes it on up the road but I didn't want anyone else working on it. Thing is, they road test it and judging by the fact my DIS says 30mpg and not 35mpg like it did this morning they've been ragging it around and then told him there was steam coming out the radiator....and you wonder why I usually work on my car myself!!! Knobheads. It wasn't my mate as the other garage is 1 mile away but there's 8 miles been added to the clock.

    I'm gonna get a new radiator and fit it and see if that cures the steam which it should. The vac leaks are all sorted now with new reinforced pipes. I'll double check for any codes tomorrow but my mate wiped them so I guess they would have come back. It's passed it's MOT which is cool. Needs rear calipers though as one is sticking, not an advisory but you can tell and my mate agreed.

    I'm just not sure what to do if it is the HG do I wait until it goes or 'guess' that it definitely is the HG and replace? - I'm assuming it won't steam (it's not much that comes out and passes after 20 seconds) after I fit the new rad.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  22. #21
    S3_Olly's Avatar
    Full Throttle

    Status
    Offline
    Join Date
    Jul 2011
    Location
    Aston, Sheffield
    Posts
    156
    Dave how would you tell if you had a crack in the head as I have an amk and rough idling and just noticed I have loads of oil running down the side of the block?
    Ill scan with vcds and see what comes up but just concerned since you mentioned a cracked head?
    Olly

  23. #22
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,611
    Hydrocarbon test, pressure test etc on the coolant system is a good start... cracked heads seems quite popular on AMK's for some reason...

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  24. #23
    S3_Olly's Avatar
    Full Throttle

    Status
    Offline
    Join Date
    Jul 2011
    Location
    Aston, Sheffield
    Posts
    156
    Where would the crack usually appear and are new heads expensive lol seems like all I do is come on here with problems at the minute. Lok
    Olly

  25. #24
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Just updating this in case it helps anyone (the original topic )

    Haven't had a chance to replace the radiator but hopefully I will do in the morning. I got a hydrocarbons test on the coolant and the guys at the garage said the MOT place and my mate were wrong, it's not the head gasket at all. They said it's the radiator and to get it replaced asap. I bought a new coolant reservoir as well in case that's got a leak as I want to have a spare anyway.

    So, not completely conclusive but I still get a crap idle when I come to traffic lights/a stop. It stutters gently at idle but not when doing say a constant 50mph. I imagine this is still a vac leak, despite all of the pipes being replaced with decent reinforced jobbies for the N249 bypass as the ones I used were collapsing when hot. I'm still not sure what/where the vac leak could be. Can the N249 still cause problems even though it's bypassed? Ie. cause a random mis-fire (according to VCDS Lite). I've got it plugged in still but no pipes going to it as per the bypass instructions. It wouldn't be the Forge 007 would it? I've fit the new piston/service kit and it seemed better. What's next? Can you leak test intake/TIP etc? Would the spark plugs cause a dodgy idle and the symptoms? Plugs have been replaced by me and coil packs were a couple of months before I bought it (September 2012 ish)

    I'll report back tomorrow night after I swap the rad and have had a test drive. Grrr, need this sorted so I can up the power.

    (Passed its MOT on Tuesday too)
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  26. #25
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    Replaced radiator, all sorted now. Idles fine. Still need to burp the system a little as it won't get up to 90C. The radiator has really fine fins and looks so much better than the original even though it was £26 (eBay). It will probably get damaged more easily due to how thin the vanes are.

    Had a lot of help from my S3-owning neighbour to swap it over which was awesome as I would still be there doing it now if I was by myself.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

  27. #26
    JudderMan's Avatar
    4th Gear

    Status
    Offline
    Join Date
    Nov 2012
    Location
    Newcastle Upon Tyne
    Posts
    751
    The fluctuating idle has returned albeit very slightly. No codes, no misfires. As above, no hydrocarbons in the coolant. New radiator. How can I test for vac leaks? Even though nearly all the vac pipes to the inlet etc are brand new.

    Also, I cannot seem to burp the coolant/radiator. After driving for 20 mins and a few good blasts then returning to a stop with the heaters on full belt and the coolant cap off. The fans kick in after a while (too long probably), and it bubbles up when you rev it at idle (to 2-3k rpm). The heaters aren't getting hot unless it's being revved and when driving normally it drops to 70 sometimes 60c. Stays at 90c at idle and stop start traffic. Do I need a new thermostat? Surely because of the new radiator it's just got an airlock or would the new rad show up the stat being broken even more?

    I haven't been using the car much in the last two weeks apart from trying to burp it. MPG is still 35-36 and the rad upper and lower pipes get hot after a run.
    2000 Audi A3 1.8T Sport AUM K03S|Second owner|Forge 007p|CM TIP|Yellow Dogbone|Pipercross panel|Stage1Map
    WANTED: Audi A4 B7 or MK5 5Dr Golf GTi (manual)(Want to Buy December 2014 so Keep Me in Mind)

 

 

Similar Threads

  1. A4 1.8T -Idle speed fluctuating and Camshaft Position Sensor fault!
    By AudiStew in forum A4/A4 cabriolet/S4 forum(B6 chassis)
    Replies: 15
    Last Post: 12th September 2010, 19:30
  2. Replies: 1
    Last Post: 27th November 2005, 09:39
  3. HELP - Fuel Meter on DIS not functioning Properly
    By fraz in forum TT/TT-S/TT-RS Forum
    Replies: 1
    Last Post: 25th November 2005, 23:17
  4. Latest threads not working properly
    By imported_Yaseen in forum Site Support & Announcements
    Replies: 4
    Last Post: 20th February 2005, 22:50
  5. pc sound not working properly? Help
    By Dumpvalve1 in forum General Chat
    Replies: 1
    Last Post: 27th September 2004, 22:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO