EM TuningVolks Autos
Results 1 to 16 of 16
  1. #1
    burns3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2011
    Posts
    223

    how to take central locking pump apart?

    As the title says i have taken my central locking pump out of the car today as this may be the reason why my keyfob has stopped working but other than removing the bottom of it to get to the circuit board how to you get too the graphite part to see if its knackered?

    Have tried the search but nothing with pics or much of description of how to get it apart just how to get it out the boot.

    Any ideas will be good people as entering through the boot aint the classiest entrance

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    burns3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2011
    Posts
    223
    this is the one i'm on about, out of a 2000 s3central locking pump.jpg

  4. #3
    epox's Avatar
    3rd Gear

    Status
    Offline
    Join Date
    Oct 2012
    Location
    Glasgow
    Posts
    561
    not sure about the pump. when u use the remote does any thing happen? if nothing is workimg i would think its the remote or programming. if the indicators flash as if arming the alarm, then may be the pump???

    mark

  5. #4
    Moderator

    Status
    Offline
    Join Date
    Jun 2003
    Location
    World of my own
    Posts
    9,813
    You can get a replacement on ebay for £30 so is it really worth faffing about with the one you have?
    "How to tear apart the ties that bind, perhaps fcuk off might be too kind"
    Alex Turner

  6. #5
    burns3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2011
    Posts
    223
    Quote Originally Posted by epox View Post
    not sure about the pump. when u use the remote does any thing happen? if nothing is workimg i would think its the remote or programming. if the indicators flash as if arming the alarm, then may be the pump???

    mark
    nothing happens with remote at all (but batteries and fob has been checked to be sending a signal) but there was a noise coming from the boot and i thought that may have been the pump. I may be wrong but either way i'm gonna get the car looked at tomorrow and see what the crack is.

  7. #6
    burns3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2011
    Posts
    223
    Quote Originally Posted by AndyMac View Post
    You can get a replacement on ebay for £30 so is it really worth faffing about with the one you have?
    i thought you had to recode it or something if you bought a new one is the only reason i was thinking about fixing it really but i may need my key re doing so will find out more tomorrow what i need to do anyway cos all i aint got a clue.

  8. #7
    Moderator

    Status
    Offline
    Join Date
    Jun 2003
    Location
    World of my own
    Posts
    9,813
    Do the windows go down if you hold in the unlock button?
    "How to tear apart the ties that bind, perhaps fcuk off might be too kind"
    Alex Turner

  9. #8
    Neutral

    Status
    Offline
    Join Date
    Dec 2011
    Location
    Basingstoke
    Posts
    84
    I bought another one and swapped the pcb over to avoid recoding keys.... easy enough if you have basic soldering skills

  10. #9
    burns3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2011
    Posts
    223
    Quote Originally Posted by AndyMac View Post
    Do the windows go down if you hold in the unlock button?
    Funny you should say that as my windows stopped working after i took the pump out but sure they were working before hand (havent used the car in over a month though).

    Does the pump control the windows too cos i may have to try plugging it back in to check using the lock button.

  11. #10
    burns3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2011
    Posts
    223
    Quote Originally Posted by George The Diesel Head View Post
    I bought another one and swapped the pcb over to avoid recoding keys.... easy enough if you have basic soldering skills
    I dont have a soldering kit but if its easy enough could get hold of one but i will see what the easiest solution is really.

    Did you take the circuit board off the bottom of the unit and go in that way too fix it cos i cant see any other way too get into it?

  12. #11
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,472
    Quote Originally Posted by burns3 View Post
    Funny you should say that as my windows stopped working after i took the pump out but sure they were working before hand (havent used the car in over a month though).

    Does the pump control the windows too cos i may have to try plugging it back in to check using the lock button.
    Windows issue will most likely be the plastic clips that hold them in the guides... common problem... and no... the pump is not connected to the windows

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  13. #12
    burns3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2011
    Posts
    223
    Quote Originally Posted by <tuffty/> View Post
    Windows issue will most likely be the plastic clips that hold them in the guides... common problem... and no... the pump is not connected to the windows

    <tuffty/>
    I presumed you were correct about the windows tuffty cos your normally right about most things but on this occasion you have let me down and just after i was bigging you up to the bloke in the garage too lol.

    Anyway we plugged it back in to hear the noise and he thinks the pump is knackered too cos when i press the door lock switch the pump makes a right racket for about 20sec, anyhow i tried the windows just for the hell of it and they worked once the pump was plugged back in too so atleast i have just the original problem to sort lol.

    The photo is the pump in question but from what i can see doesn't look that messed up really to me anyway but what do i know
    Attached Images Attached Images

  14. #13
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,472
    Hummm... ok... so I understand this right... the windows won't operate off the switches with the pump disconnected or won't open/close when you use the total closure system?

    I am surprised that the pump electrics directly influence the window operation but I do know that the central locking operates the total closure... (open/close windows using the key in the lock or by holding the lock/unlock on the key remote)

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  15. #14
    burns3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2011
    Posts
    223
    Quote Originally Posted by <tuffty/> View Post
    Hummm... ok... so I understand this right... the windows won't operate off the switches with the pump disconnected or won't open/close when you use the total closure system?

    I am surprised that the pump electrics directly influence the window operation but I do know that the central locking operates the total closure... (open/close windows using the key in the lock or by holding the lock/unlock on the key remote)

    <tuffty/>
    Windows did nothing at all with the pump unplugged but with the pump plugged in they operated fine using the drivers up and down window switch. The autolocking/unlocking button does nothing other than make the pump make a racket, when its plugged in that is and thats without the vaccumn bits plugged in just the three electrical connections back in.

  16. #15
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,472
    Bizarre... not what I would have expected at all... normally systems like this are fairly independent...

    Everyday is a school day

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  17. #16
    burns3's Avatar
    1st Gear

    Status
    Offline
    Join Date
    Jun 2011
    Posts
    223
    Just put the vaccumn pipes back on there and central locking is now working again from the inside door button but still nothing with the fob so think it needs sorting out to work with the car again. Wish it had just been the damn pump but ya win some ya lose some a guess.

 

 

Similar Threads

  1. a4 central locking pump faulty
    By Mike B in forum A4/S4 forum(B5 Chassis)
    Replies: 8
    Last Post: 18th April 2010, 17:07
  2. central locking pump impellers?
    By ian52 in forum A4/S4 forum(B5 Chassis)
    Replies: 3
    Last Post: 7th July 2008, 19:00
  3. facelift b5 central locking pump wanted
    By ian52 in forum A4/S4 forum(B5 Chassis)
    Replies: 30
    Last Post: 14th June 2008, 20:44
  4. Wiring diagram for 1997 A4 Central Locking Pump?
    By clfletch in forum General Technical / How To
    Replies: 5
    Last Post: 4th April 2007, 21:27
  5. Central Locking Pump - Shattered Impeller - Audi A4
    By OOBlinkOO in forum A4/S4 forum(B5 Chassis)
    Replies: 4
    Last Post: 15th November 2006, 23:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO