AH FabricationsSky Insurance
Results 1 to 7 of 7
  1. #1
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    17

    ABS pump faulty???

    hi all. I've had my abs light on since I've owned the car, I had it plugged in today and its saying I need to replace my abs module??? But my abs Is working fine?? Any suggestions what it could be or does it generally need replacing?? As my mot is due at the end of the month...cheers

  2. # ADS
    ADS
    Join Date
    Always
    Posts
    Many
     
  3. #2
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,439
    What was the actual fault code?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  4. #3
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    17
    Hi mate, I have no idea I was just talking too him whilst the bloke was doing it and he said that.. Ile have to back and ask for the code

  5. #4
    kwistof's Avatar
    South East Events Moderator

    Status
    Offline
    Join Date
    Jun 2010
    Location
    SE Kent
    Posts
    2,249

    My Social Networking

    Follow kwistof On Twitter Visit kwistof's Youtube Channel Visit kwistof's Instagram Channel
    Hi Sean,

    If you have had your ABS light on since you bought the car then I would be very surprised if your ABS is working at all to be honest. Even says so in your S3 handbook IIRC. I had a lot of problems with the ABS module a couple of years ago....and the garage I used at the time ended up sending it away to get rebuild. Unfortunately mine was beyond repair though and had to get a new unit installed. Also I'm almost certain that if your ABS light is on whilst it is MOT'd then it would fail.

  6. #5
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    17
    Yeah i know that! It seem to work, when emergency stopping there's no skidding, just pulls up nicely! Theres no funny feelings or hidden noises going on! might be missing summit? How much did it cost you in the end? As need to get it tickled of my never ending to do list..

  7. #6
    <tuffty/>'s Avatar
    Badger 5 Edition

    Status
    Online
    Join Date
    Sep 2008
    Location
    Gloucestershire
    Posts
    15,439
    Fault code?

    <tuffty/>
    Silver 2001 AMK S3. Silver alcantara interior... now with added powarrrrrrrr, torques. VAGCOM + KII-USB. >> My build thread...

  8. #7
    Reverse Gear

    Status
    Offline
    Join Date
    Oct 2012
    Posts
    17
    I'm going back up there Tuesday morning. I will pm you and post the code on here

 

 

Similar Threads

  1. ABS pump faulty?????????
    By floyd 1.8 turbo in forum A4/S4 forum(B5 Chassis)
    Replies: 7
    Last Post: 8th September 2010, 08:44
  2. a4 central locking pump faulty
    By Mike B in forum A4/S4 forum(B5 Chassis)
    Replies: 8
    Last Post: 18th April 2010, 17:07
  3. abs pump wanted
    By ian52 in forum A4/S4 forum(B5 Chassis)
    Replies: 7
    Last Post: 24th March 2009, 19:58
  4. ABS Pump Control Unit
    By jitvv in forum A3/S3 Forum (8L Chassis)
    Replies: 1
    Last Post: 20th March 2007, 10:46
  5. 8L A3 ABS Pump Fault & Repair!
    By Tallpaul in forum VCDS (formerly VAG-COM) forum
    Replies: 0
    Last Post: 26th June 2006, 15:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Single Sign On provided by vBSSO

Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

Content Relevant URLs by vBSEO